AMD64 Docker CE & Bintray

    • OMV 4.x
    • Resolved
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • AMD64 Docker CE & Bintray

      In OMV GUI in Browser there is docker ce as package source missing but docker is installed and I run docker hello world successfull in console.

      when I try...
      apt-get update
      ... I am getting the following messages:


      W: The repository 'https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker {distribution} Release' does not have a Release file.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      E: Fehlschlag beim Holen von dl.bintray.com/openmediavault-…ts}/binary-amd64/Packages 404 Not Found

      My aim is to install docker that it is visible and upgradable in omv gui in browser.

      ***************************************************************************************************************************************************************************************
      I am running OMV 4.1.14-1 (Arrakis) on Linux kernel 4.18.0-0.bpo.1-amd64

      ***************************************************************************************************************************************************************************************
      when I try to actualize system in omv gui in browser I am getting messages:

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; apt-get update 2>&1' with exit code '100': Get:1 file:/var/cache/openmediavault/archives InReleaseIgn:1 file:/var/cache/openmediavault/archives InReleaseGet:2 file:/var/cache/openmediavault/archives ReleaseIgn:2 file:/var/cache/openmediavault/archives ReleaseGet:3 file:/var/cache/openmediavault/archives
      ..............
      all PackagesErr:26 dl.bintray.com/openmediavault-…developers/arrakis-docker {distribution}/{components} amd64 Packages 404 Not FoundIgn:27 dl.bintray.com/openmediavault-…developers/arrakis-docker {distribution}/{components} Translation-enIgn:28 dl.bintray.com/openmediavault-…developers/arrakis-docker {distribution}/{components} Translation-deIgn:29 dl.bintray.com/openmediavault-…developers/arrakis-docker {distribution}/{components} Translation-de_DEReading package lists...W: The repository 'https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker {distribution} Release' does not have a Release file.E: Failed to fetch dl.bintray.com/openmediavault-…ts}/binary-amd64/Packages 404 Not FoundE: Some index files failed to download. They have been ignored, or old ones used instead
      ***************************************************************************************************************************************************************************************

      regards and thanks
      Thorsten
    • There is no need to run anything from the cli always use the browser gui.

      As you have run hello world from the cli do the following apt-get remove docker docker-engine docker-ce docker.io

      Then from the gui OMV-Extras -> Docker CE enable this (this is the Docker CE repo) when finished go to Plugins and search for Docker, select the Docker plugin and click install, that's it.
      Raid is not a backup! Would you go skydiving without a parachute?
    • Thanks Geaves,

      "Then from the gui OMV-Extras -> Docker CE enable this (this is the Docker CE repo)"

      "In OMV GUI in Browser there is docker ce as package source missing"

      [b][i][/i]As written "Docker CE" is missing (so it is not just disabled) under OMV-Extras. It would be helpfull if you give me details that I can add "Docker CE" entry under OMV-Extras manually...
      Or do you have better idea?
      [/b]
    • null problemo :)

      output is:

      ii openmediavault 4.1.14-1 all openmediavault - The open network attached storage s olution
      ii openmediavault-apttool 3.5 all apt tool plugin for OpenMediaVault.
      ii openmediavault-autoshutdown 4.0.4 all OpenMediaVault AutoShutdown Plugin
      ii openmediavault-backup 4.0.4 all backup plugin for OpenMediaVault.
      ic openmediavault-docker-gui 4.0.1 all OpenMediaVault plugin for Docker
      ii openmediavault-duplicati 4.0 all openmediavault duplicati plugin
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-letsencrypt 3.4.5 all Generate free and valid SSL certificates for OMV
      ii openmediavault-luksencryption 3.0.3 all OpenMediaVault LUKS encryption plugin
      ii openmediavault-omvextrasorg 4.1.13 all OMV-Extras.org Package Repositories for OpenMediaVau lt
      ii openmediavault-rsnapshot 4.2.1 all OpenMediaVault rsnapshot backup plugin.
      ii openmediavault-sftp 3.1.6 all sftp server
      ii openmediavault-virtualbox 4.1.1 all VirtualBox plugin for OpenMediaVault.
      ii openmediavault-wakealarm 4.0 all wakealarm plugin for OpenMediaVault.
      ii openmediavault-webdav 4.0 all OpenMediaVault WebDAV plugin.
      ii openmediavault-wol 3.4.1 all OpenMediaVault WOL plugin
    • twinter wrote:

      no, I have no "Docker CE" entry so I need the manual details to add it by my own...
      You must have deleted it. Uninstall omv-extras and reinstall it.

      apt-get purge openmediavault-omvextrasorg
      wget -O - http://omv-extras.org/install | bash
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thank you both for helping omv beginner.
      I reinstalled omv-install and was able to install docker gui with message:
      Restarting engine daemon ...
      Cannot create socket to [localhost]:2812 -- Connection refused
      Fertig ...

      After Refreshing Browser with OMV GUI I am getting error:

      "The property 'apiPort' does not exist in the model 'conf.service.docker'."

      I read in forum and I commented out in config.xml file the following tags:
      apiPort, version, versionInfo, dockermntent, uuid, orgpath and destpath

      Now I am not getting any errors in omv gui :)

      Was it right to comment above things out in config.xml ???
    • twinter wrote:

      After Refreshing Browser with OMV GUI I am getting error:

      "The property 'apiPort' does not exist in the model 'conf.service.docker'."

      I read in forum and I commented out in config.xml file the following tags:
      apiPort, version, versionInfo, dockermntent, uuid, orgpath and destpath

      Now I am not getting any errors in omv gui

      Was it right to comment above things out in config.xml ???
      You shouldn't comment things out in that file. You should just remove the lines. I still don't know why you needed to do that. The plugin is supposed to remove that line.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Users Online 4

      4 Guests