Docker-gui error 3

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Docker-gui error 3

      I installed Docker-gui from web interface ,installed fine,but when i try to use it i get

      Error: "" - Code: 3


      Error #0:
      OMVModuleDockerException: Error: "" - Code: 3 in /usr/share/omvdocker/Utils.php:74
      Stack trace:
      #0 /usr/share/omvdocker/Utils.php(430): OMVModuleDockerUtil::doApiCall('http::/networks')
      #1 /usr/share/openmediavault/engined/rpc/docker.inc(1057): OMVModuleDockerUtil::getNetworkList()
      #2 [internal function]: OMVRpcServiceDocker->getNetworks(Array, Array)
      #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getNetworks', Array, Array)
      #5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'getNetworks', Array, Array, 1)
      #6 {main}




      Any ideas?

      The post was edited 2 times, last by x3m444 ().

    • Looks like it may not have completely installed and/or the service isn't running. Might need to clear your browser cache too.
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Not exactly the same problem but don't want to spawn another docker install topic.

      Got error during the install of openmediavault-docker-gui 4.1.1 from WebUI - guess some dependency check but I don't know how to fix it:
      dpkg: dependency problems prevent configuration of openmediavault-docker-gui:

      Reading package lists...
      Building dependency tree...
      Reading state information...
      The following additional packages will be installed:
      containerd.io docker-ce docker-ce-cli imagemagick-6-common libfftw3-double3
      liblcms2-2 liblqr-1-0 libmagickcore-6.q16-3 libmagickwand-6.q16-3
      libopenjp2-7 omvextras-common php-curl php-imagick php-symfony-class-loader
      php-symfony-polyfill-apcu php7.0-curl
      Suggested packages:
      libfftw3-bin libfftw3-dev liblcms2-utils libmagickcore-6.q16-3-extra
      Recommended packages:
      aufs-tools cgroupfs-mount | cgroup-lite pigz ghostscript gsfonts
      ttf-dejavu-core
      The following NEW packages will be installed:
      containerd.io docker-ce docker-ce-cli imagemagick-6-common libfftw3-double3
      liblcms2-2 liblqr-1-0 libmagickcore-6.q16-3 libmagickwand-6.q16-3
      libopenjp2-7 omvextras-common openmediavault-docker-gui php-curl php-imagick
      php-symfony-class-loader php-symfony-polyfill-apcu php7.0-curl
      0 upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
      Need to get 0 B/32.6 MB of archives.
      After this operation, 157 MB of additional disk space will be used.
      Selecting previously unselected package liblqr-1-0:armhf.
      (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 48641 files and directories currently installed.)
      Preparing to unpack .../00-liblqr-1-0_0.4.2-2+b2_armhf.deb ...
      Unpacking liblqr-1-0:armhf (0.4.2-2+b2) ...
      Selecting previously unselected package libfftw3-double3:armhf.
      Preparing to unpack .../01-libfftw3-double3_3.3.5-3_armhf.deb ...
      Unpacking libfftw3-double3:armhf (3.3.5-3) ...
      Selecting previously unselected package liblcms2-2:armhf.
      Preparing to unpack .../02-liblcms2-2_2.8-4+deb9u1_armhf.deb ...
      Unpacking liblcms2-2:armhf (2.8-4+deb9u1) ...
      Selecting previously unselected package libopenjp2-7:armhf.
      Preparing to unpack .../03-libopenjp2-7_2.1.2-1.1+deb9u2_armhf.deb ...
      Unpacking libopenjp2-7:armhf (2.1.2-1.1+deb9u2) ...
      Selecting previously unselected package imagemagick-6-common.
      Preparing to unpack .../04-imagemagick-6-common_8%3a6.9.7.4+dfsg-11+deb9u6_all.deb ...
      Unpacking imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u6) ...
      Selecting previously unselected package libmagickcore-6.q16-3:armhf.
      Preparing to unpack .../05-libmagickcore-6.q16-3_8%3a6.9.7.4+dfsg-11+deb9u6_armhf.deb ...
      Unpacking libmagickcore-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      Selecting previously unselected package libmagickwand-6.q16-3:armhf.
      Preparing to unpack .../06-libmagickwand-6.q16-3_8%3a6.9.7.4+dfsg-11+deb9u6_armhf.deb ...
      Unpacking libmagickwand-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      Selecting previously unselected package containerd.io.
      Preparing to unpack .../07-containerd.io_1.2.2-1_armhf.deb ...
      Unpacking containerd.io (1.2.2-1) ...
      Selecting previously unselected package docker-ce-cli.
      Preparing to unpack .../08-docker-ce-cli_5%3a18.09.1~3-0~debian-stretch_armhf.deb ...
      Unpacking docker-ce-cli (5:18.09.1~3-0~debian-stretch) ...
      Selecting previously unselected package docker-ce.
      Preparing to unpack .../09-docker-ce_5%3a18.09.1~3-0~debian-stretch_armhf.deb ...
      Unpacking docker-ce (5:18.09.1~3-0~debian-stretch) ...
      Selecting previously unselected package php-symfony-polyfill-apcu.
      Preparing to unpack .../10-php-symfony-polyfill-apcu_1.2.0-1_all.deb ...
      Unpacking php-symfony-polyfill-apcu (1.2.0-1) ...
      Selecting previously unselected package php-symfony-class-loader.
      Preparing to unpack .../11-php-symfony-class-loader_2.8.7+dfsg-1.3+deb9u1_all.deb ...
      Unpacking php-symfony-class-loader (2.8.7+dfsg-1.3+deb9u1) ...
      Selecting previously unselected package omvextras-common.
      Preparing to unpack .../12-omvextras-common_4.0.1_all.deb ...
      Unpacking omvextras-common (4.0.1) ...
      Selecting previously unselected package php7.0-curl.
      Preparing to unpack .../13-php7.0-curl_7.0.33-0+deb9u1_armhf.deb ...
      Unpacking php7.0-curl (7.0.33-0+deb9u1) ...
      Selecting previously unselected package php-curl.
      Preparing to unpack .../14-php-curl_1%3a7.0+49_all.deb ...
      Unpacking php-curl (1:7.0+49) ...
      Selecting previously unselected package php-imagick.
      Preparing to unpack .../15-php-imagick_3.4.3~rc2-2_armhf.deb ...
      Unpacking php-imagick (3.4.3~rc2-2) ...
      Selecting previously unselected package openmediavault-docker-gui.
      Preparing to unpack .../16-openmediavault-docker-gui_4.1.1_all.deb ...
      Unpacking openmediavault-docker-gui (4.1.1) ...
      Setting up imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u6) ...
      Setting up libopenjp2-7:armhf (2.1.2-1.1+deb9u2) ...
      Setting up containerd.io (1.2.2-1) ...
      Created symlink /etc/systemd/system/multi-user.target.wants/containerd.service → /lib/systemd/system/containerd.service.
      Setting up liblcms2-2:armhf (2.8-4+deb9u1) ...
      Setting up php7.0-curl (7.0.33-0+deb9u1) ...


      Creating config file /etc/php/7.0/mods-available/curl.ini with new version
      Setting up libfftw3-double3:armhf (3.3.5-3) ...
      Processing triggers for php7.0-fpm (7.0.33-0+deb9u1) ...


      >>> *************** Error ***************
      Bad Gateway
      <<< *************************************
      Setting up liblqr-1-0:armhf (0.4.2-2+b2) ...
      Processing triggers for libc-bin (2.24-11+deb9u3) ...
      Setting up php-symfony-polyfill-apcu (1.2.0-1) ...
      Processing triggers for systemd (232-25+deb9u6) ...
      Processing triggers for man-db (2.7.6.1-2) ...
      Processing triggers for openmediavault (4.1.17-1) ...
      Restarting engine daemon ...
      Setting up docker-ce-cli (5:18.09.1~3-0~debian-stretch) ...
      Setting up docker-ce (5:18.09.1~3-0~debian-stretch) ...


      Configuration file '/etc/default/docker'
      ==> File on system created by you or by a script.
      ==> File also in package provided by package maintainer.
      What would you like to do about it ? Your options are:
      Y or I : install the package maintainer's version
      N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
      The default action is to keep your current version.
      *** docker (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing package docker-ce (--configure):
      end of file on stdin at conffile prompt
      dpkg: dependency problems prevent configuration of openmediavault-docker-gui:
      openmediavault-docker-gui depends on docker-ce (>= 5:18.09); however:
      Package docker-ce is not configured yet.
      openmediavault-docker-gui depends on docker-ce (<< 5:18.10); however:
      Package docker-ce is not configured yet.


      dpkg: error processing package openmediavault-docker-gui (--configure):
      dependency problems - leaving unconfigured
      Setting up libmagickcore-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      Setting up php-curl (1:7.0+49) ...
      Setting up php-symfony-class-loader (2.8.7+dfsg-1.3+deb9u1) ...
      Setting up libmagickwand-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      Setting up omvextras-common (4.0.1) ...
      Setting up php-imagick (3.4.3~rc2-2) ...
      Processing triggers for libc-bin (2.24-11+deb9u3) ...
      Processing triggers for openmediavault (4.1.17-1) ...
      Updating file permissions ...
      Purging internal cache ...
      Restarting engine daemon ...
      Errors were encountered while processing:
      docker-ce
      openmediavault-docker-gui
      Primary: Odroid-HC2 (ARM) + Seagate 6TB HD, OMV 4.1.17, omv-extras 4.1.13
      Backup: Odroid-HC2 (ARM) + Seagate 4TB HDD at remote location via Duplicati(??)
    • apt-get update log from Putty

      root@OMV6:~# apt-get update
      Get:1 file:/var/cache/openmediavault/archives InRelease
      Ign:1 file:/var/cache/openmediavault/archives InRelease
      Get:2 file:/var/cache/openmediavault/archives Release
      Ign:2 file:/var/cache/openmediavault/archives Release
      Get:3 file:/var/cache/openmediavault/archives Packages
      Ign:3 file:/var/cache/openmediavault/archives Packages
      Get:4 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:4 file:/var/cache/openmediavault/archives Contents (deb)
      Get:5 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:5 file:/var/cache/openmediavault/archives Contents (deb)
      Get:3 file:/var/cache/openmediavault/archives Packages
      Ign:3 file:/var/cache/openmediavault/archives Packages
      Get:4 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:4 file:/var/cache/openmediavault/archives Contents (deb)
      Get:5 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:5 file:/var/cache/openmediavault/archives Contents (deb)
      Get:3 file:/var/cache/openmediavault/archives Packages
      Ign:3 file:/var/cache/openmediavault/archives Packages
      Get:4 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:4 file:/var/cache/openmediavault/archives Contents (deb)
      Get:5 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:5 file:/var/cache/openmediavault/archives Contents (deb)
      Get:3 file:/var/cache/openmediavault/archives Packages
      Ign:3 file:/var/cache/openmediavault/archives Packages
      Get:4 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:4 file:/var/cache/openmediavault/archives Contents (deb)
      Get:5 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:5 file:/var/cache/openmediavault/archives Contents (deb)
      Get:3 file:/var/cache/openmediavault/archives Packages
      Ign:3 file:/var/cache/openmediavault/archives Packages
      Get:4 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:4 file:/var/cache/openmediavault/archives Contents (deb)
      Get:5 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:5 file:/var/cache/openmediavault/archives Contents (deb)
      Get:3 file:/var/cache/openmediavault/archives Packages [1,103 B]
      Get:4 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:4 file:/var/cache/openmediavault/archives Contents (deb)
      Get:5 file:/var/cache/openmediavault/archives Contents (deb)
      Ign:5 file:/var/cache/openmediavault/archives Contents (deb)
      Get:6 ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease [15.9 kB]
      Hit:7 packages.openmediavault.org/public arrakis InRelease
      Hit:8 security.debian.org stretch/updates InRelease
      Ign:13 dl.bintray.com/openmediavault-plugin-developers/arrakis stretch InRelease
      Hit:14 download.docker.com/linux/debian stretch InRelease
      Ign:15 dl.bintray.com/openmediavault-…developers/arrakis-docker stretch InRelease
      Hit:16 openmediavault.github.io/packages arrakis InRelease
      Ign:10 cdn-fastly.deb.debian.org/debian stretch InRelease
      Hit:17 dl.bintray.com/openmediavault-plugin-developers/arrakis stretch Release
      Hit:11 cdn-fastly.deb.debian.org/debian stretch-updates InRelease
      Hit:12 cdn-fastly.deb.debian.org/debian stretch-backports InRelease
      Hit:9 apt.armbian.com stretch InRelease
      Hit:18 cdn-fastly.deb.debian.org/debian stretch Release
      Ign:6 ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease
      Hit:19 dl.bintray.com/openmediavault-…developers/arrakis-docker stretch Release
      Fetched 15.9 kB in 4s (3,552 B/s)
      Reading package lists... Done
      W: GPG error: ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3028C3C96AD57103
      W: The repository 'http://ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease' is not signed.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      W: Target Packages (main/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (main/Contents-armhf) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (main/Contents-all) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (contrib/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (contrib/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (contrib/Contents-armhf) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (contrib/Contents-all) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (non-free/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (non-free/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (non-free/Contents-armhf) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (non-free/Contents-all) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (main/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (main/Contents-armhf) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (main/Contents-all) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (contrib/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (contrib/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (contrib/Contents-armhf) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (contrib/Contents-all) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (non-free/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Packages (non-free/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (non-free/Contents-armhf) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1
      W: Target Contents-deb (non-free/Contents-all) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1


      Running OMV 4.1.17-1 on Odroid HC2, omvextrasorg 4.1.13, stable omv-extras.org repo and Docker CE repo are enabled under OMV-Extras menu.
      Any help is appreciated, thanks!
      Primary: Odroid-HC2 (ARM) + Seagate 6TB HD, OMV 4.1.17, omv-extras 4.1.13
      Backup: Odroid-HC2 (ARM) + Seagate 4TB HDD at remote location via Duplicati(??)
    • PWSteal wrote:

      /etc/apt/sources.list
      Remove the backports line from /etc/apt/sources.list and then do apt-get update followed by apt-get -f install
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • PWSteal wrote:

      W: GPG error: ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3028C3C96AD57103
      and remove the ppa, if you want to avoid this warning
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • x3m444 wrote:

      docker network interface should be shown in openmediavault-gui in network interfaces?
      No. It should show up on the dashboard network information because it has an IP address but it shouldn't be in the network setup tab.
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      remove the backports line from /etc/apt/sources.list and then
      apt-get update
      apt-get -f install openmediavault-docker-gui

      via Putty worked for me, thanks!

      Also there was a dialog:

      Configuration file '/etc/default/docker'
      ==> File on system created by you or by a script.
      ==> File also in package provided by package maintainer.
      What would you like to do about it ? Your options are:
      Y or I : install the package maintainer's version
      N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
      The default action is to keep your current version.
      *** docker (Y/I/N/O/D/Z) [default=N] ? y


      plugin installation via OMV GUI goes in auto mode and selects N (default), I chose Y in Putty, Docker plugin now is in the list at OMV GUI and no errors pop-ups.
      Primary: Odroid-HC2 (ARM) + Seagate 6TB HD, OMV 4.1.17, omv-extras 4.1.13
      Backup: Odroid-HC2 (ARM) + Seagate 4TB HDD at remote location via Duplicati(??)
    • well..back to my problem :)
      i installed omv4 on usb to see if is working out of the box docker plugin
      well,is working
      if i am not wrong..i hope i am not,only thing i ve changed betwen these 2 instalations was curl
      one,on working system shows me
      curl 7.52.1 (x86_64-pc-linux-gnu) libcurl/7.52.1 OpenSSL/1.0.2q zlib/1.2.8 libidn2/0.16 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp scp sftp smb smbs smtp smtps telnet tftp Features: AsynchDNS IDN IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz TLS-SRP HTTP2 UnixSockets HTTPS-proxy PSL
      and the one wich isn t working is
      curl 7.63.0 (x86_64-pc-linux-gnu) libcurl/7.63.0 OpenSSL/1.0.2q zlib/1.2.8 librtmp/2.3Release-Date: 2018-12-12Protocols: dict file ftp ftps gopher http https imap imaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp Features: AsynchDNS IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP UnixSockets HTTPS-proxy

      can curl version/features affect omv web interface or i am wrong..?