Encountering error with running Plex on Docker Repo, Rock64

    • Encountering error with running Plex on Docker Repo, Rock64

      Hi, guys.
      I'm running errors with Plex Docker Repo. Basically, I setup according with the video in the forum. The error show:

      standard_init_linux.go:190: exec user process caused "exec format error"

      While I'm runing OMV 4.1.16-2 on Rock64. So it should be arm64 architecture, right? Still, there's only one docker image file for Plex server I can find under Docker images Repo tab.

      Appreciate it very much! If you guys can help a little bit.... :S
    • Sorry, Tkaiser.
      I burnt the new image into SD Card, which is :stretch-openmediavault-rock64-0.7.8-1061-arm64.img. And updated it to the lastest.

      dpkg command shows the architecture as below:


      root@rock64:~# dpkg --print-architecture
      arm64
      root@rock64:~#


      still I've got the same error msg when deploying Plex image with Docker. "standard_init_linux.go:190: exec user process caused "exec format error"

      Actually when I was trying other Docker images, I mostly got the exact same error message as above, e.g. Glances - vimagick/glances


      if anyone could give a hint or something. Appreciate it very much! ||
    • siemens_wolf wrote:

      Source Code

      1. root@rock64:~# dpkg --print-architecture
      2. arm64
      You need arm64 Dockers. Neither x64 nor armhf will x64 won't work for you. BTW: there is a search function at the upper right, simply go to the main forum view and enter the error message you got there (standard_init_linux.go:190: exec user process caused "exec format error).

      The post was edited 1 time, last by tkaiser ().

    • tkaiser wrote:

      siemens_wolf wrote:

      Source Code

      1. root@rock64:~# dpkg --print-architecture
      2. arm64
      You need arm64 Dockers. Neither x64 nor armhf will work for you. BTW: there is a search function at the upper right, simply go to the main forum view and enter the error message you got there (standard_init_linux.go:190: exec user process caused "exec format error).
      Thanks for your kindly support, Thkaiser. It really helps! I'll do the search later on before posting anything.

      BTW, is there anyway to easily identify Docker images whether they are for arm64 or not. Don't have any clue, just got to try one by one.....
    • tkaiser wrote:

      Nefertiti wrote:

      Well my version of lsioarmhf/plex is working perfect for me on rockpro64 in arm64 architecture!
      Thanks for the correction. But would it work the other way around (armhf OMV version running arm64 Dockers)? IMO to put it simple: Take care about the architecture of your OS and choose same Dockers.
      I would not dare to correct a master. I just mentioned what it is working for me. The last time I looked I did not find any arm64 docker for plex and since then the present one is OK I did not want to fix something witch is not broken.
    • There are no arm64 plex binaries yet. I am also fairly certain armhf dockers will run on arm64 systems even if the host doesn't have armhf architecture enabled. A lot of arm64 docker images are also called aarch64.
      omv 4.1.19 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!