Plex direct play keeps buffering / stuttering

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex direct play keeps buffering / stuttering

      I am using Plex media server (Version 1.12.1.4885) on OMV 4.1.17-1 Arrakis (on RockPro64) connected via ethernet (500Mbps connection)/ HDD plugged in via SATA. The setup was built recently and worked flawlessly for a week.

      Since today every movie i tried playing off plex be it on my Samsung Smart Tv / via the mobile app / streaming to Chromecast nothing seems to work. Playing the movies on my windows computer via VLC /win media player have no issues.

      The movie starts playing and after couple of minutes gets stuck with the loading/busy sign and does not resume.. Tried uninstalling / reinstalling the plex plugin , and setting up all database / libraries fresh and analyising etc and still facing the same issue.

      how should i resolve this , ive tried all the formats available in my library and all are having the same issue , checked the plex dashboard to see if the movies are being transcoded but its confirmed that they are being direct played.

      Spent the whole day figuring out if there is a solution ?

      Need some help pls..
      Images
      • OMV system info.PNG

        32.96 kB, 708×492, viewed 40 times
      • dashboard.PNG

        269.01 kB, 422×488, viewed 20 times

      The post was edited 1 time, last by denver2020 ().

    • As you describe it it would seem that there is some problem with how you connect to the TV. In what way does that differ from how you connect to your PC?

      One obvious problem could be that you use a slow WiFi connection to the TV. That might be fixed by upgrading your WiFi network or reconfiguring it. Possibly moving APs/routers/repeaters. However this has nothing to do with OMV.
      OMV 4, 5 x ODROID HC2, 2 x 12TB, 2 x 8 TB, 1 x 500 GB SSD, GbE, WiFi mesh
    • Just to clarify. You can stream the media fine from plex to the PC, but not from plex to the TV?

      If that is the case then there should be nothing wrong with the server or plex. The connection to the TV should be the problem. Check/swap cables and switches. And if possible reduce the length and number of cables/switches.
      OMV 4, 5 x ODROID HC2, 2 x 12TB, 2 x 8 TB, 1 x 500 GB SSD, GbE, WiFi mesh
    • Plex direct play keeps buffering / stuttering

      How is your chrome cast connected? Is it Wi-Fi or Ethernet?
      I’ve always found buffering issues with plex and wifi enabled tvs (eg. For bluray remuxes).
      Also sometimes the tv doesn’t have all the correct decoders (I’ve had better success with Apple TV or raspberry pi over Ethernet ).
    • hi Chromecast is on wifi.. after several attempts (knowing that similar setup worked before without buffering, I decided to flash OMV fresh on my boot and redo the whole setup... and plex is surprisingly working fine again... on Chromecast, TV and all devices... i can't seem to understand what went wrong with my earlier setup... will keep using and post if I face the issue again.

      appreciate the tips :)