Failed Docker installation on a fresh OMV 4

    • OMV 4.x
    • Looks like the docker repo isn't enabled. What is the output of apt-get update
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Looks like the docker repo isn't enabled. What is the output of apt-get update
      Display Spoiler
      Get:1 file:/var/cache/openmediavault/archives InRelease
      Ign:1 file:/var/cache/openmediavault/archives InRelease
      Get:2 file:/var/cache/openmediavault/archives Release
      Ign:2 file:/var/cache/openmediavault/archives Release
      Err:3 ftp.dk.debian.org/debian stretch InRelease
      Temporary failure resolving 'ftp.dk.debian.org'
      Err:4 security.debian.org/debian-security stretch/updates InRelease
      Temporary failure resolving 'security.debian.org'
      Err:5 httpredir.debian.org/debian stretch-backports InRelease
      Temporary failure resolving 'httpredir.debian.org'
      Err:6 packages.openmediavault.org/public arrakis InRelease
      Temporary failure resolving 'packages.openmediavault.org'
      Err:7 ftp.dk.debian.org/debian stretch-updates InRelease
      Temporary failure resolving 'ftp.dk.debian.org'
      Get:8 file:/var/cache/openmediavault/archives Packages
      Ign:8 file:/var/cache/openmediavault/archives Packages
      Get:9 file:/var/cache/openmediavault/archives Translation-en
      Ign:9 file:/var/cache/openmediavault/archives Translation-en
      Get:10 file:/var/cache/openmediavault/archives Translation-en_US
      Ign:10 file:/var/cache/openmediavault/archives Translation-en_US
      Get:8 file:/var/cache/openmediavault/archives Packages
      Ign:8 file:/var/cache/openmediavault/archives Packages
      Get:9 file:/var/cache/openmediavault/archives Translation-en
      Ign:9 file:/var/cache/openmediavault/archives Translation-en
      Get:10 file:/var/cache/openmediavault/archives Translation-en_US
      Ign:10 file:/var/cache/openmediavault/archives Translation-en_US
      Get:8 file:/var/cache/openmediavault/archives Packages
      Ign:8 file:/var/cache/openmediavault/archives Packages
      Get:9 file:/var/cache/openmediavault/archives Translation-en
      Ign:9 file:/var/cache/openmediavault/archives Translation-en
      Get:10 file:/var/cache/openmediavault/archives Translation-en_US
      Ign:10 file:/var/cache/openmediavault/archives Translation-en_US
      Get:8 file:/var/cache/openmediavault/archives Packages
      Ign:8 file:/var/cache/openmediavault/archives Packages
      Get:9 file:/var/cache/openmediavault/archives Translation-en
      Ign:9 file:/var/cache/openmediavault/archives Translation-en
      Get:10 file:/var/cache/openmediavault/archives Translation-en_US
      Ign:10 file:/var/cache/openmediavault/archives Translation-en_US
      Get:8 file:/var/cache/openmediavault/archives Packages
      Ign:8 file:/var/cache/openmediavault/archives Packages
      Get:9 file:/var/cache/openmediavault/archives Translation-en
      Ign:9 file:/var/cache/openmediavault/archives Translation-en
      Get:10 file:/var/cache/openmediavault/archives Translation-en_US
      Ign:10 file:/var/cache/openmediavault/archives Translation-en_US
      Get:8 file:/var/cache/openmediavault/archives Packages [1,971 B]
      Get:9 file:/var/cache/openmediavault/archives Translation-en
      Ign:9 file:/var/cache/openmediavault/archives Translation-en
      Get:10 file:/var/cache/openmediavault/archives Translation-en_US
      Ign:10 file:/var/cache/openmediavault/archives Translation-en_US
      Err:11 dl.bintray.com/openmediavault-plugin-developers/arrakis stretch InRelease
      Could not resolve host: dl.bintray.com
      Err:12 openmediavault.github.io/packages arrakis InRelease
      Could not resolve host: openmediavault.github.io
      Err:13 dl.bintray.com/openmediavault-…developers/arrakis-docker stretch InRelease
      Could not resolve host: dl.bintray.com
      Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f0abcaea7b8>
      Traceback (most recent call last):
      File "/usr/lib/python3.5/weakref.py", line 117, in remove
      TypeError: 'NoneType' object is not callable
      Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f0abcaea7b8>
      Traceback (most recent call last):
      File "/usr/lib/python3.5/weakref.py", line 117, in remove
      TypeError: 'NoneType' object is not callable
      Reading package lists... Done
      W: Failed to fetch ftp.dk.debian.org/debian/dists/stretch/InRelease Temporary failure resolving 'ftp.dk.debian.org'
      W: Failed to fetch security.debian.org/debian-sec…stretch/updates/InRelease Temporary failure resolving 'security.debian.org'
      W: Failed to fetch ftp.dk.debian.org/debian/dists/stretch-updates/InRelease Temporary failure resolving 'ftp.dk.debian.org'
      W: Failed to fetch dl.bintray.com/openmediavault-…s/dists/stretch/InRelease Could not resolve host: dl.bintray.com
      W: Failed to fetch dl.bintray.com/openmediavault-…r/dists/stretch/InRelease Could not resolve host: dl.bintray.com
      W: Failed to fetch httpredir.debian.org/debian/di…retch-backports/InRelease Temporary failure resolving 'httpredir.debian.org'
      W: Failed to fetch packages.openmediavault.org/public/dists/arrakis/InRelease Temporary failure resolving 'packages.openmediavault.org'
      W: Failed to fetch openmediavault.github.io/packages/dists/arrakis/InRelease Could not resolve host: openmediavault.github.io
      W: Some index files failed to download. They have been ignored, or old ones used instead.
    • You need to fix your DNS. See problem #6 here -Solutions to common problems
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Joining the problem my self. Tried on a PC and XU4 and on both I have the same problem. At first I thought is my new XU4 but did a fresn install on the PC and have the same problem. Not sure but can be one of the new updates on the OS ( on update menagement) as this problem is related only to docker , everything else working normal.
      For now ( first setup)
      Gygabite G1 Sniper mobo
      Intel I7 960 quad core
      Asus AMD R5 230 video card
      10Gtek® Intel 82576 Chip Gigabit Ethernet Converged Network Adapter (NIC), Dual RJ45 Copper Ports, PCI Express 2.0 X 1
      12GB DDR3 @1600
      32GB SSD for OMV system
      2 x 3TB 3.5" HDD
      1 X 1TB 2.5" HDD
      Corsair case and Zetec 650W PSU

      Runing latest versio ( stable )
    • Finally working........with help from other users on a different thread

      The steps worked for me
      1. Add 1.1.1.1 to DNS in network interface

      2. Make sure plugin is not instaled , if it is just uninstall and refresh your browser ( and clear cache)

      3.
      apt-get purge docker-ce



      4.
      dpkg -l | grep openm

      and make sure no docker-gui listed


      5. If docker-gui still on the output file

      rm /var/lib/dpkg/info/openmediavault-docker-gui.postrm

      and then


      apt-get purge openmediavault-docker-gui



      Check again that docker-gui is gone

      6. After no docker-gui on the output use
      wget -O - omv-extras.org/install | bash



      7. Enable docker on web-gui/omv-extras

      8.
      apt-get install docker-ce



      9. Now you can install the plugin from plugins


      Thanks to @ryecoaaron
      Thread Docker fix in case this not working for you or I missed something


      For now ( first setup)
      Gygabite G1 Sniper mobo
      Intel I7 960 quad core
      Asus AMD R5 230 video card
      10Gtek® Intel 82576 Chip Gigabit Ethernet Converged Network Adapter (NIC), Dual RJ45 Copper Ports, PCI Express 2.0 X 1
      12GB DDR3 @1600
      32GB SSD for OMV system
      2 x 3TB 3.5" HDD
      1 X 1TB 2.5" HDD
      Corsair case and Zetec 650W PSU

      Runing latest versio ( stable )
    • razvanrudy wrote:

      Finally working........with help from other users on a different thread

      The steps worked for me
      1. Add 1.1.1.1 to DNS in network interface

      2. Make sure plugin is not instaled , if it is just uninstall and refresh your browser ( and clear cache)

      3.
      apt-get purge docker-ce


      4.
      dpkg -l | grep openm

      and make sure no docker-gui listed


      5. If docker-gui still on the output file

      rm /var/lib/dpkg/info/openmediavault-docker-gui.postrm

      and then


      apt-get purge openmediavault-docker-gui


      Check again that docker-gui is gone

      6. After no docker-gui on the output use
      wget -O - omv-extras.org/install | bash


      7. Enable docker on web-gui/omv-extras

      8.
      apt-get install docker-ce


      9. Now you can install the plugin from plugins


      Thanks to @ryecoaaron
      Thread Docker fix in case this not working for you or I missed something



      THANK YOU :) !! Worked !!
    • Users Online 2

      2 Guests