Unstable ethernet with athos ar8151

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Unstable ethernet with athos ar8151

      New

      Hi,

      I have started to build a NAS using an old pc with the latest open media vault.
      Went through the install without any problems. Found enough documentation to set omv properly.

      Only problem is my ethernet connection, it works at boot but stops working after a while using it: it remains working long enough to go through the install but link goes down as soon as i try to download bigger files.
      Hardware is:
      Asrock 880GMH U3S3 with athos ar8151 chipset for network.

      I’ve been trying everything i could find over the various linux forums to get it to work (and there seems to be a lot pf problem with that chipset!) but haven’t succeeded yet.
      I have a basic knowledge of linux and am able to play around a little but i have reached my limits here :S

      Can anyone help me?
    • New

      I am connected to my internet provider’s basic router. (French internet provider called FREE)
      For the files size it depends, For example the downloading during omv install goes ok most of the time (worst i try 2 or 3 times before it works)
      Downloading linux header goes fine, but when i run apt-get install emacs for example it starts but hangs during the installation. When ftp’ing a movie (700Mb) from another pc it hangs randomly after about 100Mb.
    • New

      Shoguzz wrote:

      When ftp’ing a movie (700Mb) from another pc it hangs randomly after about 100Mb.

      This setup is broken. :)

      In case you have a free PCIe slot (single PCIe lane is sufficient) you can try to add another NIC but I would also look at the Ethernet cable and also your router (last time I visited a friend in France we had similar issues with his Freebox -- disclaimer: that was two years ago and I don't remember which version of the box he had back then).

      In case you're able to run iperf3 between two hosts on your local network this would be interesting since iperf3 also reports retransmits...
    • New

      Thanks, I’ll check all that tonight when i get back home.
      The router i use is the freebox mini.
      I currently don’t have a free pcie slot (sata extender card in place) but i can get rid of two disks to make room.
      Any suggestions to what card i should get for a plug and play, “problem free” installation?
      Would Standard pci slot for extra nic be good enough?
    • New

      Shoguzz wrote:

      The router i use is the freebox mini

      Gigabit Switch inside (as usual with everything sold within the last 5 years. Hubs have been declared deprecated already in 2011 by IEEE, back then it was already hard to find hub chips since switch ICs were that inexpensive and since hubs are limited to 100 Mbits/sec no ISP will rely on such outdated LAN tech when internet access speeds can and will exceed 100 Mbits/sec).

      I would test with iperf3 first as already suggested: iperf.fr/iperf-download.php#windows

      On OMV you need to add the non-free repo and then simply do a sudo apt update and then sudo apt install iperf3. Please post performance numbers and count of retransmits. And if you did not already exchange network cables I would try this in parallel to testing.

      If it's about a replacement I would most probably search for a PCIe card based on Intel 82574L (or maybe RTL8111G or RTL8111H if adventurous).
    • New

      Well so i wanted to try all that but tonight omv comes up with the “no network interface(s) available” message instead of an ip address ||
      I reinstalled twice, it has no problems downloading packages during the install but it always comes up with this message after reboot...
      Strangely enough, i never had trouble having network working at least for a few minutes before
    • New

      Ok i’m back at it.
      Still no network.
      Ip a command gives: enp3s0 [...] state DOWN
      Tried omv-firstaid to configure network:
      “ERROR: Failed to execute command ‘export PATH=[...] with exit code ‘1’: cannot create socket to [localhost]:2812 — Connection refused
      Not sure what to do now!