Wake On Lan - WOL - Doesn't work reliable with autoshutdown

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wake On Lan - WOL - Doesn't work reliable with autoshutdown

      New

      Hello everyone!

      After setting everything up I am really happy with my OMV NAS.

      But there is one thing that doesn't work yet.

      I can wake up my NAS with a WOL Magic packet if I put it to sleep with command line command: systemctl suspend

      But: When the autoshutdown plugin suspends the NAS it is impossible to wake it up over ethernet. I have to press a button on the keyboard or the powerbutton to wake it up again.


      I am very new to the linux world so I think I need some help to figure out what’s wrong.

      Hardware Specs:
      Mainboard: Gigabyte H97N Wifi Mini ITX
      Ethernet: Onboard Intel GbE Ethernet Card
      CPU: Intel Celeron G1820

      Thank your very much in advance!
      Greetings from Germany
      Simon
    • New

      (Assuming you have wake-on-lan enabled in BIOS.)

      For wake-on-lan purposes, you don't need to use the autoshutdown plugin. Look under System, Power Management, in Scheduled Jobs Tab and click the Add button. (Type: Shutdown) If you setup a standard power off shutdown, wake-on-lan will work.

      Video Guides :!: New User Guide :!: Docker Guides :!: Pi-hole in Docker
      Good backup takes the "drama" out of computing.
      ____________________________________
      Primary: OMV 4.1.17, ThinkServer TS140, 12GB ECC, 16GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      OMV 4.1.17, Intel Server SC5650HCBRP, 32GB ECC, 16GB USB boot, UnionFS+SNAPRAID
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
    • New

      Hey, thank you for your answer!

      The problem ist: I don't know when to shutdown the system - sometimes I need the NAS for the whole day and sometimes only a few hours a week. So there are no fixed times for a sheduled shutdown.

      Autoshutdown puts the NAS to sleep when there is no Samba Connection and no connection via Port 443 (Seafile SSL Port).

      The Problem is, that I can not wake the system up via WOL anymore after that.

      But: WOL works if I use systemctl suspend (which I did for test purposes)


      I'm sorry that I can't explain it much better but feel free to ask any question.
      Thank you very much! :)
    • New

      I just loaded the autoshutdown plugin, for the first time, in a VM. (There's interesting possibilities there, for my use cases.)

      baron11146 wrote:

      The Problem is, that I can not wake the system up via WOL anymore after that.
      This makes sense because OMV is already powered on. Wake-on-lan is about a hardware power state, it's OS independent and is very similar to hitting the front power switch. Even if the OS is in a low power consumption state, since full power is already applied, there's nothing to wake up.

      That's not to say that the "magic wake up packet" couldn't be used to trigger reactivation of a suspended/hybernating OS.
      ____________________________________________________________________

      However, you do have the makings of a work around. Based on your stated usage ("all day" or "a few hours per week") if you put the command systemctl suspend in the command line entry of a Scheduled Task and set it to trigger, daily, at Mid-night (1:00AM?), the OS will suspend until you wake it up.
      Of course the same would apply to the standard shutdown command as well. (OMV is pretty fast in booting up.) This might result in some extra hours of being on, but the net effect would be very close to the same.

      Video Guides :!: New User Guide :!: Docker Guides :!: Pi-hole in Docker
      Good backup takes the "drama" out of computing.
      ____________________________________
      Primary: OMV 4.1.17, ThinkServer TS140, 12GB ECC, 16GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      OMV 4.1.17, Intel Server SC5650HCBRP, 32GB ECC, 16GB USB boot, UnionFS+SNAPRAID
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
    • New

      baron11146 wrote:

      The Problem is, that I can not wake the system up via WOL anymore after that.
      How do you tried to wake the nas? In the OMV network section there is an option to enable Wake-On-Lan. Have you checked that?
      In the Autoshutdown plugin in the General Settings there is also an option where different shutdown commands are selectable.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • New

      Thanks for your replies!

      WOL in OMV -> Network -> Interface is currently OFF. Also testet ON but it makes no difference.

      Autoshutdown shutdown command is set to "suspend".

      WOL in the bios is ebabeled, too.
      ethtool for the ethernet adapter shows the following - WOL is enabeled
      Do the other WOL setting "p u m g" make any sense for my usecase?

      Source Code

      1. root@NAS:~# ethtool eno1
      2. Settings for eno1:
      3. Supported ports: [ TP ]
      4. Supported link modes: 10baseT/Half 10baseT/Full
      5. 100baseT/Half 100baseT/Full
      6. 1000baseT/Full
      7. Supported pause frame use: No
      8. Supports auto-negotiation: Yes
      9. Advertised link modes: 10baseT/Half 10baseT/Full
      10. 100baseT/Half 100baseT/Full
      11. 1000baseT/Full
      12. Advertised pause frame use: No
      13. Advertised auto-negotiation: Yes
      14. Speed: 1000Mb/s
      15. Duplex: Full
      16. Port: Twisted Pair
      17. PHYAD: 1
      18. Transceiver: internal
      19. Auto-negotiation: on
      20. MDI-X: on (auto)
      21. Supports Wake-on: pumbg
      22. Wake-on: g
      23. Current message level: 0x00000007 (7)
      24. drv probe link
      25. Link detected: yes
      Display All
    • New

      wol p|u|m|b|a|g|s|d...
      Set Wake-on-LAN options. Not all devices support this. The argument to this option is a string of characters specifying which options to enable.
      p Wake on phy activity u Wake on unicast messages m Wake on multicast messages
      b Wake on broadcast messages
      a Wake on ARP
      g Wake on MagicPacket(tm)
      s Enable SecureOn(tm) password for MagicPacket(tm)
      d Disable (wake on nothing). This option clears all previous options.


      In your case: 'g': It seems the interface is currently configured for WOL by MagicPacket.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304