Help with WOL command

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Help with WOL command

      Hi, First of all, thanks to this awesome firmware that you build, i am totally happy with it.

      Sorry for bothering, but I jumped from a Lubuntu to OMV 3.x as my nas Server, and the WOL was working on my previous installation (same hardware) and now i am trying to send him some magic packet trough LAN, and its not working (either from sleep mode or shutdown state).

      * Enabled the WOL on the NIC
      * installed the OMV-Extras to install the backport Kernel, but saw that is not anymore on OMV 3.x
      * Did some testing using TCPdump to see if i see the packages, and I saw it (it was working before with previos firmware anyway)
      Im using 3.x cause i have some services issues with 4.x cause i am using AMD Processor...

      System Info:
      V: 3.0.99
      Proc: AMD Sempron 140 Processor
      Kernel: Linux 4.9.0.0.bpo.6-amd64


      Thanks you in advanced
    • Im Still digging, and found a command to know if the NIC indeed on the Debian is enabled, and it is... I have no clue...

      root@OMV:~# sudo ethtool eth0
      Settings for eth0:
      Supported ports: [ TP MII ]
      Supported link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Half 1000baseT/Full
      Supported pause frame use: No
      Supports auto-negotiation: Yes
      Advertised link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Half 1000baseT/Full
      Advertised pause frame use: Symmetric Receive-only
      Advertised auto-negotiation: Yes
      Link partner advertised link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Half 1000baseT/Full
      Link partner advertised pause frame use: Symmetric Receive-only
      Link partner advertised auto-negotiation: Yes
      Speed: 1000Mb/s
      Duplex: Full
      Port: MII
      PHYAD: 0
      Transceiver: internal
      Auto-negotiation: on
      Supports Wake-on: pumbg
      Wake-on: g
      Current message level: 0x00000033 (51)
      drv probe ifdown ifup
      Link detected: yes


      Thanks,
    • Hi Macom,

      I was working with Lubuntu with out any issue (on WOL), and since i am working with OMV (because the server itself is being used as NAS) I was not able to make this work.

      The server is receiving the magic packets (checked with tcpdump) but is like it does not activate when is on shutdown or sleep state either...

      I think that a good next step will be to try in a new hard drive the OMV 4.x and check if it works (OMV 4.x gave me some issues related with AMD processor do not remember if the web daemon did not start, or the system itself...)