Enable SATA port multiplier on Banana Pi

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Enable SATA port multiplier on Banana Pi

      hello everyone

      im on banana pi 1+ + JMB 321 port multiplier

      finally decided to update my old omv

      now i only see 1 sata drive that is attached to my sata multiplier at a time

      using putty

      nano /boot/boot.cmd

      at the end of the page it clearly says :

      If you want to use a SATA PM add "ahci_sunxi.enable_pmp=1" to bootargs above


      so i have edited to :

      .....$sb-storage.quirks=${usbstoragequirks} ${extraargs} ${extraboardargs} ahci_sunxi.enable_pmp=1 "

      but still nothing

      any suggestions ?
    • hooman008 wrote:

      at the end of the page it clearly says :

      If you want to use a SATA PM add "ahci_sunxi.enable_pmp=1" to bootargs above
      It also clearly says that you need to execute another command to create /boot/boot.scr. And then of course you also need to reboot since these settings are only loaded when the kernel starts.

      Please try the above and report back after the reboot including the output from sudo armbianmonitor -u
    • tkaiser wrote:

      hooman008 wrote:

      at the end of the page it clearly says :

      If you want to use a SATA PM add "ahci_sunxi.enable_pmp=1" to bootargs above
      It also clearly says that you need to execute another command to create /boot/boot.scr. And then of course you also need to reboot since these settings are only loaded when the kernel starts.
      Please try the above and report back after the reboot including the output from sudo armbianmonitor -u
      thank you for the reply , and how do i do that ?
      its a hobby for me so i dont know much about linux commands

      this is what i did in an attmeb to create the /boot/boot.scr

      mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr

      just added it at the bottom of the page

      this is the result of the command you have mentioned above : ix.io/1FjM

      The post was edited 1 time, last by hooman008 ().

    • tkaiser wrote:

      Let's stop here. You need to be aware of what you're doing otherwise this can be very dangerous. If you add random text to boot.cmd it won't compile any more. And the mkimage command I showed (and is already there as a comment) has to be executed in a shell
      well there is nothing important on these drives , but id like to get it working , i do appreciate if you guide me through it as im just doing it as a hobby
    • I managed to make it work for anyone els whom might face the same issue here what i did :


      activation of sata multiplier in OMV 4xx + banana pi + JMB 321

      in putty


      first use the command ===> nano /boot/boot.cmd



      inside ===> find the line that stars with [ setenv bootargs.... ] and at the end before " we add : ahci_sunxi.enable_pmp=1

      then control +x and then y and enter



      then on the main page we put in the command ===> mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr

      and enter

      then reboot

      -----------------------

      Use the command 'blkid' to see the hard drives show up