Docker and plex failed to transcode

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Docker and plex failed to transcode

      Hi

      Ok i have been asking over at the plex forums and have a tempo fix, but was advised to look for a permanent fix here.
      Here's my issue
      i have plex working all my data is showing and up to date.
      if i try to play music or movies i get: Conversion failed. The transcoder exited due to an error.

      In the plex forum i was advised to change noexec to exec in fstab on one of my media drives. i was also told this is a temp fix

      Here's how i setup plex
      under Volume and bind mount table i have /media set to /sharedfolders.
      This was the only way i could get plex to see my movies, MMA, kids Movies and music folders.
      All my media is spread over 3 drives.
      I have tried to add /media /movies, /media /movies2, /media /kids moves under Volume and bind mount table and so on but the container errors out. which closes the container and i have to re add plex.

      in the plex forum i was advised to ask,
      how to make the required changes to /etc/default/openmediavault and /etc/openmediavault/config.xml such that data drives are mounted exec.

      Thanks for any and all help.
    • Only necessary to remove noexec from the drive that has the Plex media server library on it (/config location when using the docker). This is where the transcoders are located. Not necessary to do on drives with only media on them.

      But in my case I removed noexec on all data drives anyway.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • Hi,
      I'm having the same error too.
      I already followed the guide and removed the noexec from every hdd where I have media or plex config folder.
      I still get this error:
      Error creating directory "/transcode/Transcode/Sessions/plex-transcode-jzs2bx03gmrjoxka4hbdg30r-989c59c5-8d63-4df8-af76-5b9ea4df5841": boost::filesystem::create_directories: Permission denied: "/transcode/Transcode/Sessions"

      This is my Plex configuration:


      This is the disk where I keetp the folder /config:
      /dev/sdc3 /srv/dev-disk-by-label-Applicazioni ext4 rw,relatime,discard,jqfmt=vfsv0,usrjquota=aquota.user,grpjquota=aquota.group 0 0

      What am I doing wrong? :(

      EDIT:
      in case someone else got this error too: I just put the /transcode folder into
      ./Config/Plex/Transcoding/Transcode
      Intel G4400 - Asrock H170M Pro4S - 8GB ram - Corsair VS350W - 2X6TB Seagate Ironwolf - 2x4TB WD RED
      OMV 4.1.17 - Kernel 4.18 backport 3 - omvextrasorg 4.1.2

      The post was edited 1 time, last by Blabla ().