[Solved] Samba Sparse File/Strict Allocat prob with smb.conf

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [Solved] Samba Sparse File/Strict Allocat prob with smb.conf

      Hey Folks,

      I'm new to Linux and OMV, so be gentle with me :)

      The problem seems simple enough. I'm trying to back up my Win7 HomePrem PC onto a VHD file stored on a share on my OMV box.
      I have a script that auto-mounts the VHD file as a drive letter, and the backup then kicks off as planned.

      All worked fine until yesterday. I noticed the file would not mount, and gave the known error "The version does not support this version of the file format'.
      This error is a known fault, and fixable by setting the option 'strict allocate' to Yes in the smb.conf.
      Problem was, I had set this option. But when I checked my /etc/samba/smb.conf, the option had disappeared.

      I re-entered the option, and disabled/enabled the SMB/CIFS service in OMV Web ui (It's the only way I know how!!)
      The option disappeared again from the smb.conf.

      I've since tried various different options, reboots etc, but no effect.

      So - am I doing something wrong here, or is it by design this option is not settable? Or am I missing something here?

      Thanks for any help!!

      The post was edited 1 time, last by David-V ().

    • Re: Samba Sparse File/Strict Allocate problem with smb.conf

      Where and how are you setting the strict allocate option?
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Re: Samba Sparse File/Strict Allocate problem with smb.conf

      Why are you editing files manually??? When you manually edit the files, it gets overwritten by the web interface. Just add it to the Extra options box for the share.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Re: Samba Sparse File/Strict Allocate problem with smb.conf

      ...or the global config.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: Samba Sparse File/Strict Allocate problem with smb.conf

      I would move the file to your windows box, edit it, and then move it back. That should reset any odd permissions on the file. If not, go to the directory where the VHDs are stored and compare the owner and permissions with the working files.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!