Execution failed Service collectd ?

    • Execution failed Service collectd ?

      Hello

      I receive mails from my OMV server with subject "monit alert -- Execution failed collectd" and this following content:

      Execution failed Service collectd
      Date: Sun, 16 Feb 2014 14:19:35 -0500
      Action: alert
      Host: NAS
      Description: failed to start

      Do you know what it is talking about ?

      Thanks,
      Chris
    • Re: Execution failed Service collectd ?

      collectd collects information about the system to produce the graphs (memory use, load, hard drive use, etc) that you find in the omv web interface. Are the graphs working?
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: Execution failed Service collectd ?

      Yes my graphs are working. The reason I asked is this is the second time I've received this alert this week, but if its simply data collection then I'll ignore it. Possibly its a time out issue as the i/o has been running pretty hot all week as I do the initial data copy over from my old NAS.

      Thanks!
    • Re: Execution failed Service collectd ?

      *** This is for Sadaukar. The graph database files are in different location in Kralizec ***

      service collectd stop
      rm -rf /var/lib/collectd/rrd/*
      service collectd start

      After it starts again you will not have graphs at first. It will take a bit to get some data points to begin creating the graphs.
    • Re: Execution failed Service collectd ?

      Thanks for the info Tekk and I apologize for my response times... my employer doesn't allow me a lot of personal time ;)

      I don't really use the statistical data all that much other than a "neato" feature, but as a linux junkie I'm curious why this would be failing. collectd runs as root, and all these files/dirs under /var/lib/collectd/rrd are owned/writable by root. If it was a permission issue I would expect to get alerts every time it ran, but the first alert was 2 days ago, and then again today.

      I should also point out this is a spankin brand new install as of Monday with two new drives and the mirror out of my old NAS. Tuesday I enabled Notifications and began an rsync copy from the remaining drive in the old NAS to OMV (which is still running!). I got a tonne of alerts on Tuesday but Wed and Thu were quiet until I got the second collectd alert today.
    • Re: Execution failed Service collectd ?

      You made an image from a vm. It had created database files for the disks on that vm. Then you restored the vm image to another machine. It is trying to get data points for the old disks still and they are no longer present. That is reason for the error and why you need to start fresh with collectd.
    • I have the same trouble but my graphs not work anymore, I'm in 1.12 Kralizec, what can I do?

      Source Code

      1. Execution failed Service collectd
      2. ate: Wed, 11 Feb 2015 06:16:48
      3. ction: alert
      4. Host:
      5. Description: failed to start Your faithful employee,Monit


      Source Code

      1. Does not exist Service collectd
      2. Date: Wed, 11 Feb 2015 06:18:49
      3. Action: restart
      4. Host:
      5. Description: process is not running Your faithful employee,Monit


      Source Code

      1. Execution failed Service collectd
      2. Date: Wed, 11 Feb 2015 06:19:20
      3. Action: alert Host:
      4. Description: failed to start
      5. Your faithful employee,Monit
      Images
      • Sin título.png

        18.24 kB, 1,130×171, viewed 372 times
      Lenovo Thinkcentre Tower M92p + HDD 120GB OS + 8 TB RAID5 (3x4TB HDD WD&Seagate)
      Debian Wheezy 7.8 64 bits + OMV 1.12 kralizec + 3.16 backport kernel

      Radxa Rock + NAND 8 GB OS + 1 TB HD Western Digital
      Debian Wheezy 7 ARM 32 bits + OMV 1.12 kralizec
    • Sorry I'm still sleep :D

      I'm not sure why collectd.conf was delete, someone knows why?

      I just create a collectd.conf and all works. Paste de code:

      Source Code

      1. ​Hostname "localhost"
      2. FQDNLookup true
      3. LoadPlugin syslog
      4. <Plugin syslog>
      5. LogLevel info
      6. </Plugin>
      7. LoadPlugin rrdcached
      8. <Plugin rrdcached>
      9. DaemonAddress "unix:/var/run/rrdcached.sock"
      10. DataDir "/var/lib/rrdcached/db/"
      11. CreateFiles true
      12. CollectStatistics true
      13. </Plugin>
      14. LoadPlugin unixsock
      15. <Plugin unixsock>
      16. SocketFile "/var/run/collectd.socket"
      17. SocketGroup "root"
      18. SocketPerms "0660"
      19. </Plugin>
      20. LoadPlugin cpu
      21. LoadPlugin df
      22. <Plugin df>
      23. # MountPoint "/"
      24. IgnoreSelected false
      25. </Plugin>
      26. LoadPlugin interface
      27. <Plugin interface>
      28. IgnoreSelected false
      29. </Plugin>
      30. LoadPlugin load
      31. LoadPlugin memory
      32. Include "/etc/collectd/thresholds.conf"
      Display All
      Lenovo Thinkcentre Tower M92p + HDD 120GB OS + 8 TB RAID5 (3x4TB HDD WD&Seagate)
      Debian Wheezy 7.8 64 bits + OMV 1.12 kralizec + 3.16 backport kernel

      Radxa Rock + NAND 8 GB OS + 1 TB HD Western Digital
      Debian Wheezy 7 ARM 32 bits + OMV 1.12 kralizec
    • subzero79 wrote:

      OMV has internal commands that recreate conf defaults in this case omv-mkconf collectd

      If you type in terminal omv-mkconf and press tab key it will give you all available scripts to configure system configurations


      Good to know, thank you @subzero79 :D
      Lenovo Thinkcentre Tower M92p + HDD 120GB OS + 8 TB RAID5 (3x4TB HDD WD&Seagate)
      Debian Wheezy 7.8 64 bits + OMV 1.12 kralizec + 3.16 backport kernel

      Radxa Rock + NAND 8 GB OS + 1 TB HD Western Digital
      Debian Wheezy 7 ARM 32 bits + OMV 1.12 kralizec
    • Hello!
      I´m newbie with OMV and this forum, my first post...
      Is these messages somehow related to this thread:

      "Feb 12 11:44:48 OBELIX collectd[2490]: rrdcached plugin: rrdc_update (/var/lib/rrdcached/db/localhost/df-root/df_complex-used.rrd, [1423734288:1076383744.000000], 1) failed with status -1.
      Feb 12 11:44:48 OBELIX collectd[2490]: Filter subsystem: Built-in target `write': Dispatching value to all write plugins failed with status -1."

      I just installed from ISO OMV1.9 and updated through webgui to1.12 and now these eror messages keeps coming and coming. IT seems that this is related to df command and collectd makes graphs of diskusage? how can i fix this? There are thousands of these error messages and after every few minutes system informs that theres a" software error" and kicks me out from webgui...
      Cheers, Flohha
    • Hi again!
      Thanks for fast reply but i´m afraid that same messages still keeps coming.. I added 4 wd red2tb disks and started to sync raid5. And again i got this "Software failure. Press left mouse button to continue. Session expired."
      And sync failed and it started to resync. And after few moments the same occurred. Theres something i´m doing wrong?
      HW: Asus C60M1-I, 8GB DDR3, 30GB ssd for OS and 4x 2TB WD reds for data.
      SW: OMV 1.12, new install.

      -Flohha
    • You probably still have the web interface set to timeout after 5 minutes. It shouldn't stop the sync though. Set session timeout to 0 in the Web Administration tab if you don't want it to timeout.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!