[Solved] owncloud download large files aborted

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [Solved] owncloud download large files aborted

      Hello all,

      I'm facing an issue downloading large files with owncloud plugin.

      small files works fine (pictures for instance)

      I'm trying to share a 600Mo zip file and after a while connection aborts.

      apache2 openmediavault-webgui_error.log says:

      Source Code

      1. mod_fcgid: read data timeout in 300 seconds, referer: https://
      2. Premature end of script headers: index.php, referer: https://

      I've found this solution heath-whyte.info/david/compute…id-timeouts-and-downloadsbut I'm not able to find the right config file where increase the FcgidBusyTimeout value.

      By the way if someone knows how increase value to make owncloud able to zip big files; right know it says:

      Source Code

      1. Selected files too large to generate zip file.
      2. Download the files in smaller chunks, seperately or kindly ask your administrator.

      Many thanks in advance,


      The post was edited 1 time, last by Guerito73 ().

    • Re: owncloud download large files aborted

      Does it abort after a specific time or after a specific amount of data?
      Looks like upload_max_filesize would fix that problem.
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • Re: owncloud download large files aborted

      I think you will have to add something like this to the owncloud.conf, default.conf and default-ssl.conf (these 2 file are the virtual hosts). Then restart apache.
      Those configs are in these folders.


      Anyway, I let you mess with that and give us feedback. If it does not work I try to look at this later.

      Hah, you beat me. You are on right track. It is apache issue. Good Luck..... :D
    • Re: owncloud download large files aborted

      Okay I've fixed it.

      After a test in httpd.conf, I've modified in /etc/apache2/openmediavault-webgui.d


      Source Code

      1. 1 <IfModule mod_alias.c>
      2. 2 Alias /owncloud /var/www/owncloud/
      3. 3 <IfModule mod_fcgid.c>
      4. 4 FcgidBusyTimeout 259200
      5. 5 FcgidIOTimeout 600
      6. 6 # other Fcgid directives
      7. 7 </IfModule>
      8. 8 <Directory /var/www/owncloud/>
      9. 9 Options FollowSymLinks
      10. 10 <FilesMatch \.php$>
      11. 11 FcgidWrapper /var/www/owncloud/php-fcgi .php
      12. 12 SetHandler fcgid-script
      13. 13 Options +ExecCGI
      14. 14 </FilesMatch>
      15. 15 Order Allow,Deny
      16. 16 Allow from All
      17. 17 AllowOverride All
      18. 18 </Directory>
      Display All

      and default.conf

      Source Code

      1. 1 ServerName openmediavault-webgui
      2. 2 DocumentRoot /var/www/openmediavault
      3. 3 DirectoryIndex index.php
      4. 4 SuexecUserGroup openmediavault openmediavault
      5. 5 Alias /extjs/ /usr/share/javascript/extjs4/
      6. 6 Alias /images/ /var/www/openmediavault/images/
      7. 7 # Increase HTTP request header field
      8. 8 LimitRequestFieldSize 32768
      9. 9 # Set maximum HTTP request length to 25 MiB
      10. 10 FcgidMaxRequestLen 26214400
      11. 11 FcgidIOTimeout 14400
      12. 12 <Directory /var/www/openmediavault/>
      13. 13 Options FollowSymLinks
      14. 14 <FilesMatch \.php$>
      15. 15 FcgidWrapper /var/www/openmediavault/php-fcgi .php
      16. 16 SetHandler fcgid-script
      17. 17 Options +ExecCGI
      18. 18 </FilesMatch>
      19. 19 Order Allow,Deny
      20. 20 Allow from All
      21. 21 AllowOverride None
      22. 22 </Directory>
      23. 23 LogLevel warn
      Display All

      and it works :) I was able to nsuccessfully download 677Mo with my poor adsl connection yuhuu!!

      I will check now the upload of big file to check if I will be able to upload my pictures remotly during holidays