error when adding share to ftp (v.6)

    • error when adding share to ftp (v.6)

      Hi all,

      I am setting up my ftp service in v.6 of OMV.

      when i set up the service settings everything is fine, as soon as i add a shared folder and press apply i get the following message.

      Error #6000:
      exception 'OMVException' with message 'File contains invalid JSON (filename=/var/lib/openmediavault/fstab_tasks.json): ' in /usr/share/php/openmediavault/util.inc:263
      Stack trace:
      #0 /usr/share/php/openmediavault/module.inc(142): OMVJsonFile->read()
      #1 /usr/share/openmediavault/engined/module/fstab.inc(52): OMVModuleAbstract->execTasks('delete')
      #2 /usr/share/openmediavault/engined/rpc/config.inc(164): OMVModuleFsTab->stopService()
      #3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      #4 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #5 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      #6 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      #7 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      #8 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #9 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      #10 /usr/sbin/omv-engined(495): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      #11 {main}


      am i doing something wrong or is this a bug ?

      thanks

      DAn
    • Re: error when adding share to ftp (v.6)

      Source Code

      1. File: `sites'
      2. Size: 4096 Blocks: 8 IO Block: 4096 directory
      3. Device: 97fh/2431d Inode: 540803073 Links: 5
      4. Access: (2777/drwxrwsrwx) Uid: ( 0/ root) Gid: ( 100/ users)
      5. Access: 2014-06-25 12:45:56.278197091 +0100
      6. Modify: 2014-06-24 12:41:32.257216884 +0100
      7. Change: 2014-06-25 13:39:57.982122003 +0100
      8. Birth: -
      9. root@homeserver:/media/de54d6c1-f9f3-4cd3-a2c3-06d97c9196fe#
    • Re: error when adding share to ftp (v.6)

      sorry to push, but does anyone have any ideas on this one... i have now tried removing the proftp service and reinstalling it via the openmediavault package ... guess what ... same outcome as above.

      not sure what to do now as the FTP service is pretty important!

      thanks

      Dan
    • Re: error when adding share to ftp (v.6)

      Remove the file /var/lib/openmediavault/fstab_tasks.json. The problem currently occurs because of unknown behaviour. Issue is known but not identified and solved at the moment.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit