can't change permissions for directory

    • can't change permissions for directory

      Hi,

      what i want to do is have a directory that is not on the storage file system but in "/home/xxxxxxxx" so i can execute files in this folder and it needs to be accessible via FTP

      i already have made a new user named minecraft and a folder named minecraft in /home/.
      i used this command.

      Source Code

      1. sudo useradd ftp_user -p your_password -d /home/ftp -s /bin/false
      2. sudo passwd ftp_user


      after that i have applied chmod -R 771 to the folder.

      Source Code

      1. chmod -R 771 minecraft/


      and now i can connect to the ftp with the user minecraft but i cannot add or change any files.
      i use fillezilla to connect to the server, and this is the error that i get when i try to eddit the something in the folder.

      Source Code

      1. PASV
      2. Response: 227 Entering Passive Mode (192,168,0,203,226,100).
      3. Command: STOR test.sh
      4. Response: 550 test.sh: Toegang geweigerd
      5. Error: Critical file transfer error
    • Re: can't change permissions for directory

      i have enabled the passive ports annd changed them as in the guid and it is still not working.
      i can create a folder with the gui on the normal storage file system and that works fine.
      but it goes wrong when i try to change something in a folder that is on the system disk that i had to make using the cli.

      filezilla after the changes.

      Source Code

      1. Status: Connection established, waiting for welcome message...
      2. Response: 220 ProFTPD 1.3.3a Server (openmediavault) [::ffff:192.168.0.203]
      3. Command: USER minecraft
      4. Response: 331 Password required for minecraft
      5. Command: PASS ************
      6. Response: 230-Welcome !
      7. Response: 230 User minecraft logged in
      8. Command: SYST
      9. Response: 215 UNIX Type: L8
      10. Command: FEAT
      11. Response: 211-Features:
      12. Response: MDTM
      13. Response: MFMT
      14. Response: TVFS
      15. Response: UTF8
      16. Response: MFF modify;UNIX.group;UNIX.mode;
      17. Response: MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
      18. Response: LANG en-US*
      19. Response: SITE MKDIR
      20. Response: SITE RMDIR
      21. Response: SITE UTIME
      22. Response: SITE SYMLINK
      23. Response: REST STREAM
      24. Response: SIZE
      25. Response: 211 End
      26. Command: OPTS UTF8 ON
      27. Response: 200 UTF8 set to on
      28. Status: Connected
      29. Status: Retrieving directory listing...
      30. Command: PWD
      31. Response: 257 "/" is the current directory
      32. Command: TYPE I
      33. Response: 200 Type set to I
      34. Command: PASV
      35. Response: 227 Entering Passive Mode (192,168,0,203,55,22).
      36. Command: MLSD
      37. Response: 150 Opening ASCII mode data connection for MLSD
      38. Response: 226 Transfer complete
      39. Status: Directory listing successful
      40. Status: Starting upload of C:\Users\Dragon\AppData\Local\Temp\fz3temp-1\empty_file_yq744zm
      41. Command: PASV
      42. Response: 227 Entering Passive Mode (192,168,0,203,55,23).
      43. Command: STOR test.txt
      44. Response: 550 test.txt: Permission denied
      45. Error: Critical file transfer error
      46. Status: Starting upload of C:\Users\Dragon\AppData\Local\Temp\fz3temp-1\empty_file_yq744zm
      47. Command: PASV
      48. Response: 227 Entering Passive Mode (192,168,0,203,55,20).
      49. Command: STOR test.txt
      50. Response: 550 test.txt: Permission denied
      51. Error: Critical file transfer error
      Display All


      edit: when i do "ls -l myfolder" via ssh i get "total 0"
    • Re: can't change permissions for directory

      Source Code

      1. root@openmediavault:/home# stat minecraft/
      2. File: ‘minecraft/’
      3. Size: 4096 Blocks: 8 IO Block: 4096 map
      4. Device: 801h/2049d Inode: 3538948 Links: 2
      5. Access: (0755/drwxr-xr-x) Uid: ( 1004/minecraft) Gid: (65534/ nogroup)
      6. Access: 2014-07-16 16:06:15.987755327 +0200
      7. Modify: 2014-07-16 09:39:34.971814848 +0200
      8. Change: 2014-07-16 16:06:15.987755327 +0200
    • Re: can't change permissions for directory

      The ftp settings in the web interface.
      [IMG:http://i.imgur.com/HpD1x74.jpg]
      content of /etc/modprobe.d/options.conf

      Source Code

      1. options nf_conntrack_ftp ports=21,14100,14101,14102,14103,14104,14105


      content of /etc/modules

      Source Code

      1. # /etc/modules: kernel modules to load at boot time.
      2. #
      3. # This file contains the names of kernel modules that should be loaded
      4. # at boot time, one per line. Lines beginning with "#" are ignored.
      5. # Parameters can be specified after the module name.
      6. loop
      7. nf_conntrack_ftp


      edit: typos.

      The post was edited 2 times, last by niikhawod ().