Problem with UPS Plugin

    • Problem with UPS Plugin

      Hello,

      I have a Eaton 5S550I.
      My configuration don't seems to work.
      I have the following error when I Look in UPs tab :
      Failed to execute command 'upsc ups 2>&1': Error: Unknown UPS
      Erreur #4000:
      exception 'OMVException' with message 'Failed to execute command 'upsc ups 2>&1': Error: Unknown UPS' in /usr/share/openmediavault/engined/rpc/nut.inc:151
      Stack trace:
      #0 [internal function]: OMVRpcServiceNetworkUPSTools->getStats(NULL, Array)
      #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #2 /usr/share/php/openmediavault/rpc.inc(62): OMVRpcServiceAbstract->callMethod('getStats', NULL, Array)
      #3 /usr/sbin/omv-engined(495): OMVRpc::exec('Nut', 'getStats', NULL, Array, 1)
      #4 {main}

      In the configuration i have set two lines:
      [EATON5S]
      driver = usbhid-ups
      port = auto

      What's wrong ? In SSh an lsusb request show me that :
      Bus 002 Device 003: ID 0463:ffff MGE UPS Systems UPS

      Please, :| help me
    • Re: Problem with UPS Plugin

      bc installed but i've still same error:

      Erreur #4000:
      exception 'OMVException' with message 'Failed to execute command 'upsc ups 2>&1': Error: Unknown UPS' in /usr/share/openmediavault/engined/rpc/nut.inc:151
      Stack trace:
      #0 [internal function]: OMVRpcServiceNetworkUPSTools->getStats(NULL, Array)
      #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getStats', NULL, Array)
      #3 /usr/sbin/omv-engined(495): OMVRpc::exec('Nut', 'getStats', NULL, Array, 1)
      #4 {main}
    • Re: Problem with UPS Plugin

      I assume something is wrong with your configuration. Execute the following commands

      0.5.x:

      Source Code

      1. omv-mkconf nut
      2. service nut restart
      3. upsc ups


      0.6.x:

      Source Code

      1. omv-mkconf nut
      2. service nut-server restart
      3. service nut-client restart
      4. upsc ups
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Re: Problem with UPS Plugin

      Hello, please help, I do not draw graphs.

      Failed to execute command 'omv-mkgraph 2>&1': ERROR: No DS called 'value' in '/var/lib/rrdcached/db//localhost/nut-ups/percent-charge.rrd'

      Source Code

      1. Error #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'omv-mkgraph 2>&1': ERROR: No DS called 'value' in '/var/lib/rrdcached/db//localhost/nut-ups/percent-charge.rrd'' in /usr/share/openmediavault/engined/rpc/rrd.inc:65
      3. Stack trace:
      4. #0 [internal function]: OMVRpcServiceRrd->generate(NULL, Array)
      5. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      6. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('generate', NULL, Array)
      7. #3 /usr/sbin/omv-engined(495): OMVRpc::exec('Rrd', 'generate', NULL, Array, 1)
      8. #4 {main}
    • Re: Problem with UPS Plugin

      "votdev" wrote:

      I assume something is wrong with your configuration. Execute the following commands

      0.5.x:

      Source Code

      1. omv-mkconf nut
      2. service nut restart
      3. upsc ups


      0.6.x:

      Source Code

      1. omv-mkconf nut
      2. service nut-server restart
      3. service nut-client restart
      4. upsc ups


      I've install 0.6.x and i've same problem

      # omv-mkconf nut
      # service nut-server restart
      Restarting NUT - power devices information server and drivers: upsd driver(s) driver(s). (upsd failed).
      # service nut-client restart
      Restarting NUT - power device monitor and shutdown controller: nut-client.
      # upsc ups
      Error: Unknown UPS

      Thank you for help
    • I have the same error. UPS seems to work fine in the Services tab:
      device.mfr: American Power Conversion
      device.model: Smart-UPS 1000
      Any ideas?

      hobot-bobot wrote:

      Hello, please help, I do not draw graphs.

      Failed to execute command 'omv-mkgraph 2>&1': ERROR: No DS called 'value' in '/var/lib/rrdcached/db//localhost/nut-ups/percent-charge.rrd'

      Source Code

      1. Error #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'omv-mkgraph 2>&1': ERROR: No DS called 'value' in '/var/lib/rrdcached/db//localhost/nut-ups/percent-charge.rrd'' in /usr/share/openmediavault/engined/rpc/rrd.inc:65
      3. Stack trace:
      4. #0 [internal function]: OMVRpcServiceRrd->generate(NULL, Array)
      5. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      6. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('generate', NULL, Array)
      7. #3 /usr/sbin/omv-engined(495): OMVRpc::exec('Rrd', 'generate', NULL, Array, 1)
      8. #4 {main}