Configuration Backup

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Configuration Backup

      Hello,

      I'm using OMV 1.0.6 with kernel 3.2.0-4-amd64 and I've been configuring some plugins for daily use, I'm afraid that some updates or faulty OS hard drive could leave my system to freeze someday, If I had the necessity to reinstall all OMV OS is there any way to make a valid configuration backup for future safe use?

      Thanks.
      omv 1.16 kralizec | 64 bit | omvextrasorg 1.15

      24hoursofhappy.com/
    • Re: Configuration Backup

      Just clone the system drive with Clonezilla. If you install openmediavault-backup, you can install clonezilla to boot from the boot menu.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Re: Configuration Backup

      "ryecoaaron" wrote:

      Just clone the system drive with Clonezilla. If you install openmediavault-backup, you can install clonezilla to boot from the boot menu.


      Hi ryecoaaron,

      You're always my backup agent!! :D , but the problem is that I'm a newbie in linux and what you told me to do its a challenge, could you provide me with some guides to do this? :?:

      I will have to get some way to send you an "Port bottle Wine" :idea: ;)
      omv 1.16 kralizec | 64 bit | omvextrasorg 1.15

      24hoursofhappy.com/
    • Re: Configuration Backup

      Backup/Create clone image using Clonezilla

      In OpenMediaVault web interface

      1. Install omv-extras
      2. Install openmediavault-backup from Plugins section
      3. Go to Clonezilla tab in System | Backup
      4. Click Install
      5. Click Clonezilla
      6. Reboot. It will boot to Clonezilla until the next reboot.

      In Clonezilla

      7. Choose language
      8. Select default keymap option
      9. Chooose Start Clonezilla
      10. Choose device-image
      11. Choose enter_shell

      If you want to backup to a raid array:
      12. Type the following to find the array number (ie md127): cat /proc/mdstat
      13. Mount the array: mount /dev/md127 /home/partimag

      If you want to backup to a single drive:
      12. Type the following to find the drive letter and partition number (ie /dev/sdc1): fdisk -l
      13. Mount the drive: mount /dev/sdc1 /home/partimag

      14. Choose Beginner
      15. Choose savedisk
      16. Input a name for saved image
      17. Mark (with an asterisk - use space bar) source disk which has OMV installed - not a data disk. This will typically be sda.
      18. Select OK
      19. Choose default advanced extra parameter for next two screens
      20. Press Enter
      21. Press Y to continue
      22. Wait for backup and backup image verification
      23. Press enter
      24. Choose reboot

      System should boot back into OpenMediaVault.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Re: Configuration Backup

      I do not see Clonezilla tab:



      this are my support info:

      Brainfuck Source Code

      1. --------------------------
      2. ##########################
      3. 02-packages:
      4. dpkg -l | grep openmediavault
      5. --------------------------
      6. ii openmediavault 0.5.53 Open network attached storage solution
      7. ii openmediavault-backup 0.5.2 backup plugin for OpenMediaVault.
      8. ii openmediavault-keyring 0.2 GnuPG archive keys of the OpenMediaVault archive
      9. ii openmediavault-lvm2 0.5.6 OpenMediaVault Logical Volume Manager (LVM2) plugin
      10. ii openmediavault-minidlna 0.5.9 OpenMediaVault miniDLNA (DLNA server) plugin
      11. ii openmediavault-mysql 0.5.13 MySQL plugin for OpenMediaVault.
      12. ii openmediavault-nut 0.5.10 OpenMediaVault Network UPS Tools (NUT) plugin
      13. ii openmediavault-omvextrasorg 0.6.21 OMV-Extras.org Package Repositories for OpenMediaVault
      14. ii openmediavault-supportinfo 0.5.12 OpenMediaVault support panel
      15. ii openmediavault-transmissionbt 0.5.18 OpenMediaVault Transmission (BitTorrent client) plugin
      16. ii openmediavault-webdav 0.5.5 OpenMediaVault WebDAV plugin
      17. ii openmediavault-website 0.5.6 OpenMediaVault website plugin
      18. ##########################
      Display All


      What I need to do to have latest version?
      Files
      • backup.jpg

        (55.31 kB, downloaded 1,823 times, last: )
      OMV 3.0.88 x64 on a HP T510, 8GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
    • Re: Configuration Backup

      This is only available for Kralizec, not Sardaukar.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: Configuration Backup

      Hi ryecoaaron,

      I was testing your guide on a virtual Machine (VMWare ESXi) and when booting into Clonezilla the system hangs.
      Maybe some virtual hardware not compatible.
      Well it seems I've to go with my bare metal system.I hope don't loose my backups!!! :(

      Another error came when installing the Extras plugin and backup plugin:

      Source Code

      1. Failed to execute RPC (service=Apt, method=createIndex): Daemon is not running
      omv 1.16 kralizec | 64 bit | omvextrasorg 1.15

      24hoursofhappy.com/
    • Re: Configuration Backup

      I didn't have any problems with virtualbox or real systems. Maybe clonezilla has issues with VMWare.

      That error is more of a warning. Don't worry about it.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Re: Configuration Backup

      Hi ryecoaaron,

      I tried to install the OMV-Extras plugin and I can see it on the menu tab but no new plugin are visible, removed it again and reinstalled it but no new plugin available meanwhile during the installation got his error:

      Source Code

      1. Creating index of OpenMediaVault plugins ...
      2. {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(495): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}
      3. Done ...
      omv 1.16 kralizec | 64 bit | omvextrasorg 1.15

      24hoursofhappy.com/
    • Re: Configuration Backup

      I released updates for a bunch of plugins because I saw OMV 1.0.7 in the repo but it is not showing up in the updates. I will send Volker a message. Until then, do (as root):

      Source Code

      1. wget http://packages.openmediavault.org/public/pool/main/o/openmediavault/openmediavault_1.0.7_all.deb
      2. dpkg -i openmediavault_1.0.7_all.deb
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Re: Configuration Backup

      Is it possible to make an image with the backup plugin (Clonezilla), and then retsore it into a virtualbox (P to V) for testing purposes?
      ----------------------------------------------------------------------------------------------
      Software:
      Openmediavault 3.0.42 | omvextrasorg 3.3.16 | Nginx 1.10.1 | ownCloud (9.1)
      Multicraft 2.0 | Wordpress 4.6.1 | Couchdb 1.2.0 | Webmin 1.810

      Hardware:
      Chassis: Fractal Design Node 304
      Board: ASROCK Z87E-ITX
      CPU: Intel Core i5-4670T
      CPU Cooler Noctua NH-U12S
      System storage: 30GB - Kingston SMS200S3/30G
      Data storage: 3 x 4TB - WD Red WD40EFRX 4TB
      RAM: 16GB
      Ethernet Adapter TP-Link TG-3468 (PCIe)
    • Sorry for opening old post but i had similar problem.

      My system disk is going to die (S.M.A.R.T. report: bad blocks). I need to backup my system drive and recover it to new drive (maybe SSD). I can backup old drive but not found how to recover it to new (maybe smaller SSD).

      When I clone my old drive to new one - what happened to UUID (system disk) and similar stuff? I am begginer in Linux and had only experience with cloning Windows.