[SOLVED] broken dependencies

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [SOLVED] broken dependencies

      Hey @ll,

      i've installed debian wheezy and on top kralizec (omv 0.6).
      I don't really remember which packages i've tried to install but now i always receive an error message while upgrading my packages (sudo apt-get update).

      My general system info is attached to this post, otherwise the post would exceed the max number of characters.

      The error message while updating:

      {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(495): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}
      Creating index of upgradeable packages ...
      Creating index of OpenMediaVault plugins ...
      {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(495): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}
      Paketlisten werden gelesen... Fertig


      I've already tried "apt-get --simulate --reinstall install openmediavault-anacron 2>&1" but then i receive:

      Source Code

      1. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
      2. openmediavault-anacron : Hängt ab von: openmediavault (>= 1.0.7) aber 1.0.6 soll installiert werden
      3. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


      It's in german and says that there are "unfulfilled dependencies" ("openmediavault-anacron : Depends on: openmediavault (>=1.0.7) but 1.0.6 is supposed to be installes E: Problems can't be solved, defect packages are held back.")

      It sounds to me like openmediavault-anacron is the source of this error, but i don't know how to fix it. Would be great if anyone could help me!

      Thank you very much!

      Best,
      str0hlke
      Files
      • sysinfo.zip

        (163.92 kB, downloaded 170 times, last: )

      The post was edited 1 time, last by str0hlke ().

    • Re: broken dependencies

      Go to System | Update Manager | Settings and enable Pre-released updates.
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: broken dependencies

      "ryecoaaron" wrote:

      Go to System | Update Manager | Settings and enable Pre-released updates.


      Thank you very much! That solved the problem with the anacron but now greyhole and mysql are complaining.
      Since i don't use any of the omv-extra stuff i think i should just deactivate them until omv 0.6 has an official release. Seems to me like the omv-extra-plugins are generating this errors.

      Source Code

      1. Creating index of OpenMediaVault plugins ...
      2. {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-greyhole 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-greyhole : Depends: openmediavault-mysql (>= 0.5) but it is not installable\nE: Unable to correct problems, you have held broken packages.","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-greyhole 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-greyhole : Depends: openmediavault-mysql (>= 0.5) but it is not installable\nE: Unable to correct problems, you have held broken packages.' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(495): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}
      3. Creating index of upgradeable packages ...
      4. Creating index of OpenMediaVault plugins ...
      5. {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-greyhole 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-greyhole : Depends: openmediavault-mysql (>= 0.5) but it is not installable\nE: Unable to correct problems, you have held broken packages.","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-greyhole 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-greyhole : Depends: openmediavault-mysql (>= 0.5) but it is not installable\nE: Unable to correct problems, you have held broken packages.' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(495): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}


      Best,
      str0hlke
    • Re: broken dependencies

      Its just a temporary problem. It won't happen again. Only use the pre-release updates if you really now what you're dooing from now on.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: broken dependencies

      "davidh2k" wrote:

      Its just a temporary problem. It won't happen again. Only use the pre-release updates if you really now what you're dooing from now on.

      Greetings
      David


      Hey David,

      thank you.
      So if i get right now, the package anacron was already using an update from openmediavault. Now i've solved this dependency because i installed the pre-release which the other plugins don't use yet?

      Just so i get it right :)
      Thank you!

      Best,
      str0hlke
    • Re: broken dependencies

      Yes.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.