Solved - Fstab does not auto mount network drive at boot

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Solved - Fstab does not auto mount network drive at boot

      Hello,

      I am trying to mount a network share at boot and it is not working. I can mount it successfully with the command mount -a. I've pasted a copy of my fstab below. I'd appreciate any input.


      /etc/fstab: static file system information.
      #
      # Use 'blkid' to print the universally unique identifier for a
      # device; this may be used with UUID= as a more robust way to name devices
      # that works even if disks are added and removed. See fstab(5).
      #
      # <file system> <mount point> <type> <options> <dump> <pass>
      # / was on /dev/sda2 during installation
      UUID=3a799dc3-9258-4638-9d88-4e6efbdce491 / ext4 errors=remount-ro 0 1
      # /boot/efi was on /dev/sda1 during installation
      UUID=6BB2-DD33 /boot/efi vfat defaults 0 1
      # swap was on /dev/sda3 during installation
      UUID=00a7f795-1869-48d7-9788-1d8cbc752b78 none swap sw 0 0
      /dev/sdc1 /media/usb0 auto rw,user,noauto 0 0
      /dev/sdc2 /media/usb1 auto rw,user,noauto 0 0
      tmpfs /tmp tmpfs defaults 0 0
      # >>> [openmediavault]
      UUID=693317cc-a5e3-4af9-8e94-2e855c927bd8 /media/693317cc-a5e3-4af9-8e94-2e855c927bd8 ext4 def$
      # <<< [openmediavault]
      //192.168.0.15/Multimedia /mnt/voodoo cifs uid=0,guid=0,rw,credentials=/etc/cifspasswd 0 0
      Motherboard: Gigabyte GA-H81M-HD3 Micro ATX LGA1150, Processor: Intel Core i5-4440 3.1GHz Quad-Core, Memory: G.Skill 4GB (2 x 2GB) DDR3-1333

      The post was edited 1 time, last by kjacques1 ().

    • Re: Fstab does not auto mount network drive at boot

      Hi,

      you're trying to mount a network file system (cifs) and the network is is not (yet) up when the fstab is being processed. Add _netdev to the options in the fstab line and the if-up script mountnfs (don't let yourself fool by the name) will take care of mounting the filesystem.

      Should work, if I'm not completely mistaken.

      SlashOpt
      OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system
    • Re: Fstab does not auto mount network drive at boot

      There is a plugin called openmediavault-remoteshare that does this for you. It allows you to mount nfs, samba/cifs, and webdav. Just install omv-extras and it will show up in the plugin list.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: Fstab does not auto mount network drive at boot

      Here is the syntax I did per your suggestion.

      //192.168.0.15/Multimedia /mnt/voodoo cifs auto,_netdev,uid=0,guid=0,rw,credentials=/etc/cifspasswd 0 0

      Is this correct? The network share did not auto mount after a reboot. :(
      Motherboard: Gigabyte GA-H81M-HD3 Micro ATX LGA1150, Processor: Intel Core i5-4440 3.1GHz Quad-Core, Memory: G.Skill 4GB (2 x 2GB) DDR3-1333
    • Re: Fstab does not auto mount network drive at boot

      Try the plugin Aaron suggested.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: Fstab does not auto mount network drive at boot

      There was work done on the remoteshare plugin to fix this exact issue...
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: Fstab does not auto mount network drive at boot

      "kjacques1" wrote:

      Here is the syntax I did per your suggestion.

      //192.168.0.15/Multimedia /mnt/voodoo cifs auto,_netdev,uid=0,guid=0,rw,credentials=/etc/cifspasswd 0 0

      Is this correct? The network share did not auto mount after a reboot. :(


      Oops, thought that cifs filesystems are automatically mounted on reboot by the if-up script I mentioned. I tripped over this when I implemented the 'Webdav addition' for the remoteshare plugin ryecoaaron mentioned in his post.

      Sorry for the confusion!
      OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system
    • Re: Fstab does not auto mount network drive at boot

      Hmmm.

      Doesn't look like the plug-in is compatible with omv 1.0.7 kralizec. Any other ideas or do I need to downgrade?

      Thanks,
      Motherboard: Gigabyte GA-H81M-HD3 Micro ATX LGA1150, Processor: Intel Core i5-4440 3.1GHz Quad-Core, Memory: G.Skill 4GB (2 x 2GB) DDR3-1333
    • Re: Fstab does not auto mount network drive at boot

      Did you enable the testing repo in omv-extras? It definitely works on 1.0.7.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: Fstab does not auto mount network drive at boot

      OK. I've enabled it. There was no need for me to set it up though through the plug-in because now the nfs share is being mounted automatically. I'm not sure what has changed though. Maybe upgrading to 1.0.7 did the trick?

      Thanks.
      Motherboard: Gigabyte GA-H81M-HD3 Micro ATX LGA1150, Processor: Intel Core i5-4440 3.1GHz Quad-Core, Memory: G.Skill 4GB (2 x 2GB) DDR3-1333
    • Re: Fstab does not auto mount network drive at boot

      Upgrading to 1.0.7 shouldn't have fixed it because you are doing everything outside of OMV. I still recommend using the plugin.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: Fstab does not auto mount network drive at boot

      Hello,

      I've moved to using the plugin and successfully mounted the network share under the samba tab which shows enabled. However on a reboot the share is not auto-mounting? If I run a mount -a after login though it mounts Is there a preference I missed to tell it to mount on a reboot?

      Thanks.
      Motherboard: Gigabyte GA-H81M-HD3 Micro ATX LGA1150, Processor: Intel Core i5-4440 3.1GHz Quad-Core, Memory: G.Skill 4GB (2 x 2GB) DDR3-1333
    • Re: Fstab does not auto mount network drive at boot

      Is your set to use DHCP?
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: Fstab does not auto mount network drive at boot

      Here is what the plug-in wrote in to the fstab if that helps. I have x'd out the user and pass.

      //192.168.0.15/Multimedia /media/08296903-afd0-4d34-894a-ed233d5599c3/voodoo/ cifs username=XXXXX,password=XXXXXX,sec=ntlm,iocharset=utf8 0 0

      Thanks.
      Motherboard: Gigabyte GA-H81M-HD3 Micro ATX LGA1150, Processor: Intel Core i5-4440 3.1GHz Quad-Core, Memory: G.Skill 4GB (2 x 2GB) DDR3-1333
    • Re: Fstab does not auto mount network drive at boot

      All I can think is that it is a timing thing. The network isn't quite ready when it is trying to mount entries in fstab.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: Fstab does not auto mount network drive at boot

      Try the latest update - version 1.0 in the kralizec repo.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!