Permanently mount a remote windows share in OMV?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Permanently mount a remote windows share in OMV?

      So Im trying to Permanently mount a windows share in OMV.
      I am able to temporarly mount it in the command line, but when I reboot OMV, share is gone and I have to do “mount –a” for it to mount. I have edited /etc/fstab, I have added this line

      Source Code

      1. //192.168.1.25/shared /mnt/cifs cifs username=diego,password=myname,iocharset=utf8,sec=ntlm 0 0


      And also tried

      Source Code

      1. //192.168.1.25/shared /mnt/cifs cifs ,auto,username=diego,password=myname,iocharset=utf8,sec=ntlm 0 0

      It works temporarily, but when I reboot OMV the share is gone.
      How can I make it so it stays permanent?

      Thank you
    • Re: Permanently mount a remote windows share in OMV?

      The fstab entries are processed before network is up so you need to add something to the fstab entry to delay the mount of the network filesystem (I don't remember what exactly it right now).

      I suggest you to use the remoteshare plugin instead, as this has some fixes applied too and it is exactly made for what you want to do.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • davidh2k wrote:

      The fstab entries are processed before network is up so you need to add something to the fstab entry to delay the mount of the network filesystem (I don't remember what exactly it right now).

      I suggest you to use the remoteshare plugin instead, as this has some fixes applied too and it is exactly made for what you want to do.

      Greetings
      David



      Yea Im using the Remote Share plugin now that you recommended, but it only mounts if I do (mount -a) on every reboot
      any work around to "permanently " mount it?

      The post was edited 1 time, last by Diego1026 ().

    • Diego1026 wrote:


      Yea Im using the Remote Share plugin now that you recommended, but it only mounts if I do (mount -a) on every reboot
      any work around to "permanently " mount it?

      What version of OMV? What version of remote share were you using? The latest version 1.0.2 should have the fix for not mounting on reboot.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • JackElliott wrote:

      Remote Mount plugin is not showing up under Plugins in my install of Erasmus. "Remote Desktop" is the only plugin with the word "remote" in it.
      You have to enable the omv-extras testing repo.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!