problem with plugins

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • problem with plugins

      keep getting this on the list
      Error #6000:
      exception 'OMVException' with message 'The index of available plugins does not exist. Please re-synchronize the package index files from their sources.' in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:73
      Stack trace:
      #0 [internal function]: OMVRpcServicePluginMgmt->enumeratePlugins(NULL, Array)
      #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #2 /usr/share/openmediavault/engined/rpc/pluginmgmt.inc(117): OMVRpcServiceAbstract->callMethod('enumeratePlugin...', NULL, Array)
      #3 [internal function]: OMVRpcServicePluginMgmt->getList(Array, Array)
      #4 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #5 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getList', Array, Array)
      #6 /usr/sbin/omv-engined(495): OMVRpc::exec('Plugin', 'getList', Array, Array, 1)
      #7 {main}

      not sure what's happened

      i'm having a lot of problem :O
    • Re: problem with plugins

      Click on Check.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: problem with plugins

      this is what's happening

      i try that command now



      Source Code

      1. Error #6000:
      2. exception 'OMVException' with message 'The index of available plugins does not exist. Please re-synchronize the package index files from their sources.' in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:73
      3. Stack trace:
      4. #0 [internal function]: OMVRpcServicePluginMgmt->enumeratePlugins(NULL, Array)
      5. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      6. #2 /usr/share/openmediavault/engined/rpc/pluginmgmt.inc(117): OMVRpcServiceAbstract->callMethod('enumeratePlugin...', NULL, Array)
      7. #3 [internal function]: OMVRpcServicePluginMgmt->getList(Array, Array)
      8. #4 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getList', Array, Array)
      10. #6 /usr/sbin/omv-engined(495): OMVRpc::exec('Plugin', 'getList', Array, Array, 1)
      11. #7 {main}
      Display All
      Files
    • Re: problem with plugins

      "ryecoaaron" wrote:

      apt-get update from the command line


      look like something is wrong idk what is happening and why me
      LOL


      Source Code

      1. root@raspberrypi:~# apt-get update
      2. Creating index of OpenMediaVault plugins ...
      3. {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-transmissionbt 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-transmissionbt : Depends: transmission-daemon but it is not going to be installed\n Depends: transmission-cli but it is not going to be installed\nE\n:\nUnable to correct problems, you have held broken packages.\n","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-transmissionbt 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-transmissionbt : Depends: transmission-daemon but it is not going to be installed\n Depends: transmission-cli but it is not going to be installed\nE\n:\nUnable to correct problems, you have held broken packages.\n' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(495): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}
      4. Reading package lists... Done
      5. root@raspberrypi:~#
    • Re: problem with plugins

      I haven't built a version of transmission for the RPi.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Re: problem with plugins

      The index should be build now, independet wether or not transmission is installable.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: problem with plugins

      i just made a new install on it again i think my time was out and it stuffed around so i'm going to update the system first before i try and install the plug list and see if it works :)

      and transmission should not be there i think i maybe did something not sure as i download a zip and tried to upload it to it

      so maybe i did something wrong there