Error installing plugins 1.0.9

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Error installing plugins 1.0.9

      Hello,

      I am getting the following error installing minidnla (I get errors like this installing other plugins as well (lvm2) and I do not know how to fix it.

      Here is the error trying to install a plugin from within the WebGui I am running 1.0.9
      Any assistance appreciated.


      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following extra packages will be installed:
      5. libflac8 libid3tag0 minidlna
      6. The following NEW packages will be installed:
      7. libflac8 libid3tag0 minidlna openmediavault-minidlna
      8. 0 upgraded, 4 newly installed, 0 to remove and 13 not upgraded.
      9. Need to get 359 kB of archives.
      10. After this operation, 899 kB of additional disk space will be used.
      11. WARNING: The following packages cannot be authenticated!
      12. libflac8 libid3tag0 minidlna openmediavault-minidlna
      13. Authentication warning overridden.
      14. Get:1 [url]http://ftp.us.debian.org/debian/[/url] wheezy/main libflac8 i386 1.2.1-6 [152 kB]
      15. Get:2 [url]http://packages.omv-extras.org/debian/[/url] kralizec/main minidlna i386 1.1.2+dfsg-1.1 [153 kB]
      16. Get:3 [url]http://ftp.us.debian.org/debian/[/url] wheezy/main libid3tag0 i386 0.15.1b-10 [36.6 kB]
      17. Get:4 [url]http://packages.omv-extras.org/debian/[/url] kralizec/main openmediavault-minidlna all 1.0.5 [17.4 kB]
      18. Fetched 359 kB in 6s (53.3 kB/s)
      19. Selecting previously unselected package libflac8:i386.
      20. (Reading database ... 45422 files and directories currently installed.)
      21. Unpacking libflac8:i386 (from .../libflac8_1.2.1-6_i386.deb) ...
      22. Selecting previously unselected package libid3tag0.
      23. Unpacking libid3tag0 (from .../libid3tag0_0.15.1b-10_i386.deb) ...
      24. Selecting previously unselected package minidlna.
      25. Unpacking minidlna (from .../minidlna_1.1.2+dfsg-1.1_i386.deb) ...
      26. Selecting previously unselected package openmediavault-minidlna.
      27. Unpacking openmediavault-minidlna (from .../openmediavault-minidlna_1.0.5_all.deb) ...
      28. Processing triggers for man-db ...
      29. Processing triggers for openmediavault ...
      30. Restarting engine daemon ...
      31. Setting up libflac8:i386 (1.2.1-6) ...
      32. Setting up libid3tag0 (0.15.1b-10) ...
      33. Setting up minidlna (1.1.2+dfsg-1.1) ...
      34. Starting DLNA/UPnP-AV media server : minidlna.
      35. Setting up openmediavault-minidlna (1.0.5) ...
      36. Add minidlna user to group: users
      37. Processing triggers for openmediavault ...
      38. Updating locale files ...
      39. Updating file permissions ...
      40. Restarting engine daemon ...
      41. Creating index of upgradeable packages ...
      42. Creating index of OpenMediaVault plugins ...
      43. {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-pyload 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-pyload : Depends: unrar but it is not installable\nE: Unable to correct problems, you have held broken packages.","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-pyload 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-pyload : Depends: unrar but it is not installable\nE: Unable to correct problems, you have held broken packages.' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(501): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}
      44. Done ...
      Display All

      The post was edited 1 time, last by WastlJ ().

    • I'm having the same issue when installing Pyload. I'm running 64-bit system and I enabled pre-release updates. Refreshed update manager and no available updates are found. When I try to manually install unrar, it seems like there is not any installable package.
      Does anyone know how to solve it?

      Thanks
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.