FTP broken since one of the last updates (OMV 1.0)

    • OMV 1.0
    • FTP broken since one of the last updates (OMV 1.0)

      Hi there,
      I'm running OMV kralizec for a while now and it worked fine until now.

      I just realized, that after one of the last updates the shared ftp folders are empty (the ftp program shows the root folders, but they are empty).
      To fix this, I removed all the ftp shares in the settings, did a reboot and removed the folders in /srv/ftp. This directory now only containts the welcome.msg file. When I now re-add the shared folders, the ftp-program again displays only empty folders. Also, there are no folders created in /src/ftp.
      The ftp-program does also display the welcome.msg file. Seems, proftp does not ignore this file anymore.

      Any ideas?
      Best regards,
      Chris
    • Try again once 1.0.14 is out:

      sourceforge.net/p/openmediavau…diavault/debian/changelog

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • I received the update last night and the problem still persists. I removed all shares, disabled ftp then re-added a share and enabled ftp. I still only get empty folders and the welcome.msg ist still NOT hidden.

      Maybe this is an issue because of an older version of mod_vroot? I have version 0.9.2 installed, which is the default on my debian system. When my FTP-client opens one of the shared folders, the following is logged in /var/log/proftpd/vroot.log:

      Source Code

      1. Sep 03 10:10:25 mod_vroot/0.9.2[10057]: found 1 VRootAlias in directory '/srv/ftp/'
      2. Sep 03 10:10:25 mod_vroot/0.9.2[10057]: '/srv/ftp/' aliases: [0] MyShare
      3. Sep 03 10:10:26 mod_vroot/0.9.2[10057]: found 0 VRootAliases in directory '/media/3aab594d-2ca9-4d7e-b32e-09b4f63dc867/MyShare'


      Chris
    • Please open a bugreport on bugtracker.openmediavault.org

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Hi there,

      I did it exactly the same way the thread starter did and I got the same results.

      For a test I added (ftp-shared) a single folder. The ftp-client shows the shared folder but it's empty.

      The proftpd.conf contains

      <Directory /srv/ftp>
      HideFiles (welcome.msg)
      </Directory>

      but the ftp-client displays the file.

      System is running on debian wheezy amd64 (latest) and OMV 1.0.18

      Best Regards,
      -DH-
    • The contents of the shared folder is not supposed to show at /srv/ftp/xxx It is working. I added new shared folder and content. It is working perfectly. There seems to be lack of understanding on your part.
      Images
      • ftp.jpg

        103.33 kB, 890×447, viewed 562 times

      The post was edited 1 time, last by tekkb ().

    • Well, could be my lack of understanding...

      What I was trying to do so far:
      (a) remove/add shares in ftp
      (b) disable/enable ftp
      (c) change privilages and ACL on shares for some folders.

      ...same result: fillezilla on client shows old folder structure regardless what was done in point (a). Folders are empty.

      Any idea where should I look to solve the issue?
    • Hi,

      okay, seems there are more details neccessary:

      I have a folder named "backup", which is shared by CIFS and FTP.
      Access to that folder is only permitted for two users, i.e. "overlord" and "backupdevice", both in group "users".
      Both users are allowed to read and write from/to that folder/subfolders. No one else. No advanced ACL stuff, just simple access privileges.

      Since month that was working fine.
      FTP upload/download working for both users, ftp-client displayed no "welcome.msg" file at FTP root level and I was able to enter the folder and subfolders.

      At one point I updated to 1.0.12 (not sure, I believe it was the update introducing the mod_vroot changes) and the things went weird.
      CIFS access still works as before - and I would expect FTP should work too.
      But ... I see a "welcome.msg" and can't see the contents of my folder "backup".

      So maybe I have a lack of understanding but I expected to get the same results for my ftp stuff as before, even after applying an update dealing with mod_vroot.

      Best Regards,
      -DH-

      The post was edited 1 time, last by -DH- ().

    • Because we are using shared folders which reside on the data disks the data does not appear at /srv/ftp/nameofshared folder. There used to be a line in fstab that mounted the shared folder at the /srv/ftp/nameofsharedfolder on boot so the data would be available there. Volker is using some new method to achieve this.

      The welcome message is being generated without a dot "." in front of the welcome.msg. That is why it shows in Filezilla. This can be changed to make it hidden if you do not like it but the clients have no rights to delete it. In your settings I do not see a Welcome Message. If you scroll back through your connection messages you should see that the Welcome Message was listed.

      Info.
      from mkconf file:
      OMV_PROFTPD_DISPLAYLOGIN=${OMV_PROFTPD_DISPLAYLOGIN:-"/srv/ftp/welcome.msg"}

      @timmoty, you do not need ACL. Just use privileges on the shared folder. And if you are using both that is bad.

      Did you guys reference this when setting up your FTP Server:

      phpbb.openmediavault.org/viewtopic.php?f=13&t=3205

      The post was edited 4 times, last by tekkb ().