Problem installing Virtualbox Guest addition on OMV 1.0

    • OMV 1.0
    • Resolved
    • Problem installing Virtualbox Guest addition on OMV 1.0

      Today i did a fresh install (from iso) of OMV 1.0 on my system.

      I've installed the extra's plugin and then installed virtual box.
      Some of the virtual boxes i want to run need guest additions for passing trough usb devices.

      So i tried to install the guest additions as described on the Virtuabox forum:

      Source Code

      1. ​apt-get update
      2. apt-get upgrade
      3. apt-get install build-essential module-assistant
      4. m-a prepare
      5. mkdir -p /mnt/disk
      6. mount -o loop /usr/share/virtualbox/VBoxGuestAdditions.iso /mnt/disk/
      7. sh /mnt/disk/VBoxLinuxAdditions.run


      The output is the following:

      Brainfuck Source Code

      1. ​root@nas:/opt# sh /mnt/disk/VBoxLinuxAdditions.run
      2. Verifying archive integrity... All good.
      3. Uncompressing VirtualBox 4.3.16 Guest Additions for Linux............
      4. VirtualBox Guest Additions installer
      5. Copying additional installer modules ...
      6. Installing additional modules ...
      7. Removing existing VirtualBox non-DKMS kernel modules ...done.
      8. Building the VirtualBox Guest Additions kernel modules
      9. The headers for the current running kernel were not found. If the following
      10. module compilation fails then this could be the reason.
      11. Building the main Guest Additions module ...done.
      12. Building the shared folder support module ...done.
      13. Building the OpenGL support module ...done.
      14. Doing non-kernel setup of the Guest Additions ...done.
      15. Starting the VirtualBox Guest Additions ...fail!
      16. (modprobe vboxguest failed)
      17. Installing the Window System drivers
      18. Could not find the X.Org or XFree86 Window System, skipping.
      19. root@nas:/opt#
      Display All


      I can't seem to find what causes this....
      Can somebody help me with this issue ?
    • Well i didn't even get to that part.

      Just installing them om my OMV host device gives the error above.

      Here some log files:

      vboxadd-install.log
      pastebin.com/dQe2BJLn

      VBoxGuestAdditions.log

      Source Code

      1. Starting the VirtualBox Guest Additions ...fail!
      2. (modprobe vboxguest failed)
      3. Starting VirtualBox Guest Addition service VirtualBox Additions module not loaded!


      The post was edited 1 time, last by jammiejammie ().

    • That part? After you have installed a virtual machine, start it and install the guest additions. INSIDE the VM! You do not need to install the guest additions on your host machine.
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • The openmediavault-virtualbox package depends on our virtualbox-extpack-installer package which installs the corresponding extpack for VirtualBox so you shouldn't need to install it manually.

      Edit: I shouldn't have read the first post to fast, I thought this was about the extpack :)

      The post was edited 1 time, last by HK-47 ().

    • Ok so i think i am confused here.

      Guest additions don't need to be installed on the HOST but inside the virtualmachiene ?

      Any reason why an installation of a Ubuntu 10.04 LTS server edition virtualmachine on a Windows Host works perfeclty, and installing a the same using OMV as a host results in the lines "Guest additions not installed" in phpvirtualbox ?
    • jammiejammie wrote:

      Guest additions don't need to be installed on the HOST but inside the virtualmachiene ?

      Absolutely correct!

      jammiejammie wrote:

      Any reason why an installation of a Ubuntu 10.04 LTS server edition virtualmachine on a Windows Host works perfeclty, and installing a the same using OMV as a host results in the lines "Guest additions not installed" in phpvirtualbox ?


      phpvirtualbox is not the same as the virtualbox you know from Windows. It defenitely does not install the guest additions by default. Therefore you have to install them as you mentioned NOT at the host system, INSIDE the virtual machine. :thumbup:
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • I still have troubles getting it to work.

      I copied the vdi disk image i've created on my mac to my OMV.
      In OMV virtualbox (php) i create a new device with the VDi as source disk.
      After booting into the system i installed the gues addtions inside the virtual machine, but still can get an internet connection to it.

      On the phpvirtualbox screen it shows (Guest Network Adapter):
      [IMG:http://i60.tinypic.com/2628klk.png]
    • I still seem to have some issues regarding the interfacing of the virtual box to the host.

      I can't get the USB devices put trough to the guest.

      Here is a screen shot the my phpvirtualmin usb tab:
      [IMG:http://i59.tinypic.com/20jgxhu.png]


      if i do a lsusb command in my guest, the result is as following:

      Source Code

      1. ​domoticz@domoticz:~$ lsusb
      2. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
      3. Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
      4. domoticz@domoticz:~$


      Some webpages suggest is should add my user to the vboxusers group, but my guest system doesn't have that group.

      Source Code

      1. ​domoticz@domoticz:~$ groups
      2. domoticz adm cdrom sudo dip plugdev lpadmin sambashare
      3. domoticz@domoticz:~$


      Am I doing something wrong again or how should i fit this issue ?