Temperature CPU?

    • OMV 1.0
    • Not as of yet, but it would be a great addition. However, is not a priority as of right now unless someone with skills wants to contribute writing a plugin for it. So in short, not right now.
      Absolutely no support through PMs!!
      I work for the HPE servers R&D division. Have tech questions about ProLiant servers? Ask me!
      Learn more about HPE's iLO4 Management Engine included in all ProLiant servers.
      HPE Repositories for Linux are available here!

      [IMG:http://home.thepoorgeek.com/misc/Hewlett-Packard-Enterprise-logo.jpg]
    • Pardon to correct you Spy, but the Plugin is already in the making by jhmiller, cpu temp is one of the first things thats working, but jhmiller still has to fix some bugs.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Well I stand corrected, I must have missed it. There's your answer Joq3!
      Absolutely no support through PMs!!
      I work for the HPE servers R&D division. Have tech questions about ProLiant servers? Ask me!
      Learn more about HPE's iLO4 Management Engine included in all ProLiant servers.
      HPE Repositories for Linux are available here!

      [IMG:http://home.thepoorgeek.com/misc/Hewlett-Packard-Enterprise-logo.jpg]
    • The plugin needs feedback from end users so the more who try it and give feedback the better it will be.

      A lot of the issues that were found in the first release have been fixed and a new version has been released, it can be found here

      Please test and report any issues here

      Miller
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • ​Please test and report any issues here


      Access denied


      Installed sensors on latest kralizec. Modified modules (chip was found). Restarted

      # /etc/init.d/kmod start
      Loading kernel module loop.
      Loading kernel module jc42.

      From this moment the access to dashboard and services got stuck. Uninstalled the module and services and dashboard works. During uninstall there was a error popup, unfortunately i lost the msg.
      Tom

      ----

      HP N54L, 6GB, 5disc Raid5, SSD Boot with OMV Stone Burner
      HP N54L, 16GB, 4disc Raid5, SSD Boot with OMV Stone Burner
    • Sorry, I forgot that is a dev forum that you do not have access to, its nice to be special :D

      Did you run /etc/init.d/kmod start or did the system do it automatically?
      Also did you run sensors-detect?

      If you could re-install and give the output of the following 3 commands

      Source Code

      1. sensors
      2. ls /var/lib/rrdcached/db/localhost/sensors-*/
      3. cat /proc/cpuinfo

      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

      The post was edited 1 time, last by jhmiller ().

    • tom_tav wrote:



      Modified modules (chip was found). Restarted


      Where did you see this?

      tom_tav wrote:


      # /etc/init.d/kmod start
      Loading kernel module loop.
      Loading kernel module jc42.

      When was this run?

      This is the only info you have given me and none of it is to do with the plugin, It will not show what it has found and it will not run /etc/init.d/kmod
      If you install the plugin and get the error that came up, also do nothing in cli, the plugin will do all that is needed.
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • Here we go, installed the plugin again:

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following NEW packages will be installed:
      5. openmediavault-sensors
      6. 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      7. Need to get 0 B/52.2 kB of archives.
      8. After this operation, 221 kB of additional disk space will be used.
      9. WARNING: The following packages cannot be authenticated!
      10. openmediavault-sensors
      11. Authentication warning overridden.
      12. Selecting previously unselected package openmediavault-sensors.
      13. (Reading database ... 49427 files and directories currently installed.)
      14. Unpacking openmediavault-sensors (from .../openmediavault-sensors_1.0.2_all.deb) ...
      15. Processing triggers for openmediavault ...
      16. Restarting engine daemon ...
      17. Setting up openmediavault-sensors (1.0.2) ...
      18. Initial configuration.
      19. Restarting statistics collection and monitoring daemon: collectdModule cpuid loaded successfully.
      20. Silicon Integrated Systems SIS5595... No
      21. VIA VT82C686 Integrated Sensors... No
      22. VIA VT8231 Integrated Sensors... No
      23. AMD K8 thermal sensors... No
      24. AMD Family 10h thermal sensors... Success!
      25. (driver `k10temp')
      26. AMD Family 11h thermal sensors... No
      27. AMD Family 12h and 14h thermal sensors... No
      28. AMD Family 15h thermal sensors... No
      29. AMD Family 15h power sensors... No
      30. Intel digital thermal sensor... No
      31. Intel AMB FB-DIMM thermal sensor... No
      32. VIA C7 thermal sensor... No
      33. VIA Nano thermal sensor... No
      34. Probing for Super-I/O at 0x2e/0x2f
      35. Trying family `National Semiconductor/ITE'... No
      36. Trying family `SMSC'... No
      37. Trying family `VIA/Winbond/Nuvoton/Fintek'... No
      38. Trying family `ITE'... No
      39. Probing for Super-I/O at 0x4e/0x4f
      40. Trying family `National Semiconductor/ITE'... No
      41. Trying family `SMSC'... No
      42. Trying family `VIA/Winbond/Nuvoton/Fintek'... No
      43. Trying family `ITE'... No
      44. Found `IPMI BMC KCS'... Success!
      45. (confidence 8, driver `to-be-written')
      46. Probing for `National Semiconductor LM78' at 0x290... No
      47. Probing for `National Semiconductor LM79' at 0x290... No
      48. Probing for `Winbond W83781D' at 0x290... No
      49. Probing for `Winbond W83782D' at 0x290... No
      50. Using driver `i2c-piix4' for device 0000:00:14.0: ATI Technologies Inc SB600/SB700/SB800 SMBus
      51. Module i2c-dev loaded successfully.
      52. Processing triggers for openmediavault ...
      53. Updating locale files ...
      54. Client found at address 0x18
      55. Handled by driver `jc42' (already loaded), chip type `jc42'
      56. Client found at address 0x19
      57. Handled by driver `jc42' (already loaded), chip type `jc42'
      58. Client found at address 0x50
      59. Probing for `Analog Devices ADM1033'... No
      60. Probing for `Analog Devices ADM1034'... No
      61. Probing for `SPD EEPROM'... Yes
      62. (confidence 8, not a hardware monitoring chip)
      63. Probing for `EDID EEPROM'... No
      64. Client found at address 0x51
      65. Probing for `Analog Devices ADM1033'... No
      66. Probing for `Analog Devices ADM1034'... No
      67. Probing for `SPD EEPROM'... .
      68. Yes
      69. (confidence 8, not a hardware monitoring chip)
      70. Client found at address 0x49
      71. Probing for `National Semiconductor LM75'... No
      72. Probing for `National Semiconductor LM75A'... No
      73. Probing for `Dallas Semiconductor DS75'... No
      74. Probing for `National Semiconductor LM77'... No
      75. Probing for `Analog Devices ADT7410'... No
      76. Probing for `Dallas Semiconductor DS1621/DS1631'... No
      77. Probing for `Maxim MAX6642'... No
      78. Probing for `National Semiconductor LM73'... No
      79. Probing for `National Semiconductor LM92'... No
      80. Probing for `National Semiconductor LM76'... No
      81. Probing for `Maxim MAX6633/MAX6634/MAX6635'... No
      82. Probing for `NXP/Philips SA56004'... No
      83. Probing for `SMSC EMC1023'... No
      84. Probing for `SMSC EMC1043'... No
      85. Probing for `SMSC EMC1053'... No
      86. Probing for `SMSC EMC1063'... No
      87. Client found at address 0x50
      88. Probing for `Analog Devices ADM1033'... No
      89. Probing for `Analog Devices ADM1034'... No
      90. Probing for `SPD EEPROM'... No
      91. Probing for `EDID EEPROM'... Yes
      92. (confidence 8, not a hardware monitoring chip)
      93. Updating file permissions ...
      94. Restarting engine daemon ...
      95. Creating index of upgradeable packages ...
      96. Creating index of OpenMediaVault plugins ...
      97. Driver `jc42':
      98. * Bus `SMBus PIIX4 adapter at 0b00'
      99. Busdriver `i2c_piix4', I2C address 0x18
      100. Chip `jc42' (confidence: 6)
      101. * Bus `SMBus PIIX4 adapter at 0b00'
      102. Busdriver `i2c_piix4', I2C address 0x19
      103. Chip `jc42' (confidence: 6)
      104. Driver `to-be-written':
      105. * ISA bus
      106. Chip `IPMI BMC KCS' (confidence: 8)
      107. Driver `k10temp' (autoloaded):
      108. * Chip `AMD Family 10h thermal sensors' (confidence: 9)
      109. Note: there is no driver for IPMI BMC KCS yet.
      110. Check [url]http://www.lm-sensors.org/wiki/Devices[/url] for updates.
      111. To load everything that is needed, add this to /etc/modules:
      112. #----cut here----
      113. # Chip drivers
      114. jc42
      115. #----cut here----
      116. If you have some drivers built into your kernel, the list above will
      117. contain too many modules. Skip the appropriate ones!
      118. Successful!
      119. Monitoring programs won't work until the needed modules are
      120. loaded. You may want to run '/etc/init.d/kmod start'
      121. to load them.
      122. Unloading i2c-dev... OK
      123. Unloading cpuid... OK
      124. Done ...
      Display All


      --->

      made change to /etc/modules

      did /etc/init.d/kmod start

      enabled cpu monitor

      --->

      Clicking on services brings only the wheel of death ;)

      Dtto on dashboard


      On Status page i see Temperature but just unhappy icons
      ---

      got during install two messages (email):

      Description: process PID changed from 24996 to 6865

      Description: process PID changed from 6865 to 7268


      EDIT: reboot doesnt help

      module seems to be loaded (lsmod output):

      i2c_core 24228 6 drm,jc42,i2c_piix4,drm_kms_helper,i2c_algo_bit,radeon

      k10driver was found by probe sensors, seems to be there but not used by anything:

      k10temp 12618 0
      Tom

      ----

      HP N54L, 6GB, 5disc Raid5, SSD Boot with OMV Stone Burner
      HP N54L, 16GB, 4disc Raid5, SSD Boot with OMV Stone Burner

      The post was edited 4 times, last by davidh2k ().

    • also do nothing in cli, the plugin will do all that is needed.


      Source Code

      1. To load everything that is needed, add this to /etc/modules:
      2. #----cut here----
      3. # Chip drivers
      4. jc42
      5. #----cut here----
      6. If you have some drivers built into your kernel, the list above will
      7. contain too many modules. Skip the appropriate ones!
      8. Successful!


      This message should be ignored, In the first version that script was not run until you enabled the plugin and so it was run in the background, I forgot I moved it to run on install.
      Remove the entries from /etc/modules, and run

      Source Code

      1. rmmod jc42
      you may also need to restart

      This will undo what you did manually after that, disable the cpu temp and then enable it (generates new configuration files) then check the status page.

      please also do

      Source Code

      1. sensors
      2. ls /var/lib/rrdcached/db/localhost/sensors-*/
      3. cat /proc/cpuinfo
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • Removed entry in modules, did rmmod, restarted system

      After this i disabled and enabled cpu temp several times:

      1. still wheel of death
      2. no temperature tab in status

      during this steps got status mails about collectd (not exist/exist/change of pid)

      ---

      Source Code

      1. # sensors
      2. k10temp-pci-00c3
      3. Adapter: PCI adapter
      4. temp1: +44.5°C (high = +70.0°C)
      5. (crit = +100.0°C, hyst = +95.0°C)
      6. # ls /var/lib/rrdcached/db/localhost/sensors-*/
      7. /var/lib/rrdcached/db/localhost/sensors-jc42-i2c-0-18/:
      8. temperature-temp1.rrd
      9. /var/lib/rrdcached/db/localhost/sensors-jc42-i2c-0-19/:
      10. temperature-temp1.rrd
      11. /var/lib/rrdcached/db/localhost/sensors-k10temp-pci-00c3/:
      12. temperature-temp1.rrd
      13. # cat /proc/cpuinfo
      14. processor : 0
      15. vendor_id : AuthenticAMD
      16. cpu family : 16
      17. model : 6
      18. model name : AMD Turion(tm) II Neo N54L Dual-Core Processor
      19. stepping : 3
      20. microcode : 0x10000c8
      21. cpu MHz : 800.000
      22. cache size : 1024 KB
      23. physical id : 0
      24. siblings : 2
      25. core id : 0
      26. cpu cores : 2
      27. apicid : 0
      28. initial apicid : 0
      29. fpu : yes
      30. fpu_exception : yes
      31. cpuid level : 5
      32. wp : yes
      33. flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate npt lbrv svm_lock nrip_save
      34. bogomips : 4392.99
      35. TLB size : 1024 4K pages
      36. clflush size : 64
      37. cache_alignment : 64
      38. address sizes : 48 bits physical, 48 bits virtual
      39. power management: ts ttp tm stc 100mhzsteps hwpstate
      40. processor : 1
      41. vendor_id : AuthenticAMD
      42. cpu family : 16
      43. model : 6
      44. model name : AMD Turion(tm) II Neo N54L Dual-Core Processor
      45. stepping : 3
      46. microcode : 0x10000c8
      47. cpu MHz : 800.000
      48. cache size : 1024 KB
      49. physical id : 0
      50. siblings : 2
      51. core id : 1
      52. cpu cores : 2
      53. apicid : 1
      54. initial apicid : 1
      55. fpu : yes
      56. fpu_exception : yes
      57. cpuid level : 5
      58. wp : yes
      59. flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate npt lbrv svm_lock nrip_save
      60. bogomips : 4392.99
      61. TLB size : 1024 4K pages
      62. clflush size : 64
      63. cache_alignment : 64
      64. address sizes : 48 bits physical, 48 bits virtual
      65. power management: ts ttp tm stc 100mhzsteps hwpstate
      66. #
      Display All


      EDIT: even with enabled cpu temp there is no entry in modules (in case your scripts should create one there)
      Tom

      ----

      HP N54L, 6GB, 5disc Raid5, SSD Boot with OMV Stone Burner
      HP N54L, 16GB, 4disc Raid5, SSD Boot with OMV Stone Burner

      The post was edited 1 time, last by davidh2k ().

    • can you now do

      Source Code

      1. cat /usr/share/openmediavault/mkconf/collectd.d/sensors[code]
      2. followed by
      3. [code]cat /usr/sbin/omv-mkgraph


      The first is generated by the plugin and is used to amend omv-mkgraph
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS