Unable to update to openmediavault-omvextrasorg_0.6.24

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Unable to update to openmediavault-omvextrasorg_0.6.24

      Any one else seeing this? Trying to apply an update to OMV Extras but the update seems broken:

      From the OMV gui:
      Reading package lists...
      Building dependency tree...
      Reading state information...
      The following packages will be upgraded:
      openmediavault-omvextrasorg
      1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      Need to get 0 B/208 kB of archives.
      After this operation, 81.9 kB of additional disk space will be used.
      WARNING: The following packages cannot be authenticated!
      openmediavault-omvextrasorg
      Reading changelogs...
      Authentication warning overridden.
      (Reading database ... 109401 files and directories currently installed.)
      Preparing to replace openmediavault-omvextrasorg 0.6.21 (using .../openmediavault-omvextrasorg_0.6.24_all.deb) ...
      Unpacking replacement openmediavault-omvextrasorg ...
      dpkg: error processing /var/cache/apt/archives/openmediavault-omvextrasorg_0.6.24_all.deb (--unpack):
      trying to overwrite '/var/www/openmediavault/js/omv/module/admin/diagnostic/system/ProcessList.js', which is also in package openmediavault-processlist 0.5.6
      configured to not write apport reports
      dpkg-deb: subprocess paste killed by signal (Broken pipe)
      Processing triggers for openmediavault ...
      Restarting engine daemon ...


      and then the omv daemon requires restarting ..

      Tried on command line:
      > sudo apt-get install openmediavault-omvextrasorg
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following packages will be upgraded:
      openmediavault-omvextrasorg
      1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      Need to get 0 B/208 kB of archives.
      After this operation, 81.9 kB of additional disk space will be used.
      Reading changelogs... Done
      (Reading database ... 109401 files and directories currently installed.)
      Preparing to replace openmediavault-omvextrasorg 0.6.21 (using .../openmediavault-omvextrasorg_0.6.24_all.deb) ...
      Unpacking replacement openmediavault-omvextrasorg ...
      dpkg: error processing /var/cache/apt/archives/openmediavault-omvextrasorg_0.6.24_all.deb (--unpack):
      trying to overwrite '/var/www/openmediavault/js/omv/module/admin/diagnostic/system/ProcessList.js', which is also in package openmediavault-processlist 0.5.6
      configured to not write apport reports
      dpkg-deb: subprocess paste killed by signal (Broken pipe)
      Processing triggers for openmediavault ...
      Restarting engine daemon ...
      Errors were encountered while processing:
      /var/cache/apt/archives/openmediavault-omvextrasorg_0.6.24_all.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)


      Thanks ..
    • The problem is that the '/var/www/openmediavault/js/omv/module/admin/diagnostic/system/ProcessList.js' file is shipped with the openmediavault-processlist plugin but will be installed with openmediavault-omvextrasorg too. This is forbidden by the Debian package management. In this case you have to uninstall openmediavault-processlist before to fix that issue.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • tekkb wrote:

      apt-get clean
      apt-get remove openmediavault-processlist

      then try it again. Don't use sudo. This is Debian not Ubuntu.


      Not sure I understand this. apt-get always needs root privilege as far as I am aware:

      ianch-hp ~: apt-get update
      E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
      E: Unable to lock directory /var/lib/apt/lists/
      E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
      E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?


      As for the dependency conflict, removing openmediavault-processlist isn't a fix, just a workaround. Anyway, I removed the processlist plugin via the gui and then tried the command line update of omv extras and this worked fine:
      ianch-hp ~: sudo apt-get install openmediavault-omvextrasorg
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following packages will be REMOVED:
      openmediavault-supportinfo
      The following packages will be upgraded:
      openmediavault-omvextrasorg
      1 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
      Need to get 208 kB of archives.
      After this operation, 112 kB disk space will be freed.
      Do you want to continue [Y/n]?
      Get:1 packages.omv-extras.org/debian/ sardaukar/main openmediavault-omvextrasorg all 0.6.25 [208 kB]
      Fetched 208 kB in 1s (125 kB/s)
      Reading changelogs... Done
      (Reading database ... 109386 files and directories currently installed.)
      Removing openmediavault-supportinfo ...
      Processing triggers for openmediavault ...
      Restarting engine daemon ...
      Updating file permissions ...
      Updating locale files ...
      (Reading database ... 109367 files and directories currently installed.)
      Preparing to replace openmediavault-omvextrasorg 0.6.21 (using .../openmediavault-omvextrasorg_0.6.25_all.deb) ...
      Unpacking replacement openmediavault-omvextrasorg ...
      Processing triggers for openmediavault ...
      Restarting engine daemon ...
      Setting up openmediavault-omvextrasorg (0.6.25) ...
      OK
      OK
      OK
      OK
      OK
      OK
      gpg: WARNING: digest algorithm MD5 is deprecated
      gpg: please see gnupg.org/faq/weak-digest-algos.html for more information
      OK
      OK
      OK
      OK
      Agent pid 29597
      Identity added: /root/.ssh/id_rsa (/root/.ssh/id_rsa)
      Identity added: /root/.ssh/id_dsa (/root/.ssh/id_dsa)
      Processing triggers for openmediavault ...
      Updating locale files ...
      Updating file permissions ...
      Restarting engine daemon ...


      What is strange is that the version is now 0.6.25 and not 0.6.24 :)