ERRORS after upgrade OMV 0.5.59 to OMV 1

    • Upgrade 0.5 -> 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • ERRORS after upgrade OMV 0.5.59 to OMV 1

      When i upgrade OMV 0.5.59 to OMV 1 via omv-release-upgrade i get this errors:

      Source Code

      1. ​E: The value 'squeeze-lts' is invalid for APT::Default-Release as such a release is not available in the sources
      2. run-parts: /tmp/tmp.6Gvwoxh2eX/post.d/10-apt-reinstall exited with return code 1 00
      3. Reading package lists... Done
      4. E: The value 'squeeze-lts' is invalid for APT::Default-Release as such a release is not available in the sources
      5. run-parts: /tmp/tmp.6Gvwoxh2eX/post.d/10-virtualbox exited with return code 100
      6. Reading package lists... Done
      7. E: The value 'squeeze-lts' is invalid for APT::Default-Release as such a release is not available in the sources
      8. run-parts: /tmp/tmp.6Gvwoxh2eX/post.d/80-apt-autoremove exited with return code 100
      9. Site openmediavault-webgui disabled.
      10. To activate the new configuration, you need to run:
      11. service apache2 reload
      Display All


      I fear to restart my machine.
      Web gui is working now (OMV 1) but i do not see my plugins I have before (VIRTUALBOX). And also noticed that I have only SNAPRAID 0.6.2 for squeeze.

      dpkg -l | grep openmediavault

      Source Code

      1. ​ii openmediavault 1.0.21 all Open network attached storage solution
      2. ii openmediavault-anacron 0.5.3 all anacron plugin for OpenMediaVault.
      3. ii openmediavault-aufs 0.5.6 all aufs plugin for OpenMediaVault.
      4. ii openmediavault-backup 0.5.2 all backup plugin for OpenMediaVault.
      5. ii openmediavault-downloader 0.6.4 all OpenMediaVault downloader plugin
      6. ii openmediavault-keyring 0.3 all GnuPG archive keys of the OpenMediaVault archive
      7. ii openmediavault-minidlna 0.5.9 all OpenMediaVault miniDLNA (DLNA server) plugin
      8. ii openmediavault-mysql 0.5.13 all MySQL plugin for OpenMediaVault.
      9. rc openmediavault-omvextrasorg 0.6.25 all OMV-Extras.org Package Repositories for OpenMediaVault
      10. ii openmediavault-plexmediaserver 0.5.5 all OpenMediaVault Plex Media Server plugin
      11. rc openmediavault-pyload 0.5.0 all OpenMediaVault pyLoad plugin
      12. ii openmediavault-route 1.0 all OpenMediaVault IP routing table plugin
      13. ii openmediavault-snapraid 0.6.2-squeeze amd64 snapraid plugin for OpenMediaVault.
      14. rc openmediavault-supportinfo 0.5.12 all OpenMediaVault support panel
      15. ii openmediavault-transmissionbt 0.5.18 all OpenMediaVault Transmission (BitTorrent client) plugin
      16. rc openmediavault-virtualbox 0.5.16 all VirtualBox plugin for OpenMediaVault.
      17. rc openmediavault-website 0.5.6 all OpenMediaVault website plugin
      Display All
    • Meanwhile I rebooted my NAS and had some problems with grub - SOLVED
      Now I am on OMV 1 but lost my plugins (virtualbox, pyload ...) and my samba share is not working

      cat /etc/apt/sources.list

      Source Code

      1. #
      2. # deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130824-13:07]/ wheezy main non-free
      3. #deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130824-13:07]/ wheezy main non-free
      4. deb http://ftp.sk.debian.org/debian/ wheezy main
      5. deb-src http://ftp.sk.debian.org/debian/ wheezy main
      6. deb http://security.debian.org/ wheezy/updates main non-free
      7. deb-src http://security.debian.org/ wheezy/updates main non-free
      8. # wheezy-updates, previously known as 'volatile'
      9. deb http://ftp.sk.debian.org/debian/ wheezy-updates main non-free
      10. deb-src http://ftp.sk.debian.org/debian/ wheezy-updates main non-free​
      Display All


      cat /etc/apt/apt.conf

      Source Code

      1. ​#APT::Default-Release "stable";
      2. APT::Install-Recommends "false";
      3. APT::Install-Suggests "false";
      4. APT::Default-Release "wheezy";


      I edit apt.conf (had squeeze on *Release)
    • Do you have installed omv-extras? To get samba to work, just make a small change anywhere and save/apply.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • My blind eyes....
      I forgot to install omv-extras......
      Now installed and updated

      But after apt-get upgrade:

      Source Code

      1. Reading package lists... Done
      2. Building dependency tree
      3. Reading state information... Done
      4. The following packages have been kept back:
      5. openmediavault-mysql openmediavault-snapraid virtualbox-4.3
      6. 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.​

      Must it install manually via web gui?

      Now I have SnapRaid 0.6.2-squeeze - why?
      Virtualbox is not in active plugins - used it on OMV 0.5 for mail VM and now i cannot use mails
    • apt-get -f install

      Source Code

      1. Reading package lists... Done
      2. Building dependency tree
      3. Reading state information... Done
      4. The following packages were automatically installed and are no longer required:
      5. g++-4.4 gir1.2-atk-1.0 gir1.2-pango-1.0 libapache2-mod-fcgid libatk1.0-0 libatk1.0-data libatk1.0-dev libaudio2 libavcodec52
      6. libavformat52 libavutil49 libboost-iostreams1.42.0 libcrypt-openssl-random-perl libcrypt-passwdmd5-perl libdb4.7 libdbi0
      7. libdjvulibre-text libdjvulibre21 libdrm2 libevent-1.4-2 libfaad2 libgl1-mesa-glx libglapi-mesa libgs8 libgsf-1-114 libgsf-1-common
      8. libgtk2.0-0 libgtk2.0-common libgtk2.0-dev libicu44 libjavascript-minifier-perl libjbig-dev libmng1 libmysqlclient16 libnl1
      9. libpango1.0-dev libpython2.6 libqt4-network libqt4-opengl libqt4-xml libqtcore4 libqtdbus4 libqtgui4 librpcsecgss3 libserf-0-0
      10. libstdc++6-4.4-dev libt1-5 libtiffxx0c2 libxcb-glx0 libxcb-render-util0 libxcb-render-util0-dev libxcomposite-dev libxcomposite1
      11. libxcursor-dev libxcursor1 libxdamage-dev libxdamage1 libxfixes-dev libxft-dev libxi-dev libxinerama-dev libxinerama1
      12. libxml2-utils libxmu6 libxrandr-dev libxrandr2 libxxf86vm1 makepasswd ocaml-base-nox scponly virtualbox-4.3 x11proto-composite-dev
      13. x11proto-damage-dev x11proto-fixes-dev x11proto-randr-dev x11proto-xinerama-dev
      14. Use 'apt-get autoremove' to remove them.
      15. 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
      Display All
    • What about: apt-get install openmediavault-snapraid openmediavault-virtualbox
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Are they working? The new version of snapraid will definitely require you to set it up again.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Snapraid and Virtualbox configured and working. MySQL is working too.
      But have problem with NUT and PyLoad.

      NUT:
      after configured it like on OMV 0.5:

      Source Code

      1. Failed to execute command 'upsc 'ups' 2>&1': Error: Driver not connected
      2. Error #4000:
      3. exception 'OMVException' with message 'Failed to execute command 'upsc 'ups' 2>&1': Error: Driver not connected' in /usr/share/openmediavault/engined/rpc/nut.inc:151
      4. Stack trace:
      5. #0 [internal function]: OMVRpcServiceNetworkUPSTools->getStats(NULL, Array)
      6. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getStats', NULL, Array)
      8. #3 /usr/sbin/omv-engined(501): OMVRpc::exec('Nut', 'getStats', NULL, Array, 1)
      9. #4 {main}


      PyLoad is installed via webgui but after entering nas:8888 no webpage is visible (webpage is not avaiable)
    • Disabling + re-enabling, uninstall and re-install - nothing helped.

      UPS log:

      Source Code

      1. ​Sep 21 17:31:25 NAS upsd[23003]: User monmaster@127.0.0.1 logged out from UPS [ups]
      2. Sep 21 17:31:25 NAS upsmon[23109]: upsmon parent: read
      3. Sep 21 17:31:25 NAS upsd[23003]: mainloop: Interrupted system call
      4. Sep 21 17:31:25 NAS upsd[23003]: Signal 15: exiting
      5. Sep 21 17:31:52 NAS upsd[30385]: listening on 127.0.0.1 port 3493
      6. Sep 21 17:31:52 NAS upsd[30385]: Can't connect to UPS [ups] (usbhid-ups-ups): No such file or directory
      7. Sep 21 17:31:52 NAS upsd[30386]: Startup successful
      8. Sep 21 17:31:52 NAS upsmon[30394]: Startup successful
      9. Sep 21 17:31:52 NAS upsd[30386]: User monmaster@127.0.0.1 logged into UPS [ups]
      10. Sep 21 17:31:52 NAS upsmon[30395]: Poll UPS [ups@localhost] failed - Driver not connected
      11. Sep 21 17:31:52 NAS upsmon[30395]: Communications with UPS ups@localhost lost
      12. Sep 21 17:31:52 NAS upssched[30400]: Executing command: notify
      13. Sep 21 17:31:52 NAS upssched-cmd: Communications with the UPS ups@localhost are lost
      14. Sep 21 17:31:53 NAS upsmon[30395]: Signal 15: exiting
      15. Sep 21 17:31:53 NAS upsmon[30394]: upsmon parent: read
      16. Sep 21 17:31:53 NAS upsd[30386]: User monmaster@127.0.0.1 logged out from UPS [ups]
      17. Sep 21 17:31:54 NAS upsmon[30491]: Startup successful
      18. Sep 21 17:31:54 NAS upsd[30386]: User monmaster@127.0.0.1 logged into UPS [ups]
      19. Sep 21 17:31:54 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      20. Sep 21 17:31:54 NAS upsmon[30492]: Communications with UPS ups@localhost lost
      21. Sep 21 17:31:54 NAS upssched[30499]: Executing command: notify
      22. Sep 21 17:31:54 NAS upssched-cmd: Communications with the UPS ups@localhost are lost
      23. Sep 21 17:31:59 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      24. Sep 21 17:31:59 NAS upsmon[30492]: UPS ups@localhost is unavailable
      25. Sep 21 17:31:59 NAS upssched[30523]: Executing command: notify
      26. Sep 21 17:31:59 NAS upssched-cmd: Communications with the UPS ups@localhost cannot be established
      27. Sep 21 17:32:04 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      28. Sep 21 17:32:09 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      29. Sep 21 17:32:14 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      30. Sep 21 17:32:19 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      31. Sep 21 17:32:24 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      32. Sep 21 17:32:29 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      33. Sep 21 17:32:34 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      34. Sep 21 17:32:39 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      35. Sep 21 17:32:44 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      36. Sep 21 17:32:49 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      37. Sep 21 17:32:54 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      38. Sep 21 17:32:59 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      39. Sep 21 17:33:04 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      40. Sep 21 17:33:09 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      41. Sep 21 17:33:14 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      42. Sep 21 17:33:19 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      43. Sep 21 17:33:24 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      44. Sep 21 17:33:29 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      45. Sep 21 17:33:34 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      46. Sep 21 17:33:39 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      47. Sep 21 17:33:44 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      48. Sep 21 17:33:49 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      49. Sep 21 17:33:54 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      50. Sep 21 17:33:59 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      51. Sep 21 17:34:04 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      52. Sep 21 17:34:09 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      53. Sep 21 17:34:14 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      54. Sep 21 17:34:19 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      55. Sep 21 17:34:24 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      56. Sep 21 17:34:29 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      57. Sep 21 17:34:34 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      58. Sep 21 17:34:39 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      59. Sep 21 17:34:44 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      60. Sep 21 17:34:49 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      61. Sep 21 17:34:54 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      62. Sep 21 17:34:59 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      63. Sep 21 17:35:04 NAS upsmon[30492]: Poll UPS [ups@localhost] failed - Driver not connected
      Display All
    • ups.cfg

      Source Code

      1. [ups]
      2. driver=usbhid-ups
      3. port=auto


      When i try: upsdrvctl start

      Source Code

      1. Network UPS Tools - UPS driver controller 2.6.4
      2. Network UPS Tools - Generic HID driver 0.37 (2.6.4)
      3. USB communication driver 0.32
      4. Can't claim USB device [051d:0002]: could not detach kernel driver from interface 0: Operation not permitted
      5. Driver failed to start (exit status=1)


      lsusb

      Source Code

      1. ​Bus 001 Device 002: ID 8087:8008 Intel Corp.
      2. Bus 002 Device 002: ID 8087:8000 Intel Corp.
      3. Bus 003 Device 080: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
      4. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
      5. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
      6. Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
      7. Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub


      ls -l /dev/bus/usb/003/080

      Source Code

      1. crw-rw-r-T 1 root root 189, 335 Sep 21 17:48 /dev/bus/usb/003/080
    • APC Back-UPS CS 500
      On OMV 0.5 with this config were all OK

      dpkg -l | grep nut

      Source Code

      1. ​ii binutils 2.22-8 amd64 GNU assembler, linker and binary utilities
      2. ii bsdmainutils 9.0.3 amd64 collection of more utilities from FreeBSD
      3. ii debianutils 4.3.2 amd64 Miscellaneous utilities specific to Debian
      4. ii libcurl3-gnutls:amd64 7.26.0-1+wheezy10 amd64 easy-to-use client-side URL transfer library (GnuTLS flavour)
      5. ii libgnutls26:amd64 2.12.20-8+deb7u2 amd64 GNU TLS library - runtime library
      6. ii libneon27-gnutls 0.29.6-3 amd64 HTTP and WebDAV client library (GnuTLS enabled)
      7. ii nut 2.6.4-2.3+deb7u1 all network UPS tools - metapackage
      8. ii nut-client 2.6.4-2.3+deb7u1 amd64 network UPS tools - clients
      9. ii nut-server 2.6.4-2.3+deb7u1 amd64 network UPS tools - core system
      10. ii openmediavault-nut 1.0.2 all OpenMediaVault Network UPS Tools (NUT) plugin

      The post was edited 1 time, last by maxman ().

    • Checked graphs for UPS and they are not visible.
      When I refresh:

      Source Code

      1. ​Failed to execute command 'omv-mkgraph 2>&1': ERROR: No DS called 'value' in '/var/lib/rrdcached/db//localhost/nut-ups/percent-charge.rrd'
      2. Error #4000:
      3. exception 'OMVException' with message 'Failed to execute command 'omv-mkgraph 2>&1': ERROR: No DS called 'value' in '/var/lib/rrdcached/db//localhost/nut-ups/percent-charge.rrd'' in /usr/share/openmediavault/engined/rpc/rrd.inc:65
      4. Stack trace:
      5. #0 [internal function]: OMVRpcServiceRrd->generate(NULL, Array)
      6. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('generate', NULL, Array)
      8. #3 /usr/sbin/omv-engined(501): OMVRpc::exec('Rrd', 'generate', NULL, Array, 1)
      9. #4 {main}


      Only VARIABLES tab is functional