plex error #4000

    • OMV 1.0
    • Resolved
    • plex error #4000

      Hi I freshly installed OMV 1.0.
      Plex installed without problems but when I try to enable it I get the following error

      Source Code

      1. Error #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'omv-mkconf plexmediaserver 2>&1': Plex Media Server is not running (no process found)...
      3. usermod: directory /media/e512774d-adcb-45bd-9f9b-262c04fa25db/plexmediaserver exists' in /usr/share/openmediavault/engined/module/
      4. Stack trace:
      5. #0 /usr/share/openmediavault/engined/rpc/ OMVModulePlexMediaServer->applyConfig()
      6. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      7. #2 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      8. #3 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      9. #4 /usr/share/openmediavault/engined/rpc/ OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      10. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      11. #6 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      12. #7 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      13. #8 /usr/sbin/omv-engined(501): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      14. #9 {main
      Display All

      Plex was already installed on OMV 0.5 and I'm now trying to use the same database folder....


    • Is the plex server running then from what I see in you command service restart? Can you actually access through "http://IP_OF_OMV:32400/web/index.html" ?

      what's the output of ps ax | grep -i plex?
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server

      The post was edited 1 time, last by subzero79 ().

    • Back up your folder db first to some other location so you don't loose it. Try and set a new db manually to check if you can start the server in the first place.

      you can do that edit that in /etc/default/plexmediaserver and uncomment

      PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=/media/{uuid-disk}/plextest # don't forget to replace the uuid number of your disk

      create the previous folder and chmod -R plex:nogroup /media/{uuid-disk}/plextest

      start the server again and see if it works now.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server

      The post was edited 1 time, last by subzero79 ().

    • You can make them 777 but they still aren't executable because the drive is mounted noexec. So, probably not much danger.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • You only neeed "chmod -R 775". If you do 777 a user could possibly delete your folders/files from the plex interface. This is not desirable. It is better to delete things behind the scenes then risk that any user could delete things. Even with a chmod 775 on the shared folder the files/folders added/created via the samba share will follow options in the smb.conf, for the samba share in question.

      The post was edited 2 times, last by tekkb ().

    • Strangly running an ls -l I found that the owner of the folder was set as Btsync and the owner was nogroup! ...I don't know what happened!
      I realize that 777 was overkill...I just wanted to make sure that it worked.
      I'll revert the plex database folder to 775.

      Just to check, what owner/group should I have for the plexmediaserver folder?