Owncloud says that WebDAV is broken

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Owncloud says that WebDAV is broken

      Hi there,

      Installed Openmediavault Kralizec; installed Owncloud plugin with a self created certificate (CN=local ipaddress) and added domain.dyndns.org:8443 as a trusted domain into config.php. When I log in local with admin account there is no red message but logging in with admin account remotely via domain.dyndns.org:8443 I get a red message "Your webserver ... webdav seems to be broken ..."
      Anyone a solution about this?

    • If you are going to be connecting to the admin remotely all the time you should create your certificiate with domain.dydns.org:8443 as the common name. It seems here you need more then one certificate so as not gettings tons of errors in the log. You might want to try taking the force ssl connection off in the admin section. Then connect via http locally with admin and use https with cert created with common name domain.dyndns.org:844 remotely. There are some other issues with the plugin. If you add another shared folder or change any of the settings it will recreate the config.php. We are aware of some of the problems. They are getting less and less. After I get some time to lookover OC 7 I will make some suggestions to Volker to improve it. OC has been a difficult plugin in many way.

      PS- I would have answered you pm. Was finishing up at work. But it makes more sense to always post on forum. It is easier to answer/edit posts in forum than via pms.
    • Hi There,

      I'm having the same issues. I cant access owncloud at all externally form my domain. I've tried making several different certificates with different combinations with no luck. I've enabled my domain and port as trusted in the config file. I can access owncloud locally but its still says WebDAV broken regardless of the certificate settings. I've also tried turning off the force HTTPS setting in admin but it wont connect without SSL. My firewall is also open. I had this working perfectly in the earlier version of OMV.

      Could you please suggest anything else I could try to make this work ?( :)

      Cheers... Baldman :)
    • Hey hawkeye ,
      I'm sorry, I should have probably mentioned that I don't use it. I have a static IP with my own domain name. I am still having the same error though.

      Your web server is not yet properly setup to allow files synchronization because the WebDAV interface seems to be broken. Please double check the installation guides.
    • I think I found the problem.
      For some reason Owncloud is only working on the port specified for OMV. If I use the port I specified (8443) for Ownloud I cant access Owncloud at all. All of Owncloud seams to work fine on the same port as OMV. WEBDAV is working too but it still says its broken.

      How can I resolve this?... it would be nice to have OMV & OC on different ports:)

      The post was edited 4 times, last by baldman ().

    • I suggest you to ask that on the owncloud forum. ;)

      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Stupid me made a small typo mistake in my firewall, how embarrassing :S ... I checked it a few times too and never noticed!

      Thanks tekkb, I changed "Fileserver.local" to my local IP for OMV. That was the default setting after install so I wasn't sure of changing it. I have my public domain listed as second in the trusted domain config file (shown below). I do however still occasionally see that red error saying WebDAV is broken but it seams to work fine :/ . My OMV is on the other port so its all working.

      0 => '',
      1 => 'owncloud.mydomainname.com.:8443',

      Thanks for everyone's help,

      Cheers :)
    • hawkeye wrote:

      installed Owncloud plugin with a self created certificate (CN=local ipaddress)

      Hi hawkeye,

      have had a similar/the same problem with OwnCloud. Reason has been the CN in the certificate: It needs to be <servername>.<domain name> from general settings, not only domain name/IP address. After creating a new certificate with these CN and using it in OwnCloud all worked fine. Didn't need to change anything in the trusted_domains anymore.

      The post was edited 1 time, last by chris789 ().

    • Hello,
      I have the same issue but unfortunately nothing described here is working for me.

      I created a certificate with mydomain.dynu.com
      and edited the config.php like that

      'trusted_domains' =>
      array (
      0 => '',
      1 => 'mydomain.dynu.com:8443',

      But the webdav broken message isn't going away. Also when I try to use an app for owncloud I get the message that the server configuration is faulty.
      Anybody can help me to solve this problem? Would like to use an app to sync my pictures.