Hard drives won't mount anymore

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hard drives won't mount anymore

      I fix one thing then something else breaks!

      Just switched on server to find that none of my drives were mounted anymore. Just enabled the ext4 drive, but the other 2 are ntfs and will not mount at all. just keep getting:


      Source Code

      1. Failed to mount '/dev/disk/by-uuid/B0A69108A690D068': mount: can't find /dev/sda1 in /etc/fstab or /etc/mtab


      Same with the other drive.

      I have no idea why this would automatically unmount then refuse to remount. The target folders are in /media/ but the bloody thing will not work! Also, the fstab file looks as you would expect with no mention of the two drives anywhere.

      Please help
    • Ok, I tried the code but it makes no difference

      Source Code

      1. Error
      2. #6000:
      3. exception 'OMVException' with message 'Failed to mount
      4. '/dev/disk/by-uuid/B0A69108A690D068': mount: can't find
      5. /media/B0A69108A690D068 in /etc/fstab or /etc/mtab' in
      6. /usr/share/openmediavault/engined/module/fstab.inc:90
      7. Stack trace:
      8. #0 /usr/share/openmediavault/engined/rpc/config.inc(206):
      9. OMVModuleFsTab->startService()
      10. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array,
      11. Array)
      12. #2 /usr/share/php/openmediavault/rpcservice.inc(125):
      13. call_user_func_array(Array, Array)
      14. #3 /usr/share/php/openmediavault/rpcservice.inc(158):
      15. OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      16. #4 /usr/share/openmediavault/engined/rpc/config.inc(224):
      17. OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      18. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array,
      19. Array)
      20. #6 /usr/share/php/openmediavault/rpcservice.inc(125):
      21. call_user_func_array(Array, Array)
      22. #7 /usr/share/php/openmediavault/rpc.inc(79):
      23. OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      24. #8 /usr/sbin/omv-engined(501): OMVRpc::exec('Config', 'applyChangesBg',
      25. Array, Array, 1)
      26. #9 {main}
      Display All


      the error is with the drive I am NOT trying to mount at this this time.
      I also have an NFS share that is not in fstab but when I delete it from omv page and click apply I get the same error
    • Hi,

      i have the same issue. Hope someone can help me.


      Failed to mount '763de920-2576-4efe-b33d-1973f7f6ef9e': mount: can't find /media/763de920-2576-4efe-b33d-1973f7f6ef9e in /etc/fstab or /etc/mtab

      Source Code

      1. Error #6000:
      2. exception 'OMVException' with message 'Failed to mount '763de920-2576-4efe-b33d-1973f7f6ef9e': mount: can't find /media/763de920-2576-4efe-b33d-1973f7f6ef9e in /etc/fstab or /etc/mtab' in /usr/share/openmediavault/engined/module/fstab.inc:90Stack trace:#0 /usr/share/openmediavault/engined/rpc/config.inc(206): OMVModuleFsTab->startService()
      3. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      4. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      5. #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      6. #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(907): OMVRpc::exec('Config', 'applyChanges', Array, Array)
      7. #5 [internal function]: OMVRpcServiceFileSystemMgmt->mount(Array, Array)
      8. #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      9. #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('mount', Array, Array)
      10. #8 /usr/sbin/omv-engined(501): OMVRpc::exec('FileSystemMgmt', 'mount', Array, Array, 1)
      11. #9 {main}
      Display All


      ================================================================================
      = OS/Debian information
      ================================================================================
      Distributor ID: debian
      Description: Debian GNU/Linux jessie/sid
      Release: jessie/sid
      Codename:

      ================================================================================
      = OpenMediaVault information
      ================================================================================
      Release: 1.0.27.3
      Codename: Kralizec

      ================================================================================
      = System information
      ================================================================================
      Linux omv 3.16-2-amd64 #1 SMP Debian 3.16.3-2 (2014-09-20) x86_64 GNU/Linux
    • fstab

      Source Code

      1. # /etc/fstab: static file system information.
      2. #
      3. # Use 'blkid' to print the universally unique identifier for a
      4. # device; this may be used with UUID= as a more robust way to name devices
      5. # that works even if disks are added and removed. See fstab(5).
      6. #
      7. # <file system> <mount point> <type> <options> <dump> <pass>
      8. # / was on /dev/sda1 during installation
      9. UUID=fc6d6b56-ba51-4b1d-8346-afea217b4758 / ext4 noatime,nodiratime,discard,errors=remount-ro 0 1
      10. # swap was on /dev/sda5 during installation
      11. UUID=861ce8b6-f5f7-4ae9-8630-0f10ef6777e6 none swap sw 0 0
      12. /dev/sdd1 /media/usb0 auto rw,user,noauto 0 0
      13. # >>> [openmediavault]
      14. UUID=5297dbf7-50f4-4528-b619-749be3f25749 /media/5297dbf7-50f4-4528-b619-749be3f25749 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2# <<< [openmediavault]
      15. tmpfs /tmp tmpfs defaults 0 0
      Display All


      blkid

      Source Code

      1. /dev/sda5: UUID="861ce8b6-f5f7-4ae9-8630-0f10ef6777e6" TYPE="swap"
      2. /dev/sdb1: UUID="5297dbf7-50f4-4528-b619-749be3f25749" TYPE="ext4"
      3. /dev/sdc1: UUID="763de920-2576-4efe-b33d-1973f7f6ef9e" TYPE="ext4"
      4. /dev/sda1: UUID="fc6d6b56-ba51-4b1d-8346-afea217b4758" TYPE="ext4"
    • Source Code

      1. <fstab>
      2. <!--
      3. <mntent>
      4. <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</uuid>
      5. <fsname>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx|xxxx-xxxx|/dev/xxx</fsname>
      6. <dir>/xxx/yyy/zzz</dir>
      7. <type>ext2|ext3|ext4|xfs|jfs|iso9660|udf</type>
      8. <opts></opts>
      9. <freq>0</freq>
      10. <passno>0|1|2</passno>
      11. </mntent>
      12. -->
      13. <mntent>
      14. <uuid>e1e9eddc-a670-41f7-8664-969a670270ab</uuid>
      15. <fsname>763de920-2576-4efe-b33d-1973f7f6ef9e</fsname>
      16. <dir>/media/763de920-2576-4efe-b33d-1973f7f6ef9e</dir>
      17. <type>ext4</type>
      18. <opts>defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0</opts>
      19. <freq>0</freq>
      20. <passno>2</passno>
      21. <hidden>0</hidden>
      22. </mntent>
      23. <mntent>
      24. <uuid>0a11379a-70e5-45d8-8cca-e2d49c2b7113</uuid>
      25. <fsname>5297dbf7-50f4-4528-b619-749be3f25749</fsname>
      26. <dir>/media/5297dbf7-50f4-4528-b619-749be3f25749</dir>
      27. <type>ext4</type>
      28. <opts>defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0</opts>
      29. <freq>0</freq>
      30. <passno>2</passno>
      31. <hidden>0</hidden>
      32. </mntent>
      33. </fstab>
      34. <fstab>1</fstab>
      Display All
    • I think the issue is a missing @CR

      i run omv-mkconf fstab, fstab looks like

      Source Code

      1. # >>> [openmediavault]
      2. UUID=763de920-2576-4efe-b33d-1973f7f6ef9e /media/763de920-2576-4efe-b33d-1973f7f6ef9e ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2# <<< [openmediavault]


      mount -a
      [mntent]: line 14 in /etc/fstab is bad


      after editing fstab to

      Source Code

      1. # >>> [openmediavault]
      2. UUID=763de920-2576-4efe-b33d-1973f7f6ef9e /media/763de920-2576-4efe-b33d-1973f7f6ef9e ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      3. # <<< [openmediavault]


      mount -a works successfully
    • It should be writing two entries between the openmediavault keys. I don't know why it isn't. I would file a bug in the bugtracker and reference this thread.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Sorry for the late reply.

      WastlJ wrote:

      What´s your OMV version? Please upgrade first to newest OMV and then again follow aarons commands


      I am on the latest build, 1.0.27.3

      I have tried disconnecting the sata cables from the drives but they are still showing in file system (only as missing) but they are not showing in the Physical Disk section. I don't know where the info is being stored as fstab looks like this:

      Source Code

      1. # /etc/fstab: static file system information.
      2. #
      3. # Use 'blkid' to print the universally unique identifier for a
      4. # device; this may be used with UUID= as a more robust way to name devices
      5. # that works even if disks are added and removed. See fstab(5).
      6. #
      7. # <file system> <mount point> <type> <options> <dump> <pass>
      8. # / was on /dev/sda1 during installation
      9. UUID=6f7d613c-0520-4aae-914c-0274fce3b243 / ext4 errors=remount-ro 0 1
      10. # swap was on /dev/sda5 during installation
      11. UUID=5450677e-3dc6-407d-8494-0f891d387270 none swap sw 0 0
      12. /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
      13. /dev/sdb1 /media/usb0 auto rw,user,noauto 0 0
      14. tmpfs /tmp tmpfs defaults 0 0
      15. # >>> [openmediavault]
      16. # <<< [openmediavault]
      Display All

    • turrican wrote:

      Source Code

      1. <fstab>
      2. <!--
      3. <mntent>
      4. <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</uuid>
      5. <fsname>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx|xxxx-xxxx|/dev/xxx</fsname>
      6. <dir>/xxx/yyy/zzz</dir>
      7. <type>ext2|ext3|ext4|xfs|jfs|iso9660|udf</type>
      8. <opts></opts>
      9. <freq>0</freq>
      10. <passno>0|1|2</passno>
      11. </mntent>
      12. -->
      13. <mntent>
      14. <uuid>e1e9eddc-a670-41f7-8664-969a670270ab</uuid>
      15. <fsname>763de920-2576-4efe-b33d-1973f7f6ef9e</fsname>
      16. <dir>/media/763de920-2576-4efe-b33d-1973f7f6ef9e</dir>
      17. <type>ext4</type>
      18. <opts>defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0</opts>
      19. <freq>0</freq>
      20. <passno>2</passno>
      21. <hidden>0</hidden>
      22. </mntent>
      23. <mntent>
      24. <uuid>0a11379a-70e5-45d8-8cca-e2d49c2b7113</uuid>
      25. <fsname>5297dbf7-50f4-4528-b619-749be3f25749</fsname>
      26. <dir>/media/5297dbf7-50f4-4528-b619-749be3f25749</dir>
      27. <type>ext4</type>
      28. <opts>defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0</opts>
      29. <freq>0</freq>
      30. <passno>2</passno>
      31. <hidden>0</hidden>
      32. </mntent>
      33. </fstab>
      34. <fstab>1</fstab>
      Display All

      The config.xml file is corrupted. The line '<fstab>1</fstab>' is wrong. If you remove this it should work.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Okay, it's doing it again!!!! FFS, what is going on?????

      Here is the relevant section of config.xml:

      Source Code

      1. <fstab>
      2. <!--
      3. <mntent>
      4. <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</uuid>
      5. <fsname>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx|xxxx-xxxx|/dev/xxx</fsname>
      6. <dir>/xxx/yyy/zzz</dir>
      7. <type>ext2|ext3|ext4|xfs|jfs|iso9660|udf</type>
      8. <opts></opts>
      9. <freq>0</freq>
      10. <passno>0|1|2</passno>
      11. </mntent>
      12. -->
      13. <mntent>
      14. <uuid>acea5992-3743-42c0-b9a0-f8d706bbf453</uuid>
      15. <fsname>a6e632c0-fe42-44fb-944b-7405137843b4</fsname>
      16. <dir>/media/a6e632c0-fe42-44fb-944b-7405137843b4</dir>
      17. <type>ext4</type>
      18. <opts>defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0</opts>
      19. <freq>0</freq>
      20. <passno>2</passno>
      21. <hidden>0</hidden>
      22. </mntent>
      23. <mntent>
      24. <uuid>3d48726b-9776-4a52-987a-844e6cb4729d</uuid>
      25. <fsname>/dev/disk/by-uuid/B0A69108A690D068</fsname>
      26. <dir>/media/B0A69108A690D068</dir>
      27. <type>ntfs</type>
      28. <opts>defaults,nofail</opts>
      29. <freq>0</freq>
      30. <passno>2</passno>
      31. <hidden>0</hidden>
      32. </mntent>
      33. <mntent>
      34. <uuid>784707d8-7eb1-46a9-907c-d432c7d9680a</uuid>
      35. <fsname>/media/2FEAE88E665EDA39/</fsname>
      36. <dir>/export/MediaNFS</dir>
      37. <type>none</type>
      38. <opts>bind</opts>
      39. <freq>0</freq>
      40. <passno>0</passno>
      41. <hidden>0</hidden>
      42. </mntent>
      43. <mntent>
      44. <uuid>75e08da8-1494-45f8-80b6-b1ca2eb3c918</uuid>
      45. <fsname>/dev/disk/by-uuid/2FEAE88E665EDA39</fsname>
      46. <dir>/media/2FEAE88E665EDA39</dir>
      47. <type>ntfs</type>
      48. <opts>defaults,nofail</opts>
      49. <freq>0</freq>
      50. <passno>2</passno>
      51. <hidden>0</hidden>
      52. </mntent>
      53. </fstab>
      Display All

      and here is fstab:

      Source Code

      1. # /etc/fstab: static file system information.
      2. #
      3. # Use 'blkid' to print the universally unique identifier for a
      4. # device; this may be used with UUID= as a more robust way to name devices
      5. # that works even if disks are added and removed. See fstab(5).
      6. #
      7. # <file system> <mount point> <type> <options> <dump> <pass>
      8. # / was on /dev/sda1 during installation
      9. UUID=4fade403-a0a0-47ae-8b7c-3962272c00ce / ext4 errors=remount-ro 0 1
      10. # swap was on /dev/sda5 during installation
      11. UUID=f22cd855-0b5b-44f2-a37c-54a714b89cdf none swap sw 0 0
      12. /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
      13. /dev/sdb1 /media/usb0 auto rw,user,noauto 0 0
      14. tmpfs /tmp tmpfs defaults 0 0
      15. # >>> [openmediavault]
      16. UUID=a6e632c0-fe42-44fb-944b-7405137843b4 /media/a6e632c0-fe42-44fb-944b-7405137843b4 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      17. /dev/disk/by-uuid/B0A69108A690D068 /media/B0A69108A690D068 ntfs defaults,nofail 0 2
      18. /dev/disk/by-uuid/2FEAE88E665EDA39 /media/2FEAE88E665EDA39 ntfs defaults,nofail 0 2
      19. /media/2FEAE88E665EDA39/ /export/MediaNFS none bind 0 0
      20. # <<< [openmediavault]
      Display All


      I am getting the error:

      Failed
      to mount '/dev/disk/by-uuid/2FEAE88E665EDA39': fuse: failed to access
      mountpoint /media/2FEAE88E665EDA39: No such file or directory


      Very frustrating!
    • Hi!
      Finally fresh install of OMV1...(had to update kernel to wheezy, as running on ARM)
      A bit bumpy, but its now running. But I can't mount HD via Webgui (works on CLI)

      Source Code

      1. cat /etc/fstab

      [root@OXNAS:~]$.cat /etc/fstab
      # UNCONFIGURED FSTAB FOR BASE SYSTEM
      # >>> [openmediavault]
      UUID=abd590d7-a0c7-433d-a990-6100d28fbea7 /media/abd590d7-a0c7-433d-a990-6100d28fbea7 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      # <<< [openmediavault]


      Source Code

      1. cat /etc/openmediavault/config.xml | awk '/<fstab>/,/<\/fstab>/'

      <fstab>
      <!--
      <mntent>
      <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</uuid>
      <fsname>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx|xxxx-xxxx|/dev/xxx</fsname>
      <dir>/xxx/yyy/zzz</dir>
      <type>none|ext2|ext3|ext4|xfs|jfs|iso9660|udf|...</type>
      <opts></opts>
      <freq>0</freq>
      <passno>0|1|2</passno>
      <hidden>0|1</hidden>
      </mntent>
      -->
      </fstab>


      after trying to mount with Webgui:

      Source Code

      1. mount -a


      mount: wrong fs type, bad option, bad superblock on /dev/sda2,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail or so


      Source Code

      1. dmesg | tail

      [root@NAS:/]$.dmesg | tail
      [ 1247.114672] ata1: hard resetting link
      [ 1247.624693] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
      [ 1247.632248] ata1.00: configured for UDMA/133
      [ 1247.636608] ata1: EH complete
      [ 1247.643000] ox820sata: reseting SATA core
      [ 1248.000407] ata1: hard resetting link
      [ 1248.510397] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
      [ 1248.517934] ata1.00: configured for UDMA/133
      [ 1248.522370] ata1: EH complete
      [ 1398.556697] EXT4-fs (sda2): acl option not supported


      I can mount on CLI:
      [root@NAS:/media/abd590d7-a0c7-433d-a990-6100d28fbea7]$.df
      Filesystem 1K-blocks Used Available Use% Mounted on
      rootfs 8125880 928452 6761616 13% /
      udev 10240 0 10240 0% /dev
      tmpfs 25412 156 25256 1% /run
      /dev/sda1 8125880 928452 6761616 13% /
      tmpfs 5120 0 5120 0% /run/lock
      tmpfs 50820 0 50820 0% /run/shm
      /dev/sda2 1914442116 69032 1817102044 1% /media/abd590d7-a0c7-433d-a990-6100d28fbea7


      And its recognised in the Web of OMV. But when I go to add a shared folder the "Volume" drop down is empty..! Weird...

      The post was edited 2 times, last by telle ().