Can't get deluge to install...

    • OMV 1.0
    • Resolved
    • I've attached as txt file my deluge-damon script. Is the same that's around for debian with more logging, the one you pasted looks malformed. Look for the binaries location

      which deluged
      Files
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Ran the following using your script "sudo update-rc.d deluge-daemon defaults"...

      ... and got this:

      Source Code

      1. ​update-rc.d: using dependency based boot sequencing
      2. insserv: Script deluge-daemon.save.1 is broken: incomplete LSB comment.
      3. insserv: missing `Required-Start:' entry: please add even if empty.
      4. insserv: missing `Required-Stop:' entry: please add even if empty.
      5. insserv: missing `Default-Start:' entry: please add even if empty.
      6. insserv: missing `Default-Stop:' entry: please add even if empty.
      7. insserv: script deluge-daemon.save.1: service deluge-daemon already provided!
      8. insserv: script deluge-daemon.save.1: service Required-Start: already provided!
      9. insserv: script deluge-daemon.save.1 provides system facility $local_fs, skipped!
      10. insserv: script deluge-daemon.save.1 provides system facility $remote_fs, skipped!
      11. insserv: script deluge-daemon.save.1: service Required-Stop: already provided!
      12. insserv: script deluge-daemon.save.1 provides system facility $local_fs, skipped!
      13. insserv: script deluge-daemon.save.1 provides system facility $remote_fs, skipped!
      14. insserv: script deluge-daemon.save.1: service Should-Start: already provided!
      15. insserv: script deluge-daemon.save.1 provides system facility $network, skipped!
      16. insserv: Default-Start undefined, assuming empty start runlevel(s) for script `deluge-daemon.save.1'
      17. insserv: Default-Stop undefined, assuming empty stop runlevel(s) for script `deluge-daemon.save.1'
      Display All
    • Looks like you're pasting it wrongly. Try to put the file in init.d with winscp or something similar. Don't forget to chmod +x the script. Also remove the .txt extension.

      And also find out where the binaries for deluge are located in your system
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • I actually took the file you sent, didnt even open it, and removed the .txt. I uploaded it just like that and got the same error. I did chmod 755 originally but chmod -x doesnt seem to be doing anything different.

      In the file that dictates what user they run under I made them run under user "deluge" instead of "root". I figured I set up the permissions I needed just fine but could this cause an issue? What permissions do I need?
    • The deluge user doesn't exist, unless you create it. Let's first get deluge running under root.

      What happens when you type deluged in CLI?

      The output of the LSB script looks bad. try an access with nano the script

      nano /etc/init.d/deluge-daemon it should look like this sprunge.us/YRaO

      The init also loads this file /etc/default/deluge-daemon, which looks like this, if you don't have it create it

      Source Code

      1. # Configuration for /etc/init.d/deluge-daemon
      2. # The init.d script will only run if this variable non-empty.
      3. DELUGED_USER="root" # !!!CHANGE THIS!!!!
      4. # Should we run at startup?
      5. RUN_AT_STARTUP="YES"




      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • When I type deluged it does nothing; I assume that it is loading the process. Deluge-web is another story... it kind of hangs and I have to restart PuTTY and log back in.

      My init.d/deluge-daemon looks like yours. I copy and pasted yours directly into mine. I still get the same error message:

      Source Code

      1. ​root@znas:~# sudo update-rc.d deluge-daemon defaults
      2. update-rc.d: using dependency based boot sequencing
      3. insserv: script deluge-daemon is not an executable regular file, skipped!
      4. insserv: Script deluge-daemon.save.1 is broken: incomplete LSB comment.
      5. insserv: missing `Required-Start:' entry: please add even if empty.
      6. insserv: missing `Required-Stop:' entry: please add even if empty.
      7. insserv: missing `Default-Start:' entry: please add even if empty.
      8. insserv: missing `Default-Stop:' entry: please add even if empty.
      9. insserv: script deluge-daemon.save.1: service deluge-daemon already provided!
      10. insserv: script deluge-daemon.save.1: service Required-Start: already provided!
      11. insserv: script deluge-daemon.save.1 provides system facility $local_fs, skipped!
      12. insserv: script deluge-daemon.save.1 provides system facility $remote_fs, skipped!
      13. insserv: script deluge-daemon.save.1: service Required-Stop: already provided!
      14. insserv: script deluge-daemon.save.1 provides system facility $local_fs, skipped!
      15. insserv: script deluge-daemon.save.1 provides system facility $remote_fs, skipped!
      16. insserv: script deluge-daemon.save.1: service Should-Start: already provided!
      17. insserv: script deluge-daemon.save.1 provides system facility $network, skipped!
      18. insserv: Default-Start undefined, assuming empty start runlevel(s) for script `deluge-daemon.save.1'
      19. insserv: Default-Stop undefined, assuming empty stop runlevel(s) for script `deluge-daemon.save.1'
      Display All



      I did have /etc/default/deluge-daemon already. I had the user "deluge" in there. Yes, I did create the user "deluge". I changed the user in there to root just to see if I can get it working under that first.
    • "deluge" command works fine.

      "deluge-web -p 8112" does not.
      It just hangs and I have to restart PuTTY and log back in.

      If I go to my running services in OMV web interface I can see it but I am unable to "stop" it. I can only kill the process ID. I can stop "deluged" just fine though.
    • For some reason your deluge-web server is not working.
      Try another approach, kill all your running deluge daemons.
      Start a new daemon with deluged

      Download the GTK client to run in windows, switch it to classic mode in preferences, and then connect to the daemon with the omv ip address and port 58846.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • The bin's you delete them manually. The python related files take a look here at the end
      dev.deluge-torrent.org/wiki/In…Source#RemovingFromSystem

      If you build rasterbar, try and go to the rasterbar source folder and do make unintelligibleIf rasterbar comes from the repository just the ap-get remove will do it
      BTW I think they added the Ubuntu repo yesterday for Deluge try to update Omv-extras and check if you can make it run this time from there. When you build something from source like rasterbar instead of make install. Use checkinstall, that will make a standard deb package to remove for when you dont need then anymore
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • I have started a openmediavault-deluge plugin, it will not be as advanced as the transmission plugin but do what is needed.
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • It will use the latest version now @ 1.3.10. I do hope to have a test version ready by this evening but that depends on how thing go.
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS