Massive File Loss - due to plugin deinstallation?

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Massive File Loss - due to plugin deinstallation?

      Hi,

      I just realized basically all files on my NAS (more specifically, my data disk) are gone. Let me put my questions first before I go into detail. I want to know:
      • Why did this happen? (So I can avoid this scenario in the future.)
      • Is there a way to rescue my data, and if so, how?
      To explain what happened, let me give you a brief overview of my file structure:
      • Backups
      • Data*
      • eBooks*
      • ownCloud
      • plexmediaserver*
      The directories marked with a '*' have either disappeared or, in case of my Data directory, are empty. Backups, Data and eBooks are also Shares that I'm using for backing up my personal notebook, storing large files/file collections (e.g. pictures, movies,...) or for use with calibre, respectively.

      So, let me point out to you what I have done since I last checked that my files are still existent (i.e., what might have caused the loss of data):
      1. I uninstalled the calibre server (that I installed using the OMV-extras repo). It was set up to use the eBooks folder (configured as a share) for data storage.
      2. I played around a bit with couchpotato (that I installed using the OMV-extras repo) and configured it to move new movies to the Data directory, more precisely Data/Movies. That folder still existed after the data loss.
      3. I shutdown the server, plugged in a new harddisk containing some old backups of mine and copied the data onto my NAS them using rsync. For what it's worth, the exact command was:

        Source Code

        1. rsync --numeric-ids -aPvz /media/OldDiskUID/Music/* /media/myNasUID/Data/Music/

      4. I uninstalled Plex media server (that I installed using the OMV-extras repo). When doing so I encountered an error that the plexmediaserver directory was nonexistent, which might be a hint that the data loss occurred before this step.
      All of this happened in a time span of about 30 minutes and some of these steps were executed simultaneously, that is, doing the backup and uninstalling stuff in the web GUI.

      This is my setup: I run the latest version of OMV 1.0.* on a HP N54L using a SSD as system disk and 2 mirrored 2TB disks as data disk(s). As I said, I also plugged a new disk in in order to copy some old files to my NAS. The data disk(s) use XFS as file system, the disk that I plugged in uses ext4.

      I tried to find those missing files with testdisk, but it didn't show anything on that disk. Admittedly, I'm not an expert using this software though.

      So, I have been running both my new NAS and OMV for a week or two have been very happy so far. Thank you everyone for contributing and creating this awesome piece of software. I still think it's a great piece of software, however, I now need your help to avoid this scenario in the future and, hopefully, get my data back.

      Thank you very much,
      Daniel
    • What is the output of:

      ls -al /media/873d55a0-6559-4bee-8212-bfb84fb69727/
      ls -al /media/6dfe28b2-3133-4f34-af79-ddcdff82adf4/
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Source Code

      1. root@kairos:~# ls -al /media/873d55a0-6559-4bee-8212-bfb84fb69727/
      2. total 36
      3. drwxrwx---+ 5 1001 users 62 Oct 23 20:56 .
      4. drwxr-xr-x 6 root root 4096 Oct 23 20:27 ..
      5. drwxrwsr-x+ 2 root users 8192 Oct 20 21:17 Backups
      6. drwxrwsr-x+ 5 root users 42 Oct 23 21:02 Data
      7. drwxrwx---+ 6 www-data www-data 4096 Oct 20 22:17 ownCloud


      Source Code

      1. root@kairos:~# ls -al /media/6dfe28b2-3133-4f34-af79-ddcdff82adf4/
      2. total 72
      3. drwxr-xr-x 5 root root 4096 Oct 23 15:20 $RECYCLE.BIN
      4. drwxr-xr-x 11 root root 4096 Oct 23 21:16 .
      5. drwxr-xr-x 6 root root 4096 Oct 23 20:27 ..
      6. drwxr-xr-x 2 root root 4096 Oct 23 15:20 Automatic Backups
      7. drwxr-xr-x 8 root root 4096 Oct 23 15:20 Backup-13.04
      8. drwxr-xr-x 2 root root 4096 Oct 23 15:20 Backup-alt
      9. drwxr-xr-x 2 root root 4096 Oct 23 15:23 Downloads
      10. drwxr-xr-x 10 root root 4096 Oct 23 15:22 Education
      11. drwxr-xr-x 5 root root 4096 Oct 23 15:23 Filme
      12. -rw------- 1 root root 6144 Oct 23 21:16 aquota.group
      13. -rw------- 1 root root 6144 Oct 23 21:16 aquota.user
      14. drwxr-xr-x 4 root root 4096 Oct 23 15:26 bilder
      15. drwx------ 2 root root 16384 Oct 23 15:15 lost+found
      Display All


      EDIT: Just to be clear. /media/873d55a0-6559-4bee-8212-bfb84fb69727/ is the data partition on my NAS (2x2TB, raid 1). This is where the loss of data occurred. /media/6dfe28b2-3133-4f34-af79-ddcdff82adf4/ is the disk containing my old backup, that I plugged in before the data loss. (Note: My old backups are not complete, so it would be amazing to have my data back.)

      The post was edited 1 time, last by danpo ().

    • Did you look in the sub-folders from the command line to see if your data was there? According to your support info, there is data on the array (2% full).
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • (I have not looked at the Log) If the filesystem is Ext3/4 you can try to run extundelete (you may need it to run via systemrescuecd) and try to restore files, allways worth a try!

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Nope, there's only my Backups folder (which has not been deleted - who knows why...) and the data that I copied at some point during the data loss.

      Source Code

      1. root@kairos:/media/873d55a0-6559-4bee-8212-bfb84fb69727# du -hd 1
      2. 33G ./Data
      3. 13M ./ownCloud
      4. 3.5G ./Backups
      5. 36G .


      Unfortunately I'm using XFS and as far as I have seen, there is no xfsundelete. :(
    • photorec will work. Just doesn't recover filenames and directory structure.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      photorec will work. Just doesn't recover filenames and directory structure.

      That worked like a charm - thank you very much!!

      Still, the one question that remains is: What deleted the data? In the meanwhile I have set up Plex and calibre again, configured other services, rsynced more old data,... and everything works smoothly. I have no idea what may have caused the data loss. Maybe someone has an idea, so that I (and maybe others) can avoid similar hassle. Since I understand that this is a bit of guessing rather than actual bugfixing, I will eventually mark this thread as "solved".
    • Hard to say what caused the data loss. None of the plugins remove data even when uninstalled/purged.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!