file system now mounts under usb0 instead of uuid

    • file system now mounts under usb0 instead of uuid

      I'm (apparently) running OMV 1.0.24. (Why can't "About" tell the version number, instead of a tag cloud of random libraries? Seriously.)

      I've run into a problem mounting my USB drive. Normally, when I plug in the drive and click "File Systems | Mount", OMV looks up the drives UUID, creates a directory named /media/9f-blah-blah-blah and executes `mount -text4 /dev/sdf1 /media/9f-blah-blah-blah`. Now whenever I try to mount the drive, it complains /media/usb0 not existing, so I have to manually create that. Normally, I'd just say "whatever" and leave it at that, but because the drive isn't being mounted under /media/9f-blah-blah-blah, the usbbackup plugin refuses to run, saying it can't find the drive.

      Also, if you create /mnt/usb0, "File Systems | Mount" will work, but unmount won't, because it says it can't find the UUID of the drive.

      Source Code

      1. Error
      2. #3003:
      3. exception 'OMVException' with message 'Failed to get configuration
      4. (xpath=//system/fstab/mntent[uuid=''])' in
      5. /usr/share/php/openmediavault/rpcservice.inc:551
      6. Stack trace:
      7. #0 /usr/share/openmediavault/engined/rpc/fstab.inc(209):
      8. OMVRpcServiceAbstract->deleteConfigObjectByPath('//system/fstab/...',
      9. 'org.openmediava...')
      10. #1 [internal function]: OMVRpcServiceFsTab->delete(Array, Array)
      11. #2 /usr/share/php/openmediavault/rpcservice.inc(125):
      12. call_user_func_array(Array, Array)
      13. #3 /usr/share/php/openmediavault/rpc.inc(79):
      14. OMVRpcServiceAbstract->callMethod('delete', Array, Array)
      15. #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(991):
      16. OMVRpc::exec('FsTab', 'delete', Array, Array)
      17. #5 [internal function]: OMVRpcServiceFileSystemMgmt->umount(Array,
      18. Array)
      19. #6 /usr/share/php/openmediavault/rpcservice.inc(125):
      20. call_user_func_array(Array, Array)
      21. #7 /usr/share/php/openmediavault/rpc.inc(79):
      22. OMVRpcServiceAbstract->callMethod('umount', Array, Array)
      23. #8 /usr/sbin/omv-engined(501): OMVRpc::exec('FileSystemMgmt', 'umount',
      24. Array, Array, 1)
      25. #9 {main}
      Display All


      What caused changed the mount point, and how can I fix it?

      I'm pretty sure it was working before under 1.0.24 (but I don't really remember), so I'm at a loss. It definitely worked prior to my 1.0.24 upgrade in I guess October according the forum.

      The post was edited 1 time, last by jonathankoren ().

    • jonathankoren wrote:

      I'm (apparently) running OMV 1.0.24. (Why can't "About" tell the version number, instead of a tag cloud of random libraries? Seriously.)

      The version number is displayed in the start page 'Diagnostics | System Information | Overview''.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit