Updating omv (minor version) modifies nginx config - why?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Updating omv (minor version) modifies nginx config - why?

      Hi,

      Sometimes - not always - when I update OMV, the nginx configuration is "reset".
      The reason I notice this is, that I'm using nginx as a proxy for a lot of different webui's, to be accessible from the outside.
      This means, that a lot of traffic is bound on :80, but then redirected elsewhere.

      But, in the default OMV nginx config, there's 2 things that don't work with this setup:
      1. The server_name
      2. The port-configurations (listen)

      Is it possible, when making an update to the nginx configuration, to not touch those properties?
      Atom 330 @ 1.6GHz, 4GB RAM
      2x3TB Data, 1x3TB Parity, SnapRAID + AUFS pool
      Latest OMV running on custom Debain Wheezy, 3.14 Backports kernel
    • No, the nginx configuration is initially intended only for OMV, not for anything else.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • I do - it's just, that when updating omv, it changes the server_name setting, which is what nginx uses to determine what to serve when running multiple things on the same port.
      Furthermore, it sets the listen configs in a very strict way, allowing nothing else to be run on port 80/443.. And I need both omv, owncloud and my proxies to run on those ports! :)
      Atom 330 @ 1.6GHz, 4GB RAM
      2x3TB Data, 1x3TB Parity, SnapRAID + AUFS pool
      Latest OMV running on custom Debain Wheezy, 3.14 Backports kernel
    • It won't change if you use a separate configuration in sites enabled. Take a look at the guides for proxy pass in the forum. It can redirect requests in Port 80 by hostnames to another port keeping the different port hidden. Some sites require more skills in nginx some other are very simple
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • nslr wrote:

      I do - it's just, that when updating omv, it changes the server_name setting, which is what nginx uses to determine what to serve when running multiple things on the same port.
      Furthermore, it sets the listen configs in a very strict way, allowing nothing else to be run on port 80/443.. And I need both omv, owncloud and my proxies to run on those ports! :)

      To fix the server_name issue start by editing /etc/default/openmediavault. In that file, add (or edit) the line OMV_NGINX_SITE_WEBGUI_SERVERNAME="omv.lan" (replace omv.lan with what you want).

      What do you mean that it doesn't allow anything else to run on port 80/443? Because that's only true if you try to run for example Apache on the same ports or if you've configured Nginx wrong. Can you give an example of a config that doesn't work?
    • Thanks for pointing me towards /etc/default/openmediavault - hopefully that will fix the server_name issue.
      If you could point me towards the source-file for the OMV nginx config, i'd happily point out the parts, that I have to change to get stuff to work on my setup.

      I've also noticed, after an upgrade a few days ago, that my postfix setup has been screwed, but I don't know if that's related to OMV..
      Does OMV touch /etc/postfix/main.cf during upgrades? Because the mydestination property had been removed..
      Atom 330 @ 1.6GHz, 4GB RAM
      2x3TB Data, 1x3TB Parity, SnapRAID + AUFS pool
      Latest OMV running on custom Debain Wheezy, 3.14 Backports kernel

      The post was edited 3 times, last by nslr ().

    • nslr wrote:

      Thanks for pointing me towards /etc/default/openmediavault - hopefully that will fix the server_name issue.
      If you could point me towards the source-file for the OMV nginx config, i'd happily point out the parts, that I have to change to get stuff to work on my setup.

      I've also noticed, after an upgrade a few days ago, that my postfix setup has been screwed, but I don't know if that's related to OMV..
      Does OMV touch /etc/postfix/main.cf during upgrades? Because the mydestination property had been removed..

      The file /etc/postfix/main.cf is generated by OMV. If you use the wrong apt-get upgrade options you'll loose this config file. Because of that you have to use the omv-update command.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • So, not that i like "necroposting", but I've been experiencing this again, and this time I know how to reproduce the issue!

      When enabling/disabling (installing) for instance VirtualBox plugin (may be an issue with every plugin providing an webui-frame), the openmediavault-webgui config file is also updated with some pre-set default values.

      It just happens, that these default values mess up the rest of my nginx setup.
      To be exact, it's adding the IPv6 port listening options, that don't work.

      I don't see anywhere in the GUI to disable IPv6 access - is it possible to remove this default setup? It's a little annoying to have to look after the config file every time I install a plugin and then get an error (because restarting nginx failed)

      Also, after installing the Virtualbox plugin, I once more saw my postfix main.cf file had been changed. But I can't say if there's any direct relation there, enabling/disabling the plugin changes nothing in the postfix main.cf file.
      Atom 330 @ 1.6GHz, 4GB RAM
      2x3TB Data, 1x3TB Parity, SnapRAID + AUFS pool
      Latest OMV running on custom Debain Wheezy, 3.14 Backports kernel
    • nslr wrote:

      It just happens, that these default values mess up the rest of my nginx setup.
      To be exact, it's adding the IPv6 port listening options, that don't work.

      Should be fixed with sourceforge.net/p/openmediavault/code/1814 in openmediavault 2.0.5.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Great, what is the current state of OMV 2.x ? Is it only able to run on Debian 8, or can I get it now, without doing anything dangerous? ;)

      Edit: Looks like it's just a matter of getting latest 1.x, and then running "omv-release-upgrade" ?
      Atom 330 @ 1.6GHz, 4GB RAM
      2x3TB Data, 1x3TB Parity, SnapRAID + AUFS pool
      Latest OMV running on custom Debain Wheezy, 3.14 Backports kernel

      The post was edited 1 time, last by nslr ().

    • OMV 2.x doesn't work on Debian 8.

      The fix is still in svn for the moment.
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi, same problem. My server was von A+ von Qualys SSL Check. Now its back on B because somewhat in OMV or the nginx plugin is resetting ALL my custom settings. How do I stop this?

      Following NGINX settings are changed (as far as I observed)
      server_name
      ssl_ciphers
      add_header Strict-Transport-Security max-age=31536000;

      This is really annoying and a security issue!