Unionfilesystem Plugin

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Unionfilesystem Plugin

      Hi,

      first of all thank you for this plugin. To set up a pool with all your different data drives has never been easier. :) No need to use the command line for a mhddfs pool or to create shared folder manually on each drive in comparision to the normal aufs-plugin. :thumbsup:

      There are only two questions i'm not able to figure out by myself.
      • I created an aufs-pool but the files which I copied on it don't get spread any more according to which drive has the most free space. Does this function will come back in later versions or did i miss an option to configure it right?
      • Is it possible to restrict the available space for each user, so they won't be able to block the whole pool storage with their files? I tried it with the quota function but for the pool I only get the following error message: Invalid method parameter: 'false' does not match '/^[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}$/i'

        Source Code

        1. Fehler #2002:
        2. exception 'OMVException' with message 'Invalid method parameter: 'false' does not match '/^[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}$/i'' in /usr/share/php/openmediavault/rpcservice.inc:187
        3. Stack trace:
        4. #0 /usr/share/openmediavault/engined/rpc/quota.inc(68): OMVRpcServiceAbstract->validateMethodParams(Array, '{\n\t\t\t "type":"...')
        5. #1 [internal function]: OMVRpcServiceQuota->get(Array, Array)
        6. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
        7. #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('get', Array, Array)
        8. #4 /usr/sbin/omv-engined(500): OMVRpc::exec('Quota', 'get', Array, Array, 1)
        9. #5 {main}
      Thanks in advance!
    • 1 - aufs is supposed to put files on the drive with the most free space. That is its whole purpose. You didn't miss an option and there is no function to add. If it is not working, that is something I haven't been able to figure out. I can't replicate it.

      2 - No this isn't possible. If quotas don't work, I would guess they don't work with aufs. Never used quotas. You might be able to setup quotas on the drives themselves instead of the pool.
      omv 4.0.6 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • I've tested mhddfs before but only reached 50mb/s in writing and the copy only started after 10 or more seconds (temporarily "no response" on task manager of my win7 desktop). Get some strange error messages as well while copying files onto my server (something like he can't be reached anymore but the first file in queue was copied without any problem). So I went back to using aufs.
    • Strange, now the first data drive is full and I get a messages that my storage hasn't enough space. Although the pool has in total more than 5TB free space remaining. It seems that the new aufs-pool created with the unionfilesystem plugin basically do not work for me anymore. Setup the pool from scratch several times without success.
      Is there a possibility to install the "old" aufs plugin instead of the unionfs plugin? Both pooling and data writing on the drive with the most free space have worked very well on my server.
    • Try adding OMV_FSTAB_MNTOPS_AUFS="sum,create=mfs" to /etc/default/openmediavault. Change mfs to the one you want (look here under Policies for Creating to find out which you want). Then you'll have to run omv-mkconf fstab and remount the pool or reboot the server. Don't forget to check dmesg (I think?).

      About quota, it says
      If you want to use disk-quota, you should set it up to your writable branch since aufs does not have its own block device.
      here. I guess you could set up the quota for each drive and it'll will work.
    • Adding the line into it and followed your instructions. Does not work. I have two 3TB drives in my aufs pool but the files were still copied only to one of them.
      I would like to try the former aufs "standalone" plugin but after the latest omv-extras update I can't find it anymore. Haven't any problems with it. Can I download it somewhere else?
    • ryecoaaron wrote:

      Download it from here.

      Thanks for the link. I just want to try it, even if this plugin does the same on the paper. :)
      I have just tried it out and it works. Don't know, why the unionfs plugin causes problems on my server.

      HK-47 wrote:

      The only other think I can think of is that only one branch is read-write and the other ones is read-only? Or the even simpler error, the shared folders aren't setup on the pool but on the different filesystems on their own.

      Double-checked all my configurations and can't find anything wrong. The shared folder is setup on the created pool and the smb share shows me the entire pool storage size under windows.
    • Source Code

      1. root@Server:~# cat /etc/fstab
      2. # /etc/fstab: static file system information.
      3. #
      4. # Use 'blkid' to print the universally unique identifier for a
      5. # device; this may be used with UUID= as a more robust way to name devices
      6. # that works even if disks are added and removed. See fstab(5).
      7. #
      8. # <file system> <mount point> <type> <options> <dump> <pass>
      9. # / was on /dev/sda1 during installation
      10. UUID=57771ac6-abb5-4dd3-bbbf-c88b66a4922a / ext4 errors=remount-ro 0 1
      11. # swap was on /dev/sda5 during installation
      12. UUID=2460d800-8511-4227-b3da-31f38e33363f none swap sw 0 0
      13. /dev/sdh1 /media/usb0 auto rw,user,noauto 0 0
      14. /dev/sdh4 /media/usb1 auto rw,user,noauto 0 0
      15. tmpfs /tmp tmpfs defaults 0 0
      16. # >>> [openmediavault]
      17. UUID=9e041c16-21bd-4d8c-9920-c96f22aa95e1 /media/9e041c16-21bd-4d8c-9920-c96f22aa95e1 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      18. UUID=2ea509f4-2940-41d4-aabe-5133eed4586b /media/2ea509f4-2940-41d4-aabe-5133eed4586b ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      19. UUID=f390060e-efe0-4d97-90ff-4db45e1fd987 /media/f390060e-efe0-4d97-90ff-4db45e1fd987 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      20. UUID=b5b5e3ed-3bec-45d0-a7e5-0f599a28c00b /media/b5b5e3ed-3bec-45d0-a7e5-0f599a28c00b ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      21. UUID=efd9d592-a081-4f58-9a19-4b62a900d5b0 /media/efd9d592-a081-4f58-9a19-4b62a900d5b0 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      22. UUID=113193d2-253b-4b2c-b1d0-94b129fcbddb /media/113193d2-253b-4b2c-b1d0-94b129fcbddb ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      23. UUID=b82f286d-1b5e-49ee-96eb-f4941a002424 /media/b82f286d-1b5e-49ee-96eb-f4941a002424 ext4 defaults,nofail,acl,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 2
      24. none /media/Server aufs br:/media/f390060e-efe0-4d97-90ff-4db45e1fd987/D1/=rw:/media/b5b5e3ed-3bec-45d0-a7e5-0f599a28c00b/D2/=rw:/media/efd9d592-a081-4f58-9a19-4b62a900d5b0/D3/=rw:/media/113193d2-253b-4b2c-b1d0-94b129fcbddb/D5/=rw:/media/b82f286d-1b5e-49ee-96eb-f4941a002424/D6/=rw,sum,create=mfs,udba=reval 0 0
      25. /media/Server /media/f390060e-efe0-4d97-90ff-4db45e1fd987/Pool/ none bind 0 0
      26. # <<< [openmediavault]
      Display All
    • I just noticed the new plugin doesn't add the =rw for each branch and is missing udba=reval. Maybe this is causing the problem? I just noticed my aufs is not working either. I will do some tests...
      omv 4.0.6 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!

      The post was edited 1 time, last by ryecoaaron ().