Greyhole and MySQL no more working

    • OMV 1.0
    • Resolved
    • Greyhole and MySQL no more working

      Hi,

      Since 2 days, MySQL not responding..

      I attempt to purge mysql and re-install it but I have always the same problem message :

      Source Code

      1. Erreur #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'omv-mkconf mysql 2>&1': Unable to find any database files in /var/lib/mysql.
      3. Unable to find any database files in /media/b1c095e3-08cf-42ea-a182-361495564673/MySQL-DATA/.' in /usr/share/openmediavault/engined/module/mysql.inc:88
      4. Stack trace:
      5. #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleMySQL->applyConfig()
      6. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      8. #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      9. #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      10. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      11. #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      12. #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      13. #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      14. #9 {main}
      Display All


      any idea??

      tank you


      EDIT : I have see this on fresh install:

      Source Code

      1. ​Action 'configtest' failed.
      2. The Apache error log may have more information.
      3. Your apache2 configuration is broken, so we're not restarting it for you.
      NeurOSick
      Hardware ASRock N68C-GS, AMD FX-4100 8GB RAM
      OMV3 Distro + OMV-Extra + Docker + OpenVPN = Unlimited possibilities!

      The post was edited 1 time, last by NeurOSick ().

    • and why I have always this message error when I try to activate MySQL

      : Failed to execute command 'omv-mkconf mysql 2>&1': Unable to find any database files in /var/lib/mysql. Directory doesn't exist.

      this directory exist and have stuff in...
      NeurOSick
      Hardware ASRock N68C-GS, AMD FX-4100 8GB RAM
      OMV3 Distro + OMV-Extra + Docker + OpenVPN = Unlimited possibilities!

    • Can you send a support file using the Support Info tab and let me know the id?
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Ok. I don't use teamviewer much so I don't know all the options. PM your details :)
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • resolved by purge all mysql services and config files and do a fresh install

      Special tanks to ryecoaaron for his dedication. Without guys like him (and other active members as Davidh2k, tekkb, jhmiller and all other, and excuse me if I miss names) OMV would not be what it is today.

      Tank you.. and keep it up guys! :)
      NeurOSick
      Hardware ASRock N68C-GS, AMD FX-4100 8GB RAM
      OMV3 Distro + OMV-Extra + Docker + OpenVPN = Unlimited possibilities!