HP N54L - NIC Stuck at 100mbps

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • HP N54L - NIC Stuck at 100mbps

      Hello everyone,

      Thanks in advance for any knowledge that you can part with. I have Googled pretty heavily and tried all methods to fix this NIC issue but with no luck. As the subject line says my NIC in my N54L Microserver is stuck at 100mbps. The N54L is plugged directly in my Gigbit ASUS router and then another port links to a unmanaged 16 port netgear switch. I have replaced cables, replaced router, installed backport kernel and also tried "autoneg off speed 1000 duplex full" install extra params in the network section.

      Here is a paste from the 'system information' tab in the GUI. This is getting pretty frustrating as the server has not been able to work fast enough for my daily work!


      Any help you can give would be much appreciated.



      Brainfuck Source Code

      1. ================================================================================
      2. = OS/Debian information
      3. ================================================================================
      4. Distributor ID: debian
      5. Description: Debian GNU/Linux 7 (wheezy)
      6. Release: 7.7
      7. Codename: wheezy
      8. ================================================================================
      9. = OpenMediaVault information
      10. ================================================================================
      11. Release: 1.6
      12. Codename: Kralizec
      13. ================================================================================
      14. = Date
      15. ================================================================================
      16. Tuesday 16 December 23:33:42 AEDT 2014
      17. ================================================================================
      18. = Locale
      19. ================================================================================
      20. en_AU.UTF-8
      21. ================================================================================
      22. = System information
      23. ================================================================================
      24. Linux openmediavault 3.16.0-0.bpo.4-amd64 #1 SMP Debian 3.16.7-ckt2-1~bpo70+1 (2014-12-08) x86_64 GNU/Linux
      25. ================================================================================
      26. = Uptime
      27. ================================================================================
      28. 23:33:42 up 2 min, 0 users, load average: 0.35, 0.09, 0.03
      29. ================================================================================
      30. = Network interfaces
      31. ================================================================================
      32. 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
      33. link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      34. inet 127.0.0.1/8 scope host lo
      35. valid_lft forever preferred_lft forever
      36. inet6 ::1/128 scope host
      37. valid_lft forever preferred_lft forever
      38. 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
      39. link/ether c8:cb:b8:c5:38:ea brd ff:ff:ff:ff:ff:ff
      40. inet 192.168.1.168/24 brd 192.168.1.255 scope global eth0
      41. valid_lft forever preferred_lft forever
      42. --------------------------------------------------------------------------------
      43. Interface information eth0:
      44. ===========================
      45. Settings for eth0:
      46. Supported ports: [ TP ]
      47. Supported link modes: 10baseT/Half 10baseT/Full
      48. 100baseT/Half 100baseT/Full
      49. 1000baseT/Half 1000baseT/Full
      50. Supported pause frame use: No
      51. Supports auto-negotiation: Yes
      52. Advertised link modes: 10baseT/Half 10baseT/Full
      53. 100baseT/Half 100baseT/Full
      54. 1000baseT/Half 1000baseT/Full
      55. Advertised pause frame use: Symmetric
      56. Advertised auto-negotiation: Yes
      57. Link partner advertised link modes: 10baseT/Half 10baseT/Full
      58. 100baseT/Half 100baseT/Full
      59. Link partner advertised pause frame use: Symmetric Receive-only
      60. Link partner advertised auto-negotiation: Yes
      61. Speed: 100Mb/s
      62. Duplex: Full
      63. Port: Twisted Pair
      64. PHYAD: 1
      65. Transceiver: internal
      66. Auto-negotiation: on
      67. MDI-X: on
      68. Supports Wake-on: g
      69. Wake-on: g
      70. Current message level: 0x000000ff (255)
      71. drv probe link timer ifdown ifup rx_err tx_err
      72. Link detected: yes
      73. --------------------------------------------------------------------------------
      74. Driver information eth0:
      75. ========================
      76. driver: tg3
      77. version: 3.137
      78. firmware-version: 5723-v3.35
      79. bus-info: 0000:02:00.0
      80. supports-statistics: yes
      81. supports-test: yes
      82. supports-eeprom-access: yes
      83. supports-register-dump: yes
      84. supports-priv-flags: no
      Display All

      The post was edited 1 time, last by davidh2k ().

    • Have you checked physical matters? Tried another Router-Port? Pluged in directly to the switch? Other networkcabel?

      Source Code

      1. Driver information eth0:
      2. ========================
      3. driver: tg3
      4. version: 3.121
      5. firmware-version: 5723-v3.35
      6. bus-info: 0000:03:00.0
      7. supports-statistics: yes
      8. supports-test: yes
      9. supports-eeprom-access: yes
      10. supports-register-dump: yes
      11. supports-priv-flags: no
      Display All


      I have another driver, do you use backports kernel?
      | HP Microserver N54L | 8GB RAM (ECC) | BIOS-Mod | 6 Disks - 40GB Intel SSD (Erasmus), 40GB Intel SSD (VMStore), 2TB Seagate NAS HDD (Data), 2TB WD Red (DataBackup), 6TB WD Red (Rec), 6TB WD Red (RecBackup) | Delock PCI-E USB 3.0 (Art. 89315) | deleyCON Dual DS 2x USB 3.0, 1x 2,5" & 1x 3,5" HDD | APC Back-UPS ES 700G | rsync to remote site | NFS | SMB/CIFS | SSH | omv-extras.org - VirtualBox |
    • Link partner advertised link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full

      That's the point. To which device is eth0 connected? Are you sure that this netgear thingy is gigabit capable, which model?
      Homebox: Bitfenix Prodigy Case, ASUS E45M1-I DELUXE ITX, 8GB RAM, 5x 4TB HGST Raid-5 Data, 1x 320GB 2,5" WD Bootdrive via eSATA from the backside
      Companybox 1: Standard Midi-Tower, Intel S3420 MoBo, Xeon 3450 CPU, 16GB RAM, 5x 2TB Seagate Data, 1x 80GB Samsung Bootdrive - testing for iSCSI to ESXi-Hosts
      Companybox 2: 19" Rackservercase 4HE, Intel S975XBX2 MoBo, C2D@2200MHz, 8GB RAM, HP P212 Raidcontroller, 4x 1TB WD Raid-0 Data, 80GB Samsung Bootdrive, Intel 1000Pro DualPort (Bonded in a VLAN) - Temp-NFS-storage for ESXi-Hosts
    • The N40L / N54L is works with gigabit OOTB with OMV since OMV 1.0 and before. So this is definitely a problem with your switch/router. Or maybe a damaged NIC. You could try that by plugging in a PCIe NIC and test it.
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • Greeting from Melbourne, Australia and thanks for all the replies.

      @nachtmensch - I have tried all that you have mentioned. Replaced cable, different router port and connected directly to the switch all with the same result. I am also running the back ports kernel. What is this other driver you have?

      @subzero79 - Router model is ASUS DSL-AC68U. Pretty serious gear and definitely Gigabit ports.

      @datadigger- eth0 is connected directly to port 2 on the ASUS DSL-AC68U.

      @WastlJ - I thought about purchasing an PCIe Intel NIC but that will set me back $50 which isn't much but I'd rather get the built in NIC working. This N54l is only 2 years old!


      The NIC used to connect at 1000mbps when I was running a much earlier version of OMV. So the change just suddenly happened overnight. Do think the damaged NIC is more likely to be on the router or switch as opposed to the N54l? The status does say that the "Advertised Link Modes" can support 1000mbps, it's just the partner NIC doesn't reflect that...

      Is it possible to plug the N54l directly into the port of a PC running Windows 8.1 ? Is that feasible test? Mayhbe I could run an Ubuntu live stick and see what that shows..

      Any more thoughts?


      EDIT - Can anyone recommend the model number of a stable INTEL NIC?

      The post was edited 1 time, last by Slikkit ().

    • Check energy saving settings in the router. It may drop to 100mbit die to energy saving settings.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • I don't use backports... maybe your "newer" driver is causing problems?
      | HP Microserver N54L | 8GB RAM (ECC) | BIOS-Mod | 6 Disks - 40GB Intel SSD (Erasmus), 40GB Intel SSD (VMStore), 2TB Seagate NAS HDD (Data), 2TB WD Red (DataBackup), 6TB WD Red (Rec), 6TB WD Red (RecBackup) | Delock PCI-E USB 3.0 (Art. 89315) | deleyCON Dual DS 2x USB 3.0, 1x 2,5" & 1x 3,5" HDD | APC Back-UPS ES 700G | rsync to remote site | NFS | SMB/CIFS | SSH | omv-extras.org - VirtualBox |
    • My issue was the cable. bought a cat6a cable and straight to 1000mbps - my torrents are now flying. BTW, I googled my other issue which was the tun0 speed showing as 10mbps. This is standard apparently, its a 'placeholder' as the local machine cannot obviously know the true speed of the VPN to which its connected.