No HDD Spin down

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • No HDD Spin down

      first I'm sorry for that english, I'm wondering if it's ok to write in german here?

      Ok, so i've got a problem with my NAS.
      I'm using a HP micoserver Gen8 with following config:
      - 3x WD Green 2TB (Raid 5 created with OMV)
      - 32GB SSD (OMV System)
      - Mico SD for GRUB Bootloader

      - No Plugins inatalled
      - No shared folders
      - SMART active

      I created an ext4 filesystem on the raid.
      If I mount the filesystem, there is a permanently data transfer on the HDD's, nearly all 5secs there is a "click" on the hard drives (HDD LED blinks up too).
      So the Disk aren't able to go in spin down. I don't realy know much about debian, so thats what i've done:
      - Made an manual spin down : ( hdparm -y /dev/sdc ) : HDD immediately Spins up again
      Without a file system manual Spindown is possible, HDDs spinning up when the Web GUI is used.
      - Use IOtop to find out what's goning on.
      I've read abput that process but the only thing I found out, that the jbd2 is used by many other processes.

      HDD Spindown is realy important for me.

      Can anyone help me?
      Best Regards
      • putty.png

        38.85 kB, 776×238, viewed 701 times
    • Ok so I've to wait some time?
      Between, i've added another HDD (250GB) and created a ext4 Filesystem too.
      The Spindown works and the drive is spinning up when i access on it using SMB.
      Is it possible that the raid causes the data transfer on the disks?

      Another Question (sorry):
      I've created a share, used it in SMB, deleted it there (now it is not in use anywhere) but i can't delte the share, OMV says it is still in use.
      Is it possible so see where the share is used?

      • OrdnerinVerwendung.PNG

        17.79 kB, 610×313, viewed 590 times

      The post was edited 1 time, last by M4st3rM ().

    • Well after a day I would get suspicious about that if jbd2 is still writing constantly. Unless you have torrent downloader or similar.

      OMV does not have a database back end yet to provide which service is locking the share.

      You can look at the config.xml at /etc/openmediavault/config.xml to find where is share being used

      The most common and not looked place that people always forget about is: reset permission section (tab next to your screen-shot) or home folder for users section, in settings next tab to Users.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • Ok thank you.
      I've searched in the config.xml but theres nothing to find whats using this share. I deleted the entrys in the config.xml, after that it was possible to delete the filesystem. Reset permissions doesn't solved the problem.

      Now the problem changed. The writing was still active, so i decided to try something else:
      I created a XFX Filesystem on the raid drives. Now it is possible to set them manually to spin down and they stay there until a "real" file transfer starts. The only thing is that they don't spin down automatically. I've read about it and found out that mdadm checks the raid too often.
      Now i've two options:
      - Find a way to prolong the time between mdadm checks the raid
      - Write a script which set the inactive hdds in spin-down manually

      Other ideas?

      Best regards
    • I have the exact same problem, and is very obvious by looking at my NAS HD LED.

      IN my case, I have one Seagate 4TB NAs drive, and one Seagate 3TB desktop drive. As long as the drive is formatted to EXT4 and is mounted, the drive stays active. THe LED blinks about once every second. XFS doesn't have this problem.