sickbeard errors

    • sickbeard errors

      HI,

      I have installed sickbeard using the OMV multi application installer V1.9.10 but im getting en error when im trying to open the webpage:

      Traceback (most recent call last):
      File "/sickbeard/cherrypy/wsgiserver/__init__.py", line 1202, in communicate
      req.parse_request()
      File "/sickbeard/cherrypy/wsgiserver/__init__.py", line 506, in parse_request
      self._parse_request()
      File "/sickbeard/cherrypy/wsgiserver/__init__.py", line 554, in _parse_request
      if '#' in path:
      TypeError: argument of type 'NoneType' is not iterable

      Im running OMV V1.8
      Anybody knows where this is comming from ?
      OMV 3 (almost.. ) - 64 bit
      Unas 810A case + Asrock rack E3C236D4U, Xeon E3-1235l V3, 4gb ECC, 6 x 3TB (UNRAID 5)
      OMV on 128GB NVME
    • Not directly an answer to your question, but my suggestion would be to use the Sickbeard provided by the OMV Extras repository. This plugin is very easy to install through the web interface. It also gives you the flexibility of chosing a different fork for Sickbeard by providing an option to specify a GIT repository for the fork. I use this for example to use Sickrage (sickrage.tv).

      Hope this helps
    • I second that... I use the plugin and added the sickrage git link manually... everything works like a charm... I've found that if the web interface never loads or gives errors that I need to delete the config and db located at /home/sickbeard after you delete it will be regenerated.
      I'd install the plugin, change to sickrage repo (as that is the most active sickbeard repo currently) then go and delete the old config and db to ensure no snags... then reboot OMV OR enable/disable the sickbeard plugin and you should be off to the races.
      maybe that will help you.
    • i checked wich python packages where installed and i found this:

      Source Code

      1. ​rc python 2.7.3-4+deb7u1 all interactive high-level object-oriented language (default
      2. ii python-apt-common 0.8.8.2 all Python interface to libapt-pkg (locales)
      3. rc python-gi 3.2.2-2 amd64 Python 2.x bindings for gobject-introspection libraries
      4. ii python-minimal 2.7.3-4+deb7u1 all minimal subset of the Python language (default version)
      5. rc python-support 1.0.15 all automated rebuilding support for Python modules
      6. ii python2.6 2.6.8-1.1 amd64 Interactive high-level object-oriented language (version
      7. ii python2.6-minimal 2.6.8-1.1 amd64 Minimal subset of the Python language (version 2.6)
      8. ii python2.7 2.7.3-6+deb7u2 amd64 Interactive high-level object-oriented language (version
      9. ii python2.7-dev 2.7.3-6+deb7u2 amd64 Header files and a static library for Python (v2.7)
      10. ii python2.7-minimal 2.7.3-6+deb7u2 amd64 Minimal subset of the Python language (version 2.7)
      11. ii python3 3.2.3-6 all interactive high-level object-oriented language (default
      12. ii python3-apt 0.8.8.2 amd64 Python 3 interface to libapt-pkg
      13. ii python3-minimal 3.2.3-6 all minimal subset of the Python language (default python3 ve
      14. ii python3.2 3.2.3-7 amd64 Interactive high-level object-oriented language (version
      15. ii python3.2-minimal 3.2.3-7 amd64 Minimal subset of the Python language (version 3.2)
      16. ii qdbus 4:4.8.2+dfsg-11 amd64
      Display All


      Can this cause problems having multiple python versions installed??
      OMV 3 (almost.. ) - 64 bit
      Unas 810A case + Asrock rack E3C236D4U, Xeon E3-1235l V3, 4gb ECC, 6 x 3TB (UNRAID 5)
      OMV on 128GB NVME
    • Having the same issue. Clean install of OMV and SickBeard.
      I've installed Sickbeard provided by the OMV Extras repository. I get no install errors but when I launch the interface I get the same error as y_boonstra

      Traceback (most recent call last):File "/sickbeard/cherrypy/wsgiserver/__init__.py", line 1202, in communicatereq.parse_request()File "/sickbeard/cherrypy/wsgiserver/__init__.py", line 506, in parse_requestself._parse_request()File "/sickbeard/cherrypy/wsgiserver/__init__.py", line 554, in _parse_requestif '#' in path:TypeError: argument of type 'NoneType' is not iterable

      I followed ryanmillet suggestion and setup the Sickragetv fork but now I get page cannot be displayed (or No data received in Chrome)

      Also my /home/sickbeard folder is empty.

      Any suggestions?
    • The folder(s) have a leading dot, so they don't show up with ls -l, you need to use ls -la to list them.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.