No magic packets sent from network-bridge in OMV

    • OMV 1.0
    • No magic packets sent from network-bridge in OMV

      As i mentioned, i have two microserver with OMV 1.8: my 24/7 NAS, and my backupserver. Rsync to sync from NAS to backupserver already runs. Now i am trying to automate the backup with waking the backupserver, start the rsync-job and shutdown the backupserver when the job is done.

      I installed the WOL-plugin on the source machines and added an entry with the the backupservers name, MAC and IP in the machine-list manually. I did that manually, because scan ended with an error-message. I think the error is caused by the fact that my machine has a network-bridge between eth0, the internal NIC, and eth1, another NIC with Intel-Chipset, that i installed, because there wasn't a free port left in the switch in my server compartment, and because the internal Broadcom-NIC seemed to be a little too slow.

      When i send magic packets to the backupserver from my mobile connected to the LAN, the backupserver wakes up instantly from poweroff, but it doesn't, when i click on send in it's WOL-entry on my NAS.

      Is it generally possible to send magic packets from a computer, that is connected to the network via bridged NICs?

      In this case eth1 is physically connected to the LAN, and eth0 is connected to the backupserver. But when the machine and the bridge is up, there are logically neither eth0 nor eth1, just br0.

      BR
      Jan

      The post was edited 4 times, last by JanN ().

    • Shot on the dark:
      maybe you can check the MAC of your br0-NIC with "ifconfig" and see, if it is different. Use this MAC for wol then.
      "Glowing days. Don't cry because they are over. Smile because they happened." - Confucius

      Server: 1x 32GB SSD (system) - 5x 2TB Data - 1x 2TB Snapraid-Parity - latest OMV 1.x
      No Support through PM
      Tutorials --- Howto install OMV-Extras --- Upgrade/Update-Problems --- If autoshutdown doesn' -work
    • A friend of mine got almost the same error. He was not able to wake his backup machine via his network bridge. He solved it by installind DDWRT and set a few values in the settings. Lately he purchased powerline adapters which work even better. ;)
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • @Solo0815
      I don't want to wake up the machine with the bridge - that is my always on NAS. That should wake up the backupserver, that is connected to one of the bridges NICs. It think, that the WOL-plugin always try to send magic packets via eth0, that doesn't exist in my NAS.

      Any idea, where the plugin stores it's settings? Perhaps i can fix the sender interface and MAC there.

      @WastlJ
      There is no problem with my router (Fritz 7390) and the routing over the bridge, as i can send magic packets to the backupserver via LAN from my mobile. And my LAN obviously works correctly too.


      By the way: it were great to have the chance to set up and configure a bridge in the network-section of the webgui - in the moment i just see the manually via cli configured interface, but i can't edit it in the gui. And when i edit the other interfaces, my bridge will be overwritten in /etc/network/interfaces .

      BR
      Jan

      The post was edited 1 time, last by JanN ().

    • The scan calls the util nast, like nast -m you can narrow the scan to interface in CLI let's say nast -m -i br0 it should give you a list of all host in the bridge since that's the function of the bridge to be transparent in between the two nics.

      Don't know if this needs to be fixed in the core or the plugin
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • subzero79 wrote:

      The scan calls the util nast, like nast -m you can narrow the scan to interface in CLI let's say nast -m -i br0 it should give you a list of all host in the bridge since that's the function of the bridge to be transparent in between the two nics.

      Don't know if this needs to be fixed in the core or the plugin


      Thanks, subzero79, nast -m -i br0 makes the job of listing the machines in my LAN.

      Where can that be fixed?

      BR
      Jan
    • nast is installed by the wol plugin. So, no core changes or bugtracker reports needed.

      Not sure why nast doesn't use br0 when no network adapter is specified. It is supposed to be auto-detected. What is the output of: ifconfig -a
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • @ryecoaaron
      Sorry, i just posted a bugreport before i found your answer...

      root@SERVER:~# ifconfig -a
      br0 Link encap:Ethernet Hardware Adresse 00:23:7d:fc:dc:7c
      inet Adresse:192.168.151.4 Bcast:192.168.151.255 Maske:255.255.255.0
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
      RX packets:775739 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1578239 errors:0 dropped:0 overruns:0 carrier:0
      Kollisionen:0 Sendewarteschlangenlänge:0
      RX bytes:128722642 (122.7 MiB) TX bytes:5684656861 (5.2 GiB)

      eth0 Link encap:Ethernet Hardware Adresse 38:ea:a7:ab:ed:68
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
      RX packets:664218 errors:0 dropped:0 overruns:0 frame:0
      TX packets:4167483 errors:0 dropped:0 overruns:0 carrier:0
      Kollisionen:0 Sendewarteschlangenlänge:1000
      RX bytes:63140086 (60.2 MiB) TX bytes:5903584602 (5.4 GiB)
      Interrupt:18

      eth1 Link encap:Ethernet Hardware Adresse 00:23:7d:fc:dc:7c
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
      RX packets:119832 errors:0 dropped:0 overruns:0 frame:0
      TX packets:195599 errors:0 dropped:0 overruns:0 carrier:0
      Kollisionen:0 Sendewarteschlangenlänge:1000
      RX bytes:80135261 (76.4 MiB) TX bytes:41095267 (39.1 MiB)
      Interrupt:18 Speicher:fdfe0000-fe000000

      lo Link encap:Lokale Schleife
      inet Adresse:127.0.0.1 Maske:255.0.0.0
      inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
      UP LOOPBACK RUNNING MTU:16436 Metrik:1
      RX packets:1037 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1037 errors:0 dropped:0 overruns:0 carrier:0
      Kollisionen:0 Sendewarteschlangenlänge:0
      RX bytes:568910 (555.5 KiB) TX bytes:568910 (555.5 KiB)

      BR
      Jan
    • I guess I will have to add option to pick interface since it isn't auto-detecting correctly.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!