Wake on LAN stopped working

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wake on LAN stopped working

      Hi there,

      I installed a new network card (onboard NIC was too slow), enabled Wake on LAN in the Web-GUI and everything worked fine. System went down to S3 and woke on magic packet several times without any problems.

      Now, after a day, I can't wake it up by a magic packet anymore. The only thing I changed in the meantime was to set the RTC to localtime and configure NTP likewise (which I reversed to troubleshoot).

      I tested every BIOS-Option related to ACPI and WOL and restarted, suspended the system at least a hundred times. Didn't work... ?(

      ethtool eth1 shows:
      Supported ports: [ TP MII ]
      Supported link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Half 1000baseT/Full
      Supported pause frame use: No
      Supports auto-negotiation: Yes
      Advertised link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Half 1000baseT/Full
      Advertised pause frame use: Symmetric Receive-only
      Advertised auto-negotiation: Yes
      Link partner advertised link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Half 1000baseT/Full
      Link partner advertised pause frame use: Symmetric Receive-only
      Link partner advertised auto-negotiation: Yes
      Speed: 1000Mb/s
      Duplex: Full
      Port: MII
      PHYAD: 0
      Transceiver: internal
      Auto-negotiation: on
      Supports Wake-on: pumbg
      Wake-on: g
      Current message level: 0x00000033 (51)
      drv probe ifdown ifup
      Link detected: yes


      /etc/network/interfaces:
      auto lo
      iface lo inet loopback
      iface lo inet6 loopback

      # eth1 network interface
      auto eth1
      allow-hotplug eth1
      iface eth1 inet dhcp
      dns-nameservers 192.168.0.1
      dns-search fritz.box
      pre-down ethtool -s $IFACE wol g
      iface eth1 inet6 manual
      pre-down ip -6 addr flush dev eth1


      I already changed NETDOWN to "no" in /etc/init.d/halt. I disabled the onboard NIC as soon as I installed the new one.

      Does anyone know a solution or a way to troubleshoot this?

      Thank you!
      OhSiris

      My System:
      MB: EPIA-M 10000
      NIC: RTL8169/8110 Family PCI Gigabit Ethernet NIC

      EDIT: Solution is quite simple buy a Intel network card (see last post :)

      The post was edited 3 times, last by ohsiris ().

    • Might be the driver, you can try the realtek driver and build your own.

      unix.stackexchange.com/questio…-given-device-realtek-nic

      Also make sure in the server that the magic packet is being broadcasted and received in the LAN

      tcpdump -i eth0 'port 9' -vvv should give output if a magic packet is received
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Thank you for your answer!

      tcpdump showed incoming magic packets on the server.

      But, compile your driver... Not as simple as it sounds :S

      Just for the beginners out there, you need to install some stuff first to compile the driver:
      apt-get install build-essentials
      apt-get install linux-headers-$(uname -r)


      I tried two drivers, the r8168 and the r8169 from the Realtek website.

      But with the r8168 I could not bring eth1 up.

      With the r8169 I ran into problems: The Realtek driver's Makefile is not configured properly. I had to edit the paths in the Makefile manually.
      Finally compiled the r8169 and installed it. Still no WOL. Though I am not sure, wether I really have installed the new version, I could not tell the difference in the output of "lsmod | grep r8169". How can I verify, that I use my compiled driver and not the on built in?

      Furthermore I could not login to the webui. After entering username an password, the login site simply reloaded.
      After several attempts, I could finally log in.

      Essentially I am back at square one. Any suggestions?

      P.S.: Sorry for editing this post so often, it's 2am here in Germany.

      The post was edited 4 times, last by ohsiris ().

    • Just checked with modinfo, I use the new driver.

      The MB is quite old, it got a Wake on PCI Card option in the BIOS and an optional WOL connector on the board. And as I said, I got WOL working with that NIC for a day without any problems just by enabling the Wake on PCI Card option, I just can't figure out why WOL's gone now.

      The NIC is PCI.
      The old NIC is onboard, but I disabled it in the BIOS before adding the new NIC.

      The post was edited 2 times, last by ohsiris ().

    • Yeah, the rootfs was nearly full. That's also why I reinstalled with a little more space for the rootfs.

      First thing I did was to activate WOL --> but it still didn't woke up.

      I am not sure which backport kernel to use. I am running Wheezy with Kernel 3.2. How should I backport?
    • Also i was reading your MB manual. If I understand correctly the wake on PCI only works from suspend to RAM. To enable the Wake on LAN from shutted down system you have to bridge the NIC to the WOL connector





      I think you need to enable your other card and use that one for WOL.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • WOL from S3 only is fine for me, the server will not be powered off completely anyway. I am testing WOL with STR the whole time without any success.

      I just installed the backport kernel (linux-image-3.16.0-0.bpo.4-586) according to this thread (Backports 3.16 Kernel missing?).

      WOL still not working. Got some warnings while installing the Kernel:
      ​W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
      W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169


      I didn't try the onboard NIC by now, will do that tomorrow. Taking a break now from this frustrating stuff.
    • That's the firmware bundle for realtek firmware. Try apt-get install firmware-realtek. Is probably missing the backport one, so if the first one claims that is installed you can try then apt-get -t wheezy-backports install realtek-firmware

      ohsiris wrote:

      WOL from S3 only is fine for me, the server will not be powered off completely anyway. I am testing WOL with STR the whole time without any success.


      S3 is STR (suspend to RAM or sleep, many names),

      you meant hibernation or shutdown ?
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Your card is working. I've already pointed you why is not gonna work with wol from shutdown.
      You told me wol works from STR. And that's normal according to your mb manual from pci nic. You need the cable conector to work from shutdown
      The nics that are usually fully supported are the Intel ones. But in this case that's gonna be the same.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server