openmediavault-domoticz plugin (TESTING v1.0.1)

    • OMV 1.0
    • bewo wrote:

      But it's not recognized by OMV or/and the systemd correctly. There's a red indicator in dashboard. And the service is inactive:
      I will have to look at it. I don't use domoticz myself so I may not be able to fix some things.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • bewo wrote:

      Since the last Domoticz-Stable-Update from 3.5877 to 3.8153 (released 30.07.17) Domoticz works without probl
      I just updated the domoticz package in the omv-extras repo and it works. You should install this to get the latest systemd unit file.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!

      The post was edited 1 time, last by ryecoaaron ().

    • PERFECT!!! Everything works fine again! Thank's a lot!! :) :thumbsup: :thumbup:


      EDIT:

      No, it doesn't.... There was shown no update in OMV. So i deinstalled the Domoticz-Plugin and installed new.
      Then it works - BUT the Domoticz-Version ist the old one 3.5877. Then i've done a domoticz-update to 3.8153 and it's the same problem.......

      Can you post the new systemd-file manually here? :)

      The post was edited 1 time, last by bewo ().

    • bewo wrote:

      domoticz-update
      I wouldn't do this. The plugin may not work with the changes.

      bewo wrote:

      Can you post the new systemd-file manually here?
      I could but that is avoiding the problem. Lets try to fix it the right way first. The testing repo in omv-extras needs to be enabled. What is the output of: apt-cache policy domoticz
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      What is the output of: apt-cache policy domoticz

      Source Code

      1. domoticz:
      2. Installiert: 3.5877
      3. Installationskandidat: 3.5877
      4. Versionstabelle:
      5. *** 3.5877 0
      6. 500 https://dl.bintray.com/openmediavault-plugin-developers/erasmus-testing/ jessie/main amd64 Packages
      7. 100 /var/lib/dpkg/status
      The new domoticz stable version isn't recognised here...

      The post was edited 1 time, last by bewo ().

    • Done. Exactly the same...

      Source Code

      1. ...
      2. Get:65 http://ftp.de.debian.org jessie/non-free Translation-en [72.1 kB]
      3. Fetched 22.0 MB in 6s (3353 kB/s)
      4. Reading package lists... Done
      5. 8. Saving current package list...
      6. root@OMV-Server:/opt/domoticz# apt-cache policy domoticz
      7. domoticz:
      8. Installiert: 3.5877
      9. Installationskandidat: 3.5877
      10. Versionstabelle:
      11. *** 3.5877 0
      12. 500 https://dl.bintray.com/openmediavault-plugin-developers/erasmus-testing/ jessie/main amd64 Packages
      13. 100 /var/lib/dpkg/status
      Display All
    • bewo wrote:

      Done. Exactly the same...
      Sorry, I forgot to upload the amd64 package. I only uploaded the armhf version. Fixed now.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Nice tot see ryecoaaron
      I am still using domoticZ.
      By now on a raspberry but i have plans to setup a second one on omv

      Verstuurd vanaf mijn XT1562 met Tapatalk
      ---------------------------------------------
      My HP T610 thin client NAS
      ---------------------------------------------
      ---------------------------------------------
      My Thin Client single drive NAS build
      ---------------------------------------------
      -----------------------------------------------------
      I'm from the Netherlands, excuse me for bad english
      -----------------------------------------------------------------
    • Hello,

      I installed the pluggin after update to OMV 3.1.8.

      After enabling the pluggin, I get the error :
      "Failed to connect to socket: Connection refused", and I can't enter the GUI.

      Any clue what is going on ?

      Here is the detailed error :


      Display Spoiler
      Erreur #0:

      exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: Connection refused' in /usr/share/php/openmediavault/rpc/rpc.inc:140
      Stack trace:
      #0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
      #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
      #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
      #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
      #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      #6 {main}




      Thanks for your help !!!!
    • I downloaded the file with link on first page of this thread.
      I loaded it into omv, and installed.
      I enabled Domoticz service.

      => from then omv does what's described above.

      Everything seems to works apart from GUI login (any user including admin) => Samba service is OK, Plex server is OK ...
    • Hello,

      I took some time to look into this.

      So I see there is an issue with domoticz install as the command omv-engined -f -dreturns this in the end :
      PHP Fatal error: require_once(): Failed opening required 'openmediavault/error.inc' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/openmediavault/engined/rpc/domoticz.inc on line 23


      But then... I can only face my ignorance. What can I do with this ?

      can you guys help me find a link to a similar problem in order to sort me out ?

      Thanks.
      G
    • Sounds like you have a mismatched version of OMV and the plugin. What is the output of: dpkg -l | grep openm
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hello, thank you for your help.

      The output is :

      Source Code

      1. ii openmediavault 3.0.98 all Open network attached storage solution
      2. ii openmediavault-domoticz 1.0.1 all Domoticz plugin for OpenMediaVault.
      3. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      4. ii openmediavault-omvextrasorg 3.4.29 all OMV-Extras.org Package Repositories for OpenMediaVault
      5. ii openmediavault-plexmediaserver 3.8.2 all OpenMediaVault Plex Media Server plugin
    • That is definitely the problem. You have a very old version of the plugin. Not even sure where you got it. I would uninstall it with apt-get purge openmediavault-domoticz then enable the omv-extras testing repo. Then you should be able to install the 3.0 version from the repo.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • That did the trick.

      Thanks.

      I actually thought the link in the first post of this thread was kept up to date to the last version of the pluggin.

      This is what I used to install it.

      I did not install the last revision from the extras repo yet, since I installed Domoticz on a Raspberry I had available in the meantime. However, I regained access to my omv web interface.

      Not sure what will be my next move, yet.

      Thanks a lot.

      G.