My Thecus N5200 NAS

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • My Thecus N5200 NAS

      Just wanted to let people know that the old Thecus N5200 5-drive NAS ( not the Pro or XXX version, the original N5200 ) seems to be pretty happy running with OpenMediaVault v1.10. It's a little more involved to get it all running since you have to open the unit up and swap parts and add headers to the motherboard. But it's a really nice little box that I am glad I could get working again. It has an eSATA port, a couple USB 2.0 ports and two gigabit Ethernet ports. The CPU is a Celeron M 600MHz box, so it's not powerful exactly. But it does make it x86 32-bit compatible. Score! If it had been able to do 64-bit that would have been great, but it's too old for that. Now it's running 5x 2TB hard drives in RAID 5 happily. Thanks OpenMediaVault people/community!

      I had two of them to get working again after some drive failures meant that I had to change the hard drives to new ones that have 4K sectors as you can't get the older 512-byte sector models it seems. The old Thecus software started choking regularly on the new hard drives and just wasn't stable any longer. So I started doing some research on replacing the whole NAS that now seemed to be useless. That's how I found OMV. After watching a few YouTube videos I decided to update the OS to something modern that can handle 4K sectors and was still being developed.



      Step 1 - Open the case up and swap the RAM. It came with 256MB of RAM, but I had some spare older DDR2 1GB sticks from an upgrade I did a year or two ago on a desktop.

      Step 2 - Order a new DOM module. The unit had a 128MB DOM unit on it's 44-pin IDE port, but that's just not sufficient if I want to use this thing in the future. After much careful searching I found a good price on an 8GB DOM module. The module in the N5200 was a horizontal DOM, but the case gave me plenty of room to order a vertical DOM unit which was cheaper. DOM modules as I found out are typically used in industrial systems, so they tend to be hard to find and somewhat pricey. I found some 8GB commercial grade DOM modules that were half the price and in Canada already, so no customs charges (win!) to order them. Only problem was I had to wait 5 weeks before I got them <sigh>. I'll link to them below so no one has to try and scour the Internet for them like I did.

      memorydepot.com/ssd/listcat.html?catid=innolite-ide44

      Step 3 - The N5200 has the place on it's motherboard for a VGA header, Thecus just never installed one on the box to save themselves $0.25 each. As improbable as it sounds, no one has loose VGA headers any longer. It's probably only the most popular video interface in the world for the last 20 years. After much searching locally, I had to order them on-line. It works, but it's not a good fit with the case, so I use an alligator clip to hold the VGA header on to the motherboard long enough to do the installation of OMV then remove it. I'll have to try ordering a slightly different header to see if I can get one that I can one that I can permanently soldier on to the motherboard.

      digikey.ca/product-detail/en/1-1734344-2/A114810-ND/1891556

      Step 4 - Now that I have video working, I use the built-in USB ports to connect a USB keyboard. It has a stock standard AMI type BIOS, so just hit "Del" when it starts up and you get in to BIOS. Go in to the boot settings and set it up to boot from USB CD-ROM first and then the DOM drive. I tried to boot from USB sticks, but the BIOS seems too old to understand how and it always fails. Fortunately I had a old USB CD-ROM drive I could hook-up to it and burned a copy of OMV on to CD to install from. And it works! Went through the setup and about 20 minutes later I was booting in to OMV.

      Of course being a newbie I screwed it up a couple of times. But that's what learning is all about. I can clock it at about 50MB/sec which is 2x as fast as it ever was under the stock software from Thecus. Once I figure it all out I rebuilt the second N5200 I had as well.

      :thumbsup: