[Solved] OpenMediaVault-webgui disapeared

    • Resolved
    • [Solved] OpenMediaVault-webgui disapeared

      Dear all,

      Further to the copy of a 500 GB backup through usb 3.0 external drive, I noticed a huge sollicitation of my processor (as far as I remember, there were 70 to 80% of my processor used by a "user process"). Then I decided to reboot my server thanks to the top right menu in the web-gui interface.
      After it, I could'nt reconnect to web GUI despite my Transmission GUI was working and ssh acces too.
      When I try to connect to [OMV.server.IP]:80 I have the following page :
      It works!
      This is the default web page for this server.
      The web server software is running but no content has been added, yet.

      When I try to connect to [OMV.server.IP]:443 I have a page saying that the connexion failed

      I connected to a root console and send the following command :

      Source Code

      1. # omv-firstaid
      and reseted the https only acces I created to acces my server but nothing was working.

      No improvement

      I noticed that there were only "000-default" file in /etc/apache2/sites-enabeled but no openmediavault-wegui, neither in "sites-available" folder

      I uninstalled apache2

      Source Code

      1. # apt-get remove --purge apache2*


      and reinstalled it

      Source Code

      1. # apt-get install apache2


      But I still face the same problem and can't find a solution.
      If someone could help me, I would be glad !

      Thanks in advance.
    • Thanks tekkbb for your reactivity, I tryed both of these commands the second returned :

      Source Code

      1. root@OpenMediaVault:~# service nginx start
      2. Starting nginx: nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
      3. nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
      4. nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
      5. nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
      6. nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
      7. nginx: [emerg] still could not bind()
      8. nginx.
      9. root@OpenMediaVault:~#


      Unfortunately I still have the same issue to connect trough web-GUI
    • As far as I understood I was investigating thanks to older posts edited when apache2 was used as web server instead of nginx. I think the message I got is the one from apache2 replying on port 80 instead of nginx. Can-I remove apache2 (I also use OwnCloud) ?
      Oh and by the way, I didn't activate ipv6 at any time, how the hell can it be possible that it gets mentionned in this result ?
      Thanks for your time.
    • Yep it seems that apache2 is still listening to the port 80 on your ipv6 address.

      You can verify if the ipv6 support is enabled by editing the file /etc/sysctl.conf :

      Source Code

      1. vi /etc/sysctl.conf


      Search for the following lines and change to 1 if you want to disable it :

      Source Code

      1. net.ipv6.conf.all.disable_ipv6=1
      2. net.ipv6.conf.default.disable_ipv6=1
      3. net.ipv6.conf.lo.disable_ipv6=1


      Restart your network connection :

      Source Code

      1. /etc/init.d/networking restart


      After that try to remove again apache2 with the commands given by @tekkb
      Cheers
      - ASROCK FM2A88X-ITX+ (SATAIII (6Gb/s) x6 (for the DATA), mSATA x1 (for the OS) ==> maybe the only afordable motherboard with 6xSATAIII ports)
      - AMD A6 7400K 3.5GHz (overpowerful for NAS but the cheapest for this motherboard)
      - Corsair 2Go DDR3 1333MHz C9 (x2)
      - INTEL GIGABIT CT DESKTOP ADAPTER SINGLE PORT RJ45 PCIE (to avoid backports problems with network controller)
      - COOLER MASTER G450M (80+ bronze)
      - WD Red 2To 64Mo 3.5" SATAIII (6Gb/s) (x4 for the DATA, 2 SATA ports left for future use)
      - 32 Go SSD mSATA KingSpec Half-Size Solid State (for the OS which allows 6 SATA HDDs)
      - Fractal Design Node 304 black (HDD 3.5" x6)
      - RAID 5 xfs
      - OMV 1.12 (Kralizec) - 3.16.0-0.bpo.4-amd64
    • I prefer to post the content of my systctl.com before doing anythig as it is all starting by # (comment ?)

      Source Code

      1. #
      2. # /etc/sysctl.conf - Configuration file for setting system variables
      3. # See /etc/sysctl.d/ for additonal system variables
      4. # See sysctl.conf (5) for information.
      5. #
      6. #kernel.domainname = example.com
      7. # Uncomment the following to stop low-level messages on console
      8. #kernel.printk = 3 4 1 3
      9. ##############################################################3
      10. # Functions previously found in netbase
      11. #
      12. # Uncomment the next two lines to enable Spoof protection (reverse-path filter)
      13. # Turn on Source Address Verification in all interfaces to
      14. # prevent some spoofing attacks
      15. #net.ipv4.conf.default.rp_filter=1
      16. #net.ipv4.conf.all.rp_filter=1
      17. # Uncomment the next line to enable TCP/IP SYN cookies
      18. # See http://lwn.net/Articles/277146/
      19. # Note: This may impact IPv6 TCP sessions too
      20. #net.ipv4.tcp_syncookies=1
      21. # Uncomment the next line to enable packet forwarding for IPv4
      22. #net.ipv4.ip_forward=1
      23. # Uncomment the next line to enable packet forwarding for IPv6
      24. # Enabling this option disables Stateless Address Autoconfiguration
      25. # based on Router Advertisements for this host
      26. #net.ipv6.conf.all.forwarding=1
      27. ###################################################################
      28. # Additional settings - these settings can improve the network
      29. # security of the host and prevent against some network attacks
      30. # including spoofing attacks and man in the middle attacks through
      31. # redirection. Some network environments, however, require that these
      32. # settings are disabled so review and enable them as needed.
      33. #
      34. # Do not accept ICMP redirects (prevent MITM attacks)
      35. #net.ipv4.conf.all.accept_redirects = 0
      36. #net.ipv6.conf.all.accept_redirects = 0
      37. # _or_
      38. # Accept ICMP redirects only for gateways listed in our default
      39. # gateway list (enabled by default)
      40. # net.ipv4.conf.all.secure_redirects = 1
      41. #
      42. # Do not send ICMP redirects (we are not a router)
      43. #net.ipv4.conf.all.send_redirects = 0
      44. #
      45. # Do not accept IP source route packets (we are not a router)
      46. #net.ipv4.conf.all.accept_source_route = 0
      47. #net.ipv6.conf.all.accept_source_route = 0
      48. #
      49. # Log Martian Packets
      50. #net.ipv4.conf.all.log_martians = 1
      51. #
      Display All
    • I followed your instructions tekkb,

      Source Code

      1. root@OpenMediaVault:~# service apache2 stop
      2. Stopping web server: apache2 ... waiting .
      3. root@OpenMediaVault:~# update-rc.d -f apache2 remove
      4. update-rc.d: using dependency based boot sequencing
      5. root@OpenMediaVault:~# service nginx restart
      6. Restarting nginx: nginx.
      7. root@OpenMediaVault:~#


      Then I typed :

      Source Code

      1. root@OpenMediaVault:~# omv-firstaid
      2. Updating web administration settings. Please wait ...
      3. root@OpenMediaVault:~#

      To change the default web interface to 80 but still faced the same page ("It works ! ..."). For now I reconfigured webgui access on port 81 but am still looking for a solution if you have other ideas / suggestions.

      Many thanks to both of you for your help.
    • My mistake !
      You're right !

      Source Code

      1. root@OpenMediaVault:~# service apache2 status
      2. Apache2 is NOT running.
      3. root@OpenMediaVault:~#

      I didn't try to access it from an other device. But just accessed from my phone after reconfiguring webgui on prot 80 thanks to omv-firstaid. I purged the cache of my browser and it's now functionning. I'm ashamed of this mistake of mine :cursing: .

      Thanks a lot guys for the solution, I'll pass the post on solved after writing a shor summary for the next readers. Have you got an idea of how it occured ?
      Thanks again !
    • Tip : use private window on Chrome or Firefox, it's quicker and more comfortable than your phone ^^
      - ASROCK FM2A88X-ITX+ (SATAIII (6Gb/s) x6 (for the DATA), mSATA x1 (for the OS) ==> maybe the only afordable motherboard with 6xSATAIII ports)
      - AMD A6 7400K 3.5GHz (overpowerful for NAS but the cheapest for this motherboard)
      - Corsair 2Go DDR3 1333MHz C9 (x2)
      - INTEL GIGABIT CT DESKTOP ADAPTER SINGLE PORT RJ45 PCIE (to avoid backports problems with network controller)
      - COOLER MASTER G450M (80+ bronze)
      - WD Red 2To 64Mo 3.5" SATAIII (6Gb/s) (x4 for the DATA, 2 SATA ports left for future use)
      - 32 Go SSD mSATA KingSpec Half-Size Solid State (for the OS which allows 6 SATA HDDs)
      - Fractal Design Node 304 black (HDD 3.5" x6)
      - RAID 5 xfs
      - OMV 1.12 (Kralizec) - 3.16.0-0.bpo.4-amd64
    • Here might be the solution you're looking for (well, at least it worked for me ...)
      My problem was due to aa apache service running in parallel of nginx and listening port 80 instead of nginx. The message "It works ! ..." was a default message from apache.

      I ran the following commands to stop apache and avoid its restart :

      Source Code

      1. service apache2 stop
      2. update-rc.d -f apache2 remove
      3. service nginx restart


      Then you got to purge the cache as I faced a non refresh of the page I was looking for on port 80 in my browser.

      Thanks a lot tekkb and tiste for your help !
    • I had a similar issue of no gui after upgrading to 1.12. Shares and ssh worked, it looked like just the webgui wasn't working.

      I tried all the steps above and from other threads where people had a similar issue but no cigar.

      apache was running so I did the above to remove apache but still no gui, but not only no gui no website at all, connection refused.

      nginx was running but the above netstat command didn't have any output.

      omv-firstaid, reinstalling omv and nginx didn't help.

      I did some googling on nginx and found that the dir /etc/nginx/sites-enabled was empty. I linked /etc/nginx/sites-available/openmediavault-webgui to /etc/nginx/sites-enabled/ and the gui worked.

      hopefully this helps someone with a similar issue.
    • tekkb wrote:

      service apache2 stop
      update-rc.d -f apache2 remove
      service nginx restart

      Apache should not be running. This stops it and removes the run levels so it will not start.


      This is what did the trick for me, awesome, thank you !!

      what I did was erase an HDD using the non installed ubuntu and then gparted on it and after trying to run OMW again, it would only show that website thing and that it works..
      Typing your commands was the quick solution !!
      THANK YOU