View hidden files in user home directories

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • View hidden files in user home directories

      I have enabled the option "Enable user home directories" which works fine however I need to stop samba from hiding or setting the hidden attribute for dot files within these user shares.

      I have added hide dot files = no to "Extra options" under "General settings" which I thought should have set this as the default however this is not the case.

      smb.conf extract

      comment = Home directories
      browseable = no
      writable = yes
      create mask = 0640
      directory mask = 0750
      valid users = %S

      Does anyone know how i can solve this within OMV 1.11?
    • Isn't that something you enable/disable in the client (windows, mac, linux)?

      In my Fedora Linux (thunar) i press CTRL+H and it displays all hidden files. In windows show hidden files the same.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server

      The post was edited 1 time, last by subzero79 ().

    • Correct subzero79, enabling "show hidden files, folders or drives" from within windows explorer does show the files however other programs/scrips may still have issues.

      I have enabled this option on the client machines now but was hoping to avoid future issues by disabling the hidden attribute. Disabling hidden files works just fine for regular smb shares.
    • Tekkb, the windows machines have some folders/files with leading "dots" which are then marked as hidden by Samba when saving.

      Anyhow I was mistaken Samba and OMV are working fine. The issue I think was client side caching. Restarting the windows machine fixed it.

      It would be nice to selectively enable and disable "hide dot files" for [homes] shares instead of globally. Not an issue for my use case though.