OMV hangs after reboot

    • OMV hangs after reboot

      Hi,

      I have a problem with my NAS and I think it is related with my motherboard (Asrock Q1900-ITX). My config is 3 OS (W8 + Debian/OMV + Mint). I boot all using rEFInd.

      If I try to shutdown OMV (GUI, SSH or direct), it works. No problem with this. But if I try to reboot, computer shuts down well (OMV GUI shows an error message 'An error has ocurred' but in the NAS screen the process continue.), I show Asrock logo in the screen, rEFInd+Grub and when the system should start to load, a black screen appears. No cursor, no text, nothing.

      I have the same problem with Mint, buy I solved it adding 'reboot=pci' on my loader config. But with Debian, nothing works.

      Anybody with same problem or with same motherboard without this problem?

      Thanks!
    • Every now and then a User experiences this. But we're unable to identify the root cause of that problem. I suspect it may go away with Debian Jessie, but only time will tell that.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Hello Emerge and Sylvania - Got the same board and HAD the same problem. Seems like I found the solution a few minutes ago and I wanna share it with you. Luckily I found your thread by clicking randomly through the forums.
      Probably the solution:
      Flashing cursor when rebooting / Blackscreen
      Works for now without any issues!

      I can't confirm if it will work with the openmediavault-installer. For now I have installed Debian Wheezy 7.8 64 bit with OMV as installed package.
      OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
      ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

      The post was edited 1 time, last by Nyctophilia ().

    • I'm also using an Q1900 board and for me "kbd" worked.
      Normally kbd should be standard but without changing it doesn't work.
      Just changed it two days ago and no more problems.
      Login via SSh:
      • nano /etc/default/grub
      • changed GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="reboot=kbd"
      • Save, update-grub
      • reboot



      Display Spoiler

      warm = Don’t set the cold reboot flag
      cold = Set the cold reboot flag
      bios = Reboot by jumping through the BIOS (only for X86_32)
      smp = Reboot by executing reset on BSP or other CPU (only for X86_32)
      triple = Force a triple fault (init)
      kbd = Use the keyboard controller. cold reset (default)
      acpi = Use the RESET_REG in the FADT
      efi = Use efi reset_system runtime service
      pci = Use the so-called “PCI reset register”, CF9
      force = Avoid anything that could hang.