Owncloud 8 and MySQL: alternative approach

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • i have test the manuel, but i cant activate plugins.
      on the admin page i see an error

      Source Code

      1. Error core Die Applikation enthält keine info,xml Datei
      2. Error PHP copy([url]http://apps.owncloud.com/CONTENT/content-files/168707-calendar.zip):failed[/url] to open stream: HTTP request failed! at /media/uuid/testcloud/owncloud/lib/private/installer.php#244

      omv 4.0.19 | 64 bit | omvextrasorg 4.1.2 | kernel 4.14
      used plugins: nginx | mysql | docker-gui |rsnapshot | antivirus | apt tool | letsEncrypt |
      used other: netxtcloud | logitechmediaserver | emby
    • I have follow the guide on 1st page, to install owncloud 8 with ngnix and mysql plugin.
      And it works !!! Nice work !

      I think you (or an admin) move this guide to Forum->Guide.
      Maybe rename the title to "Owncloud 8 with Nginx and MySQL plugin : alternative approach"
      I am not sure for that ...
      Open Media Vault 2.2.6 (Stone burner) in Prod
      Open Media Vault 3.0.32 (Erasmus) in Test

      openmedivault Docker Container
      https://github.com/prbond/openmedivault-dockerfile

      Dev :
      openmediavault-fail2ban 1.1.5 for OMV2.X
      openmediavault-fail2ban 1.3.0 for OMV3.X
      https://github.com/prbond/openmediavault-fail2ban
      https://github.com/OpenMediaVault-Plugin-Developers/openmediavault-fail2ban
    • Thank you! Mine is up and running beautifully!

      ************************

      Spoke too soon. I'm mostly up and running, with the the exception of being able to use it outside of my network.
      I have the server name set to sockmonster.asuscomm.com/owncloud (ddns) on port 90 and port forwarding is sending requests to port 90 to omv's IP address. (while trying to make this work, I inadvertently made the omv admin ui accessible from outside - Bonus!)

      When trying to go to sockmonster.asuscomm.com/owncloud:90, sockmonster.asuscomm.com/owncloud or sockmonster.asuscomm.com:90 I get this message:

      You are accessing the server from an untrusted domain.Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domain" setting in config/config.php. An example configuration is provided in config/config.sample.php.
      Depending on your configuration, as an administrator you might also be able to use the button below to trust this domain.

      Add "sockmonster.asuscomm.com/owncloud" as trusted domain <--
      This is a link I can click on. If I click it I get 404 Not Found nginx.

      I googled around and found out how to add the trusted domain to owncloud's config.php, however that didn't help. I continue to get the same 404.

      Interestingly if I use 192.168.xx.xx:90 I can access it just fine behind the router.

      The trusted domains statement in config.php is:
      'trusted_domains' =>
      array (
      0 => '192.168.1.49','sockmonster.asuscomm.com/owncloud'
      ),


      Any help is much appreciated!


      edited to add that I have dumped my browser's temp files and tried other browsers as well - same results.

      The post was edited 2 times, last by amyb ().

    • Forgot about the cert. It was created with the cn being the ip. I created a new one with omv, 4096b key size, period of validity 1 week for testing, cn sockmonster.asuscomm.com and ignored the other options

      I applied that to the owncloud server, then rebooted.

      Still getting the 404 error. ?(

      I wonder if I should ditch this install option and go with the plug in instead
    • amyb wrote:

      When trying to go to sockmonster.asuscomm.com/owncloud:90, sockmonster.asuscomm.com/owncloud or sockmonster.asuscomm.com:90 I get this message:


      Presuming you are running OC with https on port 90 and a port based nginx config.

      Just checked that in my virtualbox:
      When starting, I had the same behaviour like you.
      After adding this line in config.php "trusted_domains"
      1 => 'mydyndnsname.myddnsprovider.de'
      everything worked fine.
    • As this is a standard way to install OC on hosted web servers, it should be reliable.

      From OC website:
      The Web Installer is the easiest way to install
      ownCloud on a web space. It checks the dependencies, downloads the
      newest ownCloud from the official server, unpacks it with the right
      permissions and the right user account. Finally, you will be redirected
      to the ownCloud installer.


      The disadvantage is mentioned in Post#1
      Perhaps the file-permissons of nginx (ACL vs permissons) could be handled in another way, not sure about that.
      On my home installation it runs without issues.
    • Hi,

      openmedianer wrote:

      wo speichert Owncloud die Daten ab?


      in your OC-folder, which is created during your installation:
      In this example it would be /media/75826092357891275151789/www/owncloud/data/.

      openmedianer wrote:

      Kann ich die Benutzerverwaltung von OpenMediaVault vollständig, auch mit Owncloud 8 weiter verwenden?


      No, the OC users are not syncronized to the OMV users.
      Perhaps there is a trick but I don't know it.

      The post was edited 1 time, last by Enra ().

    • openmedianer wrote:

      Than i don t nee Openmediavault.

      If you only want to use OC, your correct.
      But OMV is a lot more than this.

      openmedianer wrote:

      Or i must use the Owncloud Pugin (old Owncloud) from OpenMediaVault 1.17.

      Feel free to give it a try.

      Don't forget:
      You won't get an out-of-the-box eierlegende-wollmilchsau here.
      You'll have to check your needs against the "standard" OMV.
      If something is missing, there are mostly individual ways to implement it.