ZFS zPool not being created

    • OMV 1.0
    • ZFS zPool not being created

      Hi,

      I'd like to switch form freenas to openmediavault and I wanted to test the zfs funcitonality right now.
      I found that zpool creation seems to take quite some time is that true?
      I wanted to create a raid-z1 out of 4x3TB hard drives.
      Just started the creation process and when I look into htop on the terminal I don't see any processes that could be creating something.
      However nothing appears in the web gui as well.
      Am I missing something here?

      *edit*
      Hardware:
      HP Proliant N54L
      4x3TB Seagate desktop 7,2k drives
      System drive is a 30 GB kingston sata ssd
      openmediavault is almost a clean install, no other plugins installed previously no other volumes created except the ones on the system drive

      I just checked zpool events
      Besides this from two hours ago, there is nothing shown.
      resource.fs.zfs.statechange
      resource.fs.zfs.statechange
      resource.fs.zfs.statechange
      resource.fs.zfs.statechange
      ereport.fs.zfs.config.sync
      ereport.fs.zfs.zpool.destroy
      ereport.fs.zfs.config.sync

      There is also no significant load on the system. CPU is between 0 and 1 % load all the time and the HDD led is blinking very rarely.

      *edit2*
      I just checked syslog:
      There are 3 significant entries to the topic.
      It says:
      openmediavault zed: eid=5 class=config.sync pool=Main
      openmediavault zed: eid=6 class=zpool.destroy pool=Main
      openmediavault zed: eid=7 class=config.sync pool=Main

      any idea why this is happening?
      I also tried to create the zpool using force option but same result here...
      I also have to reboot openmediavault and wipe the disks to add them to a new zpool again after another failed attempt. Otherwise they won't show up in the selection list.

      *edit3*
      I gave ZFS another go, I plugged 4x 8GB USB flashdrives in and created a zpool out of them, worked perfectly...
      So where could be the problem with my 4x 3TB HDDs? Any Ideas?

      The post was edited 5 times, last by audiocrush ().

    • Hey, I know this post is over one year old. Sorry for the resurrection.

      Did you ever get it to work with your hardware? I have (essentially) the same hardware, a HP N40L Microserver with 10GB of RAM, and 4x3TB WD 7200 HDDs, running the current stable OMV (2.1 AMD 64) from a 8GB Kingston

      When I go through the steps to create the pool, nothing happens. I thought that maybe I was being impatient, but even leaving it over night, nothing appeared to have happened. I don't have a collection of USB sticks to try it with, so I can't replicate what you did by creating another pool with different hardware.
    • OK, so I don't know if it's relevant, but I was running the OS from a thumb drive. In the searching for the answers to my problems, I learnt that running it from a flash drive was bad, so I enabled the fs2ram.

      After editing the fstab, enabling the plugin and restarting the device, the next pool I created worked. I also didn't use any numeric values in the pool name this time (I was trying to use 12TB-POOL, and this time I just used POOL) so not sure if that too is relevant.