GRUB only on /dev/sda ?

    • OMV 1.0
    • GRUB only on /dev/sda ?

      Installed OMV 1.9 from CD last night. GRUB failed to install. Here are my disks:

      /dev/sda Data disk 1, 4TB HD
      /dev/sdb Data disk 2, 4TB HD
      /dev/sdc Boot disk, 64GB SSD

      GRUB was trying to install to /dev/sda even though in previous steps I had selected /dev/sdc as the disk I wanted to install too / boot from.

      I tried running disk detect again, still GRUB only wanted /dev/sda

      For kicks I ran the LILO step, it listed all 3 drives for me to choose to install to. I wanted GRUB so I aborted LILO.

      I solved the problem by powering down, unplugging the 2 data disks, powering up and doing the install. With only the SSD available, GRUB installed fine. After install I powered down again, plugged in the data HDs and set them up for data storage.

      It would be nice if GRUB installed to the disk already selected as the boot disk, or allowed the user to choose the disk to install to.
    • It is recommended in the wiki (and forum) to do exactly what you did - unplug all data disks - when installing OMV. The only reason you see the menu is for when you are installing from a usb stick and Debian thinks the usb stick is a potential candidate for installation.
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!