Can't get Deluge to install

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't get Deluge to install

      Hey folks. Hoping to find a bit of help here. I am trying to install Deluge via the CLI and when I run

      Source Code

      1. apt-get install -t precise deluge-common deluged deluge-web deluge-console


      I get this

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. Some packages could not be installed. This may mean that you have
      5. requested an impossible situation or if you are using the unstable
      6. distribution that some required packages have not yet been created
      7. or been moved out of Incoming.
      8. The following information may help to resolve the situation:
      9. The following packages have unmet dependencies:
      10. deluged : Depends: python-libtorrent (>= 0.14.9) but it is not going to be installed
      Display All


      I am eventually trying to end up with deluge installed and accessible via the thin-client from my Mac if that helps.

      Thanks folks
    • jhmiller wrote:

      Some private trackers do not work with the latest version (Install Deluge) so you have the option to install a version that is known to work.


      Thanks dude.

      Do you know if it's possible to get the thin-client to connect to the deluge install?

      I've tried to edit the auth file but keep getting a permission denied message. I still get the error if I sudo the command
    • It is possible as I am using in on my windows 8.1 box. I wanted to manage it from my PC and be able to rename files, which is what the thin client allows.

      I used nano from the command line (used the shellinabox plugin and logged in as root) to edit the auth file in the .config hidden directory for deluge and created a new user and password for the thin client.

      You have to make sure classic mode is disabled in the thin client (under interface). Under Daemon on the server (use the web ui) make sure allow remote connections is checked.

      When you go to add the connection in the connection manager from the thin client on your Mac, the address will be 192.168.X.X:58846 (unless you change the port, and obviously it's the IP address for your OMV box).

      I believe that's all I had to do to get it up and running. I had trouble initially because I tried to use the user and password already in the auth file... it wouldn't connect. Once I created a new user and password on top of the other one, it connected no problem. Works great.

      Let me know if that helped.
    • darcmanomv wrote:

      It is possible as I am using in on my windows 8.1 box. I wanted to manage it from my PC and be able to rename files, which is what the thin client allows.

      I used nano from the command line (used the shellinabox plugin and logged in as root) to edit the auth file in the .config hidden directory for deluge and created a new user and password for the thin client.

      You have to make sure classic mode is disabled in the thin client (under interface). Under Daemon on the server (use the web ui) make sure allow remote connections is checked.

      When you go to add the connection in the connection manager from the thin client on your Mac, the address will be 192.168.X.X:58846 (unless you change the port, and obviously it's the IP address for your OMV box).

      I believe that's all I had to do to get it up and running. I had trouble initially because I tried to use the user and password already in the auth file... it wouldn't connect. Once I created a new user and password on top of the other one, it connected no problem. Works great.

      Let me know if that helped.


      Hey thanks for the reply.

      Was your auth file already present? The auth file wasn't there so I had to create it and stick in the details.

      Can't seem to connect though and did everything else you said.
    • crofty83 wrote:

      darcmanomv wrote:

      It is possible as I am using in on my windows 8.1 box. I wanted to manage it from my PC and be able to rename files, which is what the thin client allows.

      I used nano from the command line (used the shellinabox plugin and logged in as root) to edit the auth file in the .config hidden directory for deluge and created a new user and password for the thin client.

      You have to make sure classic mode is disabled in the thin client (under interface). Under Daemon on the server (use the web ui) make sure allow remote connections is checked.

      When you go to add the connection in the connection manager from the thin client on your Mac, the address will be 192.168.X.X:58846 (unless you change the port, and obviously it's the IP address for your OMV box).

      I believe that's all I had to do to get it up and running. I had trouble initially because I tried to use the user and password already in the auth file... it wouldn't connect. Once I created a new user and password on top of the other one, it connected no problem. Works great.

      Let me know if that helped.


      Hey thanks for the reply.

      Was your auth file already present? The auth file wasn't there so I had to create it and stick in the details.

      Can't seem to connect though and did everything else you said.


      The auth file has to be there as it has the credentials for when you login to the webui, so afaik it's automatically there. Mine was. Are you looking for it in the right place? It's in the hidden directory .config (I think). Unless someone else can jump in and tell you where it is, I'll look when I get home tonight and post instructions on where to look. I'm relatively certain that's what's keeping you from connecting. It didn't even show as available for my thin client until I added that second set of credentials. As soon as I did... magic. :)

      Darcy
    • crofty83 wrote:

      darcmanomv wrote:

      It is possible as I am using in on my windows 8.1 box. I wanted to manage it from my PC and be able to rename files, which is what the thin client allows.

      I used nano from the command line (used the shellinabox plugin and logged in as root) to edit the auth file in the .config hidden directory for deluge and created a new user and password for the thin client.

      You have to make sure classic mode is disabled in the thin client (under interface). Under Daemon on the server (use the web ui) make sure allow remote connections is checked.

      When you go to add the connection in the connection manager from the thin client on your Mac, the address will be 192.168.X.X:58846 (unless you change the port, and obviously it's the IP address for your OMV box).

      I believe that's all I had to do to get it up and running. I had trouble initially because I tried to use the user and password already in the auth file... it wouldn't connect. Once I created a new user and password on top of the other one, it connected no problem. Works great.

      Let me know if that helped.


      Hey thanks for the reply.

      Was your auth file already present? The auth file wasn't there so I had to create it and stick in the details.

      Can't seem to connect though and did everything else you said.


      Sorry I wasn't able to look for the information I promised last night.

      The auth file you need to edit and ADD the new credentials to is located in :
      /home/deluge-daemon/.config/deluge
      There will be an existing auth file there. I just used nano to edit ("nano auth") and added the username and password for the thin client. Don't get rid of the first one in the file.

      Good luck!
    • I know there were bugs with dependencies (if I remember correctly) when this plugin was first released, but they were all fixed. So I don't know if you've got a repo issue or not. Have you tried doing a refresh? I am not at home and can't remember where it is (plugins? update manager?). And then try installing the plugin again?

      Try doing apt-clean in the omv-extras section and see if that helps.

      The post was edited 1 time, last by darcmanomv ().

    • darcmanomv wrote:

      crofty83 wrote:

      darcmanomv wrote:

      It is possible as I am using in on my windows 8.1 box. I wanted to manage it from my PC and be able to rename files, which is what the thin client allows.

      I used nano from the command line (used the shellinabox plugin and logged in as root) to edit the auth file in the .config hidden directory for deluge and created a new user and password for the thin client.

      You have to make sure classic mode is disabled in the thin client (under interface). Under Daemon on the server (use the web ui) make sure allow remote connections is checked.

      When you go to add the connection in the connection manager from the thin client on your Mac, the address will be 192.168.X.X:58846 (unless you change the port, and obviously it's the IP address for your OMV box).

      I believe that's all I had to do to get it up and running. I had trouble initially because I tried to use the user and password already in the auth file... it wouldn't connect. Once I created a new user and password on top of the other one, it connected no problem. Works great.

      Let me know if that helped.


      Hey thanks for the reply.

      Was your auth file already present? The auth file wasn't there so I had to create it and stick in the details.

      Can't seem to connect though and did everything else you said.


      The auth file has to be there as it has the credentials for when you login to the webui, so afaik it's automatically there. Mine was. Are you looking for it in the right place? It's in the hidden directory .config (I think). Unless someone else can jump in and tell you where it is, I'll look when I get home tonight and post instructions on where to look. I'm relatively certain that's what's keeping you from connecting. It didn't even show as available for my thin client until I added that second set of credentials. As soon as I did... magic. :)

      Darcy


      Sorry for for the late update that was exactly the issue and it's all sorted and up and running now

      Thanks dude
    • Is Deluge still in the repo? I cant find it anywhere and i cany get it to install via the terminal (even though i can on a VM) something to do with packages not being installable as the first post said.

      My tracker requires deluge 1.3.11 or transmission 2.08 so at the moment i cant use OMV for its/my intended purpose. Any advice would be appreciated.
    • Unfortunately 1.5 isn't supported either.

      edit: Nevermind i can install 1.3.5, hopefully :)

      edit2: Nope i can install it but the Daemon wont start. The warning.log states there is no module called "libtorrent" which is related to the errors i got when installing manually.





      As you can see i have libboost installed albeit a higher version

      If i do a

      Source Code

      1. sudo apt-get dist-upgrade
      I get a list of what has been "kept back" and it also tells me Deluge will be upgraded, which i dont want.


      The post was edited 7 times, last by mcloum ().